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Sauna™ V5.60 Release Notes

Welcome to Version V5.60 of the Sauna thermal modeling package.

Getting started with Sauna V5.60

Please begin by reading “Sauna V5.60 New Features List” on the next page.

When you are ready to begin using Sauna V5.60, work through "Sauna V5.60 Tour", which
starts on page 6.  This exercise takes 1-2 hours to complete.

Who should install Sauna V5.60?

Everyone.  Sauna V5.60 includes many important new features and fixes several bugs.

Installation

To install or update Sauna, see the “Installation” chapter in the Sauna User Manual.  The
method is the same as for previous Sauna releases.
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Sauna V5.60 New Features List

Sauna thermal model incorporated within LTspice circuit

Why export a thermal model?

• Many electrical component properties are temperature-dependent

- resistance, including MOSFET Rds-on
- gain

- power dissipatoin

• Incorporating a thermal model in the Spice analysis provides for a much more accurate
simulation

• Unlock the value of a thermal model

- not just for checking survivability in a worst case situation

- include a thermal model when analyzing circuit performance and stability

• startup

• duty cycles

• voltage spikes

• thermal impacts everything



3

Sauna is the ideal tool for generating and exporting a thermal model

• Sauna is based on the intuitive thermal resistor and thermal capacitor method

• no need to be a thermal analysis expert, 50% of users are electrical engineers

• create models for heat sinks, boards and complete boxes

• handles natural and forced convection and provides sophisticated radiation analysis

• Sauna models are compact, so the circuit analysis is not strongly impacted by
additional complexity

Sauna export capability explained

• easy to use

- calculate temperatures within Sauna first, which initializes all the resistances

- export only takes a second or two

• can export a single thermal circuit or a library

• create library with different cooling configurations

- different component layouts

- natural vs. forced air cooling

- different heat sink sizes

- metal vs. plastic boxes

• component (heat source) options

- no limit on the number of heat sources

- do not have to model every heat source

- use distributed wattage to include heat load from non-critical components

• thermal model symbol is exported with thermal circuit (see figure on next page)

- SPICE schematic only shows a simple block symbol

- details of subcircuit are hidden

- only connection points are heat sources and ambients
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Thermal model symbol within LTspice

SPICE versions supported

• directly supports LTspice

- widely used industry standard

- free download from Analog Devices

• works with other SPICE versions as well, including PSPICE

- if not using LTspice, some user manipulation may be required, such as creating a
symbol for the thermal circuit

SPICE components

• need a SPICE model with thermal input/output

• models available from Infineon, On Semi, Analog Devices, more

• not available for all components, particularly older components

Gap resistor improvement

• can specify a special gap distance

• provides modeling flexibility

• can use for simplifying models for export



5

Room AmbRoom AmbRoom Amb

Room Amb

Room AmbRoom AmbRoom Amb

Room Amb

Before combining: 5 fixed nodes After combining: 1 fixed node

Easity combine ambients

New combine ambient feature

• when modeling, can somtimes create more ambients than necessary

• new feature makes it easy to combine multiple fixed node ambients into a single ambient

• reduces clutter, model is easier to understand

Other V5.6 enhancements

• capacitor symbol display

• many small refinements and bug fixes
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Sauna V5.60 Tour

Exporting Sauna models to LTspice®

In this section, you will export a Sauna thermal model to the LTspice simulation program.  The
LTspice software is a free program made available by Analog Devices, Inc.  LTspice is a
derivative of the SPICE software originally developed at the University of California, Berkeley
in the 1970's.  The name "LTspice" comes from the original creator, Linear Technology
Corporation.  Linear Technology was acquired by Analog Devices in 2015.  Analog Devices has
continued to support and enhance LTspice and it has become a widely used industry standard
tool.

LTspice can be downloaded here:

https://www.analog.com/en/resources/design-tools-and-calculators/LTspice-simulator.html

Sauna officially supports export to LTspice.  But these exported models can also be read by
other circuit simulation programs, such as PSpice®.

Thermal capacitance in a Sauna model

You will start by creating a simple 25 mm x 25 mm square plate model:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Planar Plate ➔ hit <Enter> to skip ➔ Rectangle
➔ Vertical XY ➔ "25,25,1" ➔ (0,0,0) ➔ Iron/Steel ➔ AISI 1010 ➔ Paint/White

The plate assembly will be created.  There are 4 nodes in the assembly.  Each of the node has an
associated thermal capacitance.  Capacitance has always been part of Sauna models, but prior to
Sauna V5.6, there was no way to actually show that the capacitance was present.  (This was
done to minimize draw times.)  But there are situations where it's nice to see an actual capacitor
symbol.  Activate symbols with:

<F6 Setup> ➔ Display ➔ Node ➔ Capacitance ➔ Show Symbol

Now the screen shows a capacitor symbol as well as the ground connection, as shown in
Figure 1 on the next page.  In thermal modeling, the network ground is the room ambient
temperature.
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capacitor symbol

X

Y

Figure 1: Node capacitor symbol

You can also display capacitance values:

Write Value

The screen now shows the capacitance of 0.56 W-sec/°C for each node, a useful feature.  Return
to the default display mode:

Off

Now you need to complete the simple model.  First add a transistor and align the mesh:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "2" ➔ "S1" ➔ TO-247 ➔ Typical
➔ Standard ➔ Greased ➔ Plate/Board ➔ One ➔ trap assembly edge ➔ Coords/Trap ➔ "12,20"

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source ➔ 4 Node Conn
➔ trap heat source ➔ All In Wind ➔ USE

Finally, add float resistors and an ambient node.  Then calculate temperatures:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Comp+Secdry ➔ All In Wind ➔ USE

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain TS1-Junct = 107.11°C.  Now you're ready to export.



8

Exploring export options

Begin the export process:

<F12 Root Menu> ➔ File ➔ Export ➔ Model ➔ LTspice

You will reach the LTspice menu:

   LTSPICE
 1 Subcirc/Symb
 2 Library
 3 Netlist

There's three basic options.  The simplest to use is "Subcirc/Symb", for "subcircuit/symbol", and
you will start with this option.  The "Library" option is also quite useful and you can use this to
export a series of thermal designs.  Finally, there is the "Netlist" option.  This option is awkward
to use, but does have the advanatage of being compatbile with just about any Spice software
variant.

Continue with:

Subcirc/Symb

Now you reach the Ht Src Capac (heat source capacitance) menu:

  HT SRC CAPAC
>1 Skip
 2 Include

You are probably a bit perplexed by this menu, but it's actually pretty simple.  Within Spice,
you will be connecting the Sauna thermal models to component models which already include
thermal capacitance.  So while the Sauna model does include capacitance for heat sources, you
don’t want to double-count this information.  Finish with:

Skip ➔ Screen

The exporting information will be displayed on the screen.  Of course, you would normally
export to a file (actually two files), but for learning it's useful to see the export contents on the
screen.

The first screen shows the beginning of the subcircuit definition.  The first non-comment line is
".subckt NEW_FILE S1_Tc room_amb".  This line provides a name for the subcircuit, as well as
the connection points (pins in the Spice model).  There are only two connection points, one for
the heat source and one for the ambient connection.  You can certainly have more than one heat
source, in which case there would be additional connection points.

After the subcircuit header line, you will see the line "Rth1 N1 N5 2.1108E+1".  This is the
definition for the first resistor.  Sauna automatically creates unique labels for each resistor and
each node, as required by Spice and the resistance value is 2.1108E+1°C/W.

Click the Next button to advance to the next screen.  Halfway down, there is a transition to the
capacitor definitions.  Click Next again, and you will reach the end of the subcircuit definition
with the line “.ends NEW_FILE”.
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Now click the Done button.  There will be one more screen.  This is the definition of the symbol
for the thermal circuit.  When you place the thermal model in the Spice schematic, you won't see
any nodes, resistors and capacitors.  Instead you will see a simple symbol with connection pins
for each heat source and another for the ambient.  See Figure 2 for an example:

Figure 2: Thermal model symbol in Spice

Click the Done button to clear the Info screen.

First export to Spice

The current model doesn't represent anything that you're likely to export, thus it's not a good
test case.  Delete the current model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

You will be exporting a model which is quite similar to the "new_sink.smf" model that is
created in the first introductory exercise.  Very possibly, you have this model readily available.
The model can also be found in the “C:\Program Files (x86)\Sauna Thermal Modeling
\Reference Models”folder.  Load the model now:

<F12 Root Menu> ➔ File ➔ Open ➔ select new_sink.smf ➔ click Open button

click  

You should see TS1-junct = 136.98°C.  The Rjc for the heat source is currently 0.60°C/W.  You will
change the thermal resistance to 0.55°C/W, which is the value for an Infineon IMW65R020M2H
CoolSiC MOSFET.  This is the device you will co-simulate in LTspice (see Figure 10 for details).
Make the change:

<F12 Root Menu> ➔ Edit ➔ Heat Input ➔ Basic Source ➔ R_junct_case
➔ trap heat source ➔ Specify ➔ ".55"
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Now recalculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

With this change, TS1-junct = 134.98°C and TS1-case = 112.98°C.  Next, you will save the model as
"spice_test.smf".  Be sure to save the model in an appropriate folder (not the Reference Models
folder).  Save the model now:

<F12 Root Menu> ➔ File ➔ Save As ➔ type "spice_test" in file name box ➔ click Save button

Now you are ready to export:

<F12 Root Menu> ➔ File ➔ Export ➔ Model ➔ LTspice ➔ Subcirc/Symb ➔ Skip ➔ File
➔ click Save button

Sauna will create two files, the subcircuit file (.subckt) and the symbol file (.asy).  You will see:

Successfully wrote "spice_test.subckt"
Successfully wrote "spice_test.asy"

You're ready to create a simple schematic in LTspice.

Building a simple schematic in LTspice

You will start by creating the simple schematic shown in Figure 3.  With this circuit, you will be
able to verify that LTspice and Sauna produce the same result.

Figure 3: First LTspice schematic

Start up LTspice.  You can leave Sauna open with the spice_test model (minimize to the Taskbar
if you wish).
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Begin with:

File ➔ New Schematic

In a moment, you will place the symbol for the Sauna subcircuit.  But you need to make sure
that the symbol is in the search path.  Click the Gear icon at the upper left, then click the Search Paths
tab.  The dialog box shows the default path and any additional paths in Symbol Search Paths.
You will probably want to add a new path so that LTspice can find your Sauna subcircuit.

If you are an experienced LTspice user, just go ahead and create the circuit shown in Figure 3.

Figure 4: Icons used to create schematic

If you are new to LTspice, or just out of practice, the checklist below will guide you.  Figure 4
show the icons that you will be using.  Create the schematic now:

1.  Click the Component icon (see Figure 4), then select spice_test on the list (scroll to the
right).  Click the Place button, then position the symbol at the center of the screen and click.
Hit <Esc> or right-click to stop placing additional copies.

2.  Use the scroll wheel on your mouse to zoom out.  To re-center the screen, hold down the
left mouse button and drag.

3.  Click the Voltage Source icon.  Then position the voltage source below the Sauna symbol
and click.  Hit <Esc> or right-click to stop placing.

4.  Right-click the voltage source and type in 25 for the DC value, then click the OK button.
For LTspice, temperature is represented as a voltage.

5.  Click the Component icon again.  Scroll to the left and select current, then click the Place
button.  Prior to final placement, use <Ctrl>-r to rotate the current source.  Then move to
the position shown in Figure 3 and click.  Hit <Esc> or right-click to stop placement.  For
LTspice, wattage is represented as an electrical current.

6.  Right-click the current source and type in 40 for DC value, then click the OK button.
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7.  Figure 3 shows 2 grounds.  Click the Ground icon and place the grounds in the
appropriate position.  When finished, hit <Esc> or right-click.

8.  Now that components and grounds are in place, you need to add wires.  Click the Wire
icon .  Then click on the appropriate pins and create the wires.  By default, LTspice draws on
the grid.  (For a diagonal connection, depress the <Ctrl> key while drawing between two
pins.)  When finished, hit <Esc> or right-click.

9.  Notice that the wire above the Sauna model is labeled with "T_case".  This is a net label.
Click the Label Net icon.  In the dialog box, type in T_case and click OK.  Then click the wire
to the right of the current source.  When finished, hit <Esc> or right-click.

10.  Finally, note that the letters ".op" are shown in the lower-left of Figure 3.  This is known
officially as a Spice directive but is generally referred to as a dot command (much easier to
say).  The .op command tells LTspice to perform a DC analysis (operating point), the
equivalent of a steady state thermal analysis.  Click the dot command icon and enter .op in
the box, then click OK.  Place the command in the appropriate location.

This is a good time to save the schematic.  Use the name "spice_test_simple":

File ➔ Save As ➔ “spice_test_simple”➔ click Save button

Running the first Spice simulation

Now you’re ready to simulate.  You just need to click the run icon shown in Figure 6.

Figure 5: Run icon

Click  now.

The simulation will be complete in about 1 second.  A text window will pop open with the
operating point (steady state) results.  Remember that voltage is analagous with temperature.  So
the window shows V(n001) of 25, which is the ambient temperature.  V(t_case) is 112.981, which
exactly matches the case temperature in the Sauna model.  So everything is as expected.

Clear the Operating Point window before continuing.
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Performing a transient analysis

Follow these steps to run a transient analysis of one hour (see Figure 6):

1.  Click the delete icon.  Then click on the .op command to delete.  Right-click or hit <Esc>
to stop.

2.  Add a transient analysis dot command by clicking the Spice Directive icon and entering
“.tran 3600s”(no quotes) in the box.  Then click the OK button and place in an appropriate
location.  Right-click or hit <Esc> to stop.

3.  There’s one last step.  You need to tell LTspice to start the heat sink at 25C.  You will do
this with an initial condition of 25 for V(T_case).  As you have done before, define the
“.ic V(T_case)=25” dot command shown in Figure 6.

Figure 6: Model setup for transient analysis

Now you are ready to run the analysis:

click  

The simulation completes quite quickly, only about one second.  A blank second window,
identified as spice_test_simple.raw, will open above the schematic.  This is the results window
and you will plot resuls here.

It’s very easy to plot results, position the mouse cursor on the T_case wire, then click.  The transient
curve for T_case will be as shown in Figure 7 on the next page:
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Figure 7: transient case temperature

The curve is largely identical to the curve you would obtain with Sauna.  Note that transient
results will never be exactly the same because of differences in the transient analysis algorithms.
Also, Sauna adjusts the thermal resistance to ambient throughout the analysis while LTspice is
working with a constant resistance obtained at the final steady state conditions.  But these are
generally small discrepancies (see "Assumptions and limitations" later in the release notes).

Before starting the next section, return to steady state analysis.  This is easy to do with the Undo
command.  Just hit the Undo icon, located at the upper right of the screen, three times.  Besides
the Undo icon, you can use <Ctrl-z> or Edit ➔ Undo.  When complete, the .op commend should
be visible.  Finally, close the results window and expand the schematic window.

Performing a forced air cooling analysis in Sauna

The first analysis was done with natural cooling for the heat sink, now you will try simulating
with an air flow of 500 ft/min.

Return to the spice_test model in Sauna.  You should leave LTspice open (minimize to the Taskbar
if you wish).

Analyze the heat sink with 500 ft/min cooling:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Forced Air ➔ Feet/Minute ➔ “500” ➔ "25"

You should obtain TS1-junct = 98.92°C and TS1-case = 76.92°C.

With forced air cooling, the resistance between the heat sink and the ambient will be reduced.
So you need to re-export the Spice model to incorporate the resistance change.
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As before, export the model:

<F12 Root Menu> ➔ File ➔ Export ➔ Model ➔ LTspice ➔ Subcirc/Symb ➔ Skip ➔ File
➔ click Save button ➔ click Yes to overwrite spice_test.subckt

➔ click Yes to overwrite spice_test.asy

Sauna will indicate that spice_test.subckt and spice_test.asy were sucessfully written.

Updating the model in LTspice

Return to LTspice.  You should leave Sauna open (minimize if you wish).

As it turns out, there’s nothing to update, just run the analysis:

click  

The operating point window will open and you will see V(t_case) = 76.9182, the same
temperature as Sauna.

While it’s really easy to switch between Sauna and LTspice, you should be aware of the
significant potential for confusion.  Under normal circumstances, it’s better to export the Sauna
model with a completely different symbol and circuit name if analysis parameters are modified
(such as switching between natural and forced air cooling).

Clear the Operating Point window before continuing.

A more substantial model change

Return to Sauna.

You can make substantial changes to the Sauna model and still have quick and easy export to
LTspice.  As shown in Figure 8 on the next page, you will be reducing the heat sink width to 150
mm and adding distributed wattage of 3W.

Before modifying, check the model node count:

<F7 Info> ➔ Node/Resis ➔ Numb Nd/Rth ➔ Screen

The report will show that the model has 299 nodes and 857 resistors.  When you change the
assembly width, the number of nodes and resistors will be reduced, but there will be no
problem with exporting to an existing schematic.

After clearing the report, reduce the width of the heat sink to 150 mm:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Dimensions ➔ In Plane ➔ Modify X ➔ Enter Dimen
➔ "150" ➔ Origin ➔ All In Wind ➔ USE

click  

The heat sink width will be modified.
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Figure 8: Modified heat sink model

As shown in Figure 8, add 3W of distributed wattage to the 9 nodes:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Node Group ➔ Assy Nodes ➔ "3"
➔ Face Area ➔ Select Regn ➔ use grouping rectangle from Figure 8 ➔ USE

Sauna will indicate that "distributed wattage applied to 9 nodes".

Now calculate temperatures for natural cooling:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain TS1-junct = 143.09°C and T  = 121.09°C.

With temperatures calculated, and float resistors initialized, you're ready to export the model.
Under normal circumstances, you should save the model with a new name.  Then export the
model using the new name.  This approach avoids any confusion with identifying the current
revision of the thermal model.  However, this is an exercise, so you will first export with the
current name to see how this is handled by LTspice.  Export now:

<F12 Root Menu> ➔ File ➔ Export ➔ Model ➔ LTspice ➔ Subcirc/Symb ➔ Skip ➔ File
➔ click Save button ➔ click Yes to overwrite spice_test.subckt

➔ click Yes to overwrite spice_test.asy

Sauna will indicate that spice_test.subckt and spice_test.asy were sucessfully written.
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Now do a second calculation with 500 ft/min cooling:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Forced Air ➔ Feet/Minute ➔ "500" ➔ "25"

You should obtain TS1-junct = 101.29°C and TS1-case = 79.29°C.

This time, things will be handled in the recommended fashion, so first save the model with a
new name:

<F12 Root Menu> ➔ File ➔ Save As ➔ type "spice_test_mod_frc" in file name box
➔ click Save button

Export the model:

<F12 Root Menu> ➔ File ➔ Export ➔ Model ➔ LTspice ➔ Subcirc/Symb ➔ Skip ➔ File
➔ click Save button

Sauna will indicate that spice_test_mod_frc.subckt and spice_test_mod_frc.asy were sucessfully
written.

Modifying the LTspice model

Return to LTspice.

Run another simulation:

click  

LTspice automatically loads the latest revision for the subcircuit, no questions asked.  The
operating point window will open and you should obtain V(t_case) = 121.091, which once again
matches the case temperature from the Sauna model.

Clearly, if all revisions are loaded automatically, there can be confusion.  Given that the latest
thermal model has both a change in the number of nodes and total wattage, it is surprising that
there isn't some sort of warning that subcircuits have been updated.  But that's the way it is and
you have to be careful.

Next, you will update the schematic with the recommended, more organized approach.
Previously you saved and exported spice_test_mod_frc.smf.  Follow these steps to incorporate
in the schematic:

1.  Clear the operating point window.

2.  Select the Delete icon, then click on the Sauna thermal model block.  Hit <Esc> or right-
click to stop deleting.

3.  Click the Component icon.  Find spice_test_mod_frc in the list and click.  (If you don't see
spice_test_mod_frc, hit the Refresh button below the list.)  Then click the Place button.  If
you position the new symbol in exactly the same position as previously, LTspice will auto-
generate the connections, so no modifications to the wires are needed.  Hit <Esc> or right-
click to stop placement.

It's quite easy to switch to a new symbol.
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Run the model again:

click  

As usual, the operating point window will open and you should obtain V(t_case) = 79.287,
which once again matches the case temperature from the Sauna model.

About distributed wattage, it's important

The current thermal model has distributed wattage assigned to some of the nodes in the heat
sink.  You should be aware that distributed wattage stays constant throughout the LTspice
analysis.  If you want this wattage to vary in some way, then you must create heat sources
instead.

Distributed wattage is an important feature for co-simulation.  With distributed wattage the user
can do detailed modeling of a few components while using a simplified approach elsewhere.
After all, any heat generated in the system impacts all components.  But you don't need to
model all components in the same detail.  Also, there's a good chance you don't have thermal
Spice models for every component.  By using distributed wattage you can model your key
components in good detail, while using an approximate model for the rest of the heat sink or
box.  Close the operating point window before continuing.

Creating a thermal model library

Up until now, you have exported with the "Subcirc/Symb" option.  This is the quick and easy
option.  But "quick and easy" can lead to confusion when you want to evaluate a series of
thermal designs, since LTspice always automatically loads the latest subcircuit iteration without
changing the symbol or notifying the user.  And the confusion will be worse if the thermal
modeler and LTspice user are not the same person.

To keep everything organized, there are strong advantages to exporting with a library.  So in
this section you will creating a simple library for the spice_test heat sink.  The library will
contain 3 thermal models: natural cooling, 500 ft/min cooling and 1000 ft/min cooling.

Return to Sauna.

Re-open the spice_test model:

<F12 Root Menu> ➔ File ➔ Open ➔ select spice_test.smf ➔ click Open button

click  

If you have been exactly following the release notes, the model should show TS1-junct = 134.98°C,
the natural cooling result.  (If you don't see this temperature, just recalculate with natural
cooling.)

The natural cooling configuration will be the first subcircuit in the library.  Begin creating the
library:

<F12 Root Menu> ➔ File ➔ Export ➔ Model ➔ LTspice ➔ Library
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You will reach the Lib Export (library export) menu:

 LIB EXPORT
1 New + Symb
2 Append

You will start with "New + Symb" which creates a library containing one subcircuit, along with
an associated symbol.  The first subcircuit will be natural cooling.  After creating the library,
you will use "Append" to add additonial subcircuits, in this case the 500 ft/min and 1000 ft/min
configurations.  Finish creating the library with:

New + Symb ➔ Skip ➔ File ➔ enter "lib_spice_test" in File name box ➔ click Save
➔ "nat_cooling"

Sauna will indicate that you successfully wrote "lib_spice_test.lib" and "lib_spice_test.asy".

The library has now been created.  At the moment, there is one subcircuit with the identifier
"nat_cooling".  The next step is to add a second subcircuit for 500 ft/min cooling.

Recalculate temperatures with 500 ft/min (fpm) cooling:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Forced Air ➔ Feet/Minute ➔ “500” ➔ "25"

As before, you should obtain TS1-junct = 98.92°C and TS1-case = 76.92°C.  Now that the thermal
resistance to ambient has been updated, append the results to the library:

<F12 Root Menu> ➔ File ➔ Export ➔ Model ➔ LTspice ➔ Library ➔ Append ➔ Skip ➔ File
➔ select "lib_spice_test.lib" ➔ click Save ➔ "forced_500_fpm"

Sauna will indicate that "successfully appended to lib_spice_test.lib".

Finally, obtain results for 1,000 ft/minute cooling:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Forced Air
➔ Feet/Minute ➔ “1000” ➔ "25"

You should obtain TS1-junct = 89.02°C and TS1-case = 67.02°C.  Once again, append the results to
the library:

<F12 Root Menu> ➔ File ➔ Export ➔ Model ➔ LTspice ➔ Library ➔ Append ➔ Skip ➔ File
➔ select "lib_spice_test.lib" ➔ click Save ➔ "forced_1000_fpm"

A library has now been created with three different operating conditions.
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Using a Sauna library with LTspice

Return to LTspice.

You will modify the circuit to obtain Figure 9.  There isn't much to do, just delete the existing
Sauna model block and replace with the library block ("lib_spice_test").  Then add the library
dot command.

Figure 9: LTspice schematic with Sauna library

If you're an experienced LTspice user, make the changes now..

If you want detailed steps, follow this checklist:

1.  Select the Delete icon.  Then click on the Sauna model to delete.  Hit <Esc> or right-click
to end.

2.  Click on the Component icon.  Find lib_spice_test in the list and select it.  (If you don't see
spice_test_mod_frc, hit the Refresh button below the list.)  Then click the Place button.
Move the symbol to the appropriate position and click.  Hit <Esc> or right-click to end.

3.  Select the dot command icon.  Type ".lib lib_spice_test.lib" in the box, then click OK.
Move the dot command to the appropriate location and click.

This is a good time to save the model:

File ➔ Save As ➔ “spice_test_with_library”➔ click Save button
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The model is now ready to run.  But first, there's some things to point out.  First, notice that the
name of the Sauna block has changed to "Sauna Thermal Library", which is not surprising.  But,
more importantly, the center of the block shows "nat_cooling".  This is the first subcircuit and
also the active subcircuit.  So the first analysis will be for natural cooling.  Later, when you
switch the cooling mode, the block text will automatically update.

Run the model:

click  

The operating point window will open and you will see V(t_case) = 112.981, which matches the
natural cooling result from Sauna.  Close the Operating Point window before continuing.

Switching subcircuits

It's exceptionally easy to switch to a different thermal subcircuit.  Follow these steps:

1.  Right-click on "nat_cooling" in the Sauna block.

2.  A window with the title "Enter new value for U1" will open.  Enter "forced_500_fpm" and
click OK.

That's it, you have switched to 500 feet/minute cooling.  Notice that the center of the Sauna block
has been updated to show the new subcircuit.

Once again, run the model:

click  

With the new cooling mode, you will obtain V(t_case) = 76.9182, once again matching the Sauna
result.

Finally, working on your own, switch the model to 1000 ft/min cooling.  You should obtain
V(t_case) = 67.0217, matching the Sauna model.

After clearing the Operating Point window, close the schematic without saving:

File ➔ Close ➔ click No button

In the next section, you will model with an actual Infineon MOSFET.  Finally, something real!
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Real world circuit with Infineon MOSFET

Now you will simulate the circuit shown in Figure 10:

Figure 10: Co-simulation with Infineon CoolSiC MOSFET

 If you examine Figure 10, and assuming you know something about MOSFET's, you can
deduce that the MOSFET is in the "on" state.  In this situation, the dissipation is determined by
the current, voltage and Rds-on.  The V3 and R7 were chosen to obtain a nominal Pdiss of 40W,
which is what you have been using in the Sauna model.  So, once again, you will have an
opportunity to compare results between LTspice and Sauna.

If you are a frequent LTspice user, it will only take a few minutes to create the circuit.  But you
also have the option of loading "sauna_mosfet_infin.asc" from Sauna's reference models folder.

However, the first step is to download the necessary Spice library from Infineon.  It's not
appropriate for Thermal Solutions to provide the library, so go to the webpage for the MOSFET:

https://www.infineon.com/part/IMW65R020M2H#design-resources

On the page, select "Simulation models".  Then download "CoolSiC™ MOSFET 650 V G2 Spice",
which is a zip file.  After uncompressing, place the library in a folder in the LTspice search path.
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The Infineon library can be opened with any text editor.  Open the library file. The top of the file
shows the supported parts.  If you scroll down, all of the subcircuits can be viewed.  This is not
always the case, many library files are binary and can't be viewed.  Exit the library file.

However, there is a disadvantage with the Infineon library.  It's intended to work with several
different Spice variations, not just LTspice.

Also, Infineon does not provide a symbol (.asy) file.  So you need to go to C:\Program Files(x86)
\Sauna Thermal Modeling\Reference Models”folder and copy infineon_mosfet.asy to your
working folder.

Return to LTspice.

As stated above, you can create the Figure 10 circuit on your own or you can simply open
sauna_mosfet_infin.asc from C:\Program Files(x86)\Sauna Thermal Modeling\Reference
Models.  Load or build the schematic now.

Now you're ready to run the simulation:

click  

It won't work.  Assuming there isn't a path problem, you will get an error message about "This
sub-circuit canot be instantiated...".  This is an error in LTspice, but not with other versions of
SPICE.  But, fortunately, the Infineon library is a just a text file, so it's easy to fix.

Follow these steps:

1.  Open ifx_coolsic_gen2_650v.lib.

2.  Go to line 230.  Line 230 is a function definition for "fparl132(fpar134)".  This function is
completely unneeded for the current problem.

3.  Delete the entire line 230.

4.  Save the file.

Return to LTspice.  Now try again:

click  

This time the simulation will complete successfully and the results window will open.  If you
hold the cursor over the MOSFET symbol, you will see "Dissipation=39.938417w", which is close
to the 40W target.

Now generate plots of Tcase and Tjunction by clicking the T_case and T_junct wires.  You should
obtain Figure 11 on the next page.



24

Figure 11: graph of V(t_case) and V(t_junct)

But there's something wrong.  The graph shows V(t_junct) = 160 and T(t_case) = 132, much hotter
than the Sauna model, which has TS1-junct = 134.98°C and TS1-case = 112.98°C.  What's going on?

But you can find the answer by plotting wattage.  Depress the <Alt> key and hold the cursor over
the T_case wire until you see the ammeter icon, then click.  The current (= wattage) will be displayed
with the scale on the right.  Examination of the plot shows that while the wattage started at
roughly 40W, the final wattage is 49W.  This is a very significant 22.5% jump.  The wattage
increase is a consequence of the temperature coefficient of Rds-on, where the resistance increases
with temperature.

If you were to go back to Sauna (not required) and increase the wattage to 49W, you would
obtain TS1-junct = 159.50°C, very close to the LTspice value.

Now you will try the other cooling configurations in the Sauna library, starting with 500 ft/min.
Follow these steps:

1.  Zoom in on the Sauna block.

2.  Right-click on "nat_cooling" in the Sauna block.

3.  Enter "forced_500_fpm" and click OK.

Run the simulation again:

click  

With the new cooling mode, V(t_junct) ≈ 102, much closer to the TS1-junct = 98.92°C in the Sauna
model.  This is easy to explain, the plot shows that the wattage has decreased to 41.3W, close to
the 40W assumed in the Sauna model.
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Finally, switch to 1,000 ft/min:

1.  Right-click on "forced_500_fpm" in the Sauna block.

2.  Change the value to "forced_1000_fpm" and click OK.

Run the simulation:

click  

Now V(t_junct) = 89, quite close to TS1-junct = 89.02°C in the Sauna model.  The LTspice wattage
is almost exactly 40W, so the Spice/Sauna correlation should be very close, and it is.

This completes the exercise.  Delete the schematic without saving:

File ➔ Close ➔ click No button

Co-simulation vs. the old way

You have just seen how the heat sink and circuit are interrelated.  If you use a better heat sink,
the Pdiss decreases.  And, of course, other electrical parameter are affected by temperature as
well.  All of these important insights are unlocked when you use electrical/thermal
co-simulation.

This is, of course, is very different from the old way of handling thermal issues.  The old way is
top-down and there is no feedback.  Specifically, the analysis starts with a worst-case (probably
very crude) estimate of power dissipation.  And then an engineer attempts to define a cooling
system based on the worst case estimate.  There is no consideration that the power dissipation
and cooling method are actually interrelated.

And in a convential design environment, thermal modeling is only used for a worst-case
survivability analysis.  There is no consideration of how operating temperatures are impacting circuit
performance and stability on a continuing basis.

So much more is possible

The example that you just worked is very simple.  First, you are not limited to a single heat
source, there's no hard limit.  Most products have multiple heat dissipating components, so it's
important to assess the thermal interaction.  And you can do this for a variety of conditions:
cold start, duty cycle operation, voltage pulses and more.  And results will be so much more
meaningful than with classic circuit analysis methods like simple temperature sweeps.

 As far as the Sauna thermal model goes, you worked with a simple heat sink.  In fact, it's the
very first model created when learning Sauna.  It's something that any engineer, electrical or
mechanical, can learn how to do in just a couple of hours.  Yet this model is still quite useful and
can be the basis for sophisticated co-simulation.

And, of course, you can do much more with Sauna: complex multiplane heat sinks, multilayer
boards and complete boxes.  For those willing to invest some time learning the tool (a day or
two), all sorts of complex configurations can be analyzed.
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Assumptions and limitations

Co-simulation is amazaing.  But there are some things to be aware of.

Linearity and non-linearity.  The resistors and capacitors that you export to SPICE are assumed
to be constants.  For the resistors and capacitors for ordinary solid materials (aluminum, steel,
plastic, FR4) this is a pretty good assumption.  Silicon is a notable exception, but this should be
handled through the component model in SPICE.

For cooling, the resistors are not constants and have some dependence on the ∆T between a
surface and the room ambient.  But the temperature dependence is fairly modest.  For example,
for natural convection in air, the thermal resistance decreases by about 15% with a doubling of
the ∆Tsurface-to-ambient.  Thermal radiation thermal resistance also decreases with a doubling
of the ∆T, with a 12% reduction.  On the other hand, for forced air cooling there is little
dependence (< 1% for a doubling of the ∆T).

The ambient temperature also impacts thermal resistances.  With a change from 25C to 60C
ambient, the natural convection resistance increases by roughly 4% while the thermal radiation
resistance decreases by about 25%.  Forced air cooling resistances are little impacted by a
change in the ambient temperature.

Overall, the assumption of linearity is reasonable, within limits.  For major changes in power
dissipation and ambient range, it's a good idea to re-calculate and re-export the Sauna model.

Work with time average power.  Since the thermal model is sensitve to the ∆Tsurface-to-ambient
and the ∆Tsurface-to_surface, export the resistances which corresponds to the time average power.
In the 40W example above, if the duty cycle was 25% power on, you should adjust the heat
source to 10W prior and re-analyze the model prior to exporting.

Simplifying the thermal model

In the exercise just completed, you worked with a model with 299 nodes.  All of the LTspice
simulations completed quite quickly.  However, Sauna models can be quite a bit larger than 299
nodes.  It's certainly possible to have Sauna models with thousands of nodes and in this
situation there will be impact on the SPICE simulation.  What is the best way to deal with this
issue?

Remeshing, in conjunction with some simple slicing, is the best way to simplify the model.
Throughout the Sauna tutorials, it is assumed that the user wants to have a mesh density which
provides temperature results accurate to a couple of percent.  But for co-simulation you can
frequently reduce mesh density a bit and still obtain very reasonable results.

Figure 12 on the next page shows a detail of the spice_test.smf model that you have been
working with.  As shown in the figure, there are 4 case-to-sink resistors connecting the source to
the heat sink, which is recommended for good accuracy.
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S1

112.98
134.98

heat source connected with 4 resistors,
recommended for best accuray

X

Y

Steady State

Figure 12: spice_test model with "recommended" mesh density

Now examine Figure 13 below.  The heat sink was re-meshed with the "Coarser 4x" option (Edit
➔ Assembly ➔ Remesh/Align ➔ Remesh ➔ In Plane ➔ Both Axes ➔ Coarser 4x).  With the
remesh, the heat source is only connected to the heat sink with one case-to-sink resistor.  There
is an increase, 3.6°C hotter, which is still probably close enough for export to SPICE.  The node
count (86 total nodes) is reduced by more than 2/3.

S1

116.55
138.55

temperatures within 3.6˚C

remeshed with "Coarser 4x", 86 nodes in model

X

Y

Steady State

Figure 13: spice_test model after simple remesh
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But there's an even better way to remesh, as shown in Figure 14.  Two simple slices were
performed, followed by a remesh.  The mesh density close to the heat source is unchanged, but
the overal node count is 111, a roughly 2/3 reduction from the original model.  While this
approach takes a bit more effort from the user, the heat source temperature is remarkably close,
just a discrepancy of 0.13°C from the original spice_test model.

S1

113.11
135.11

X-coord slice

Y-coord
slice

remeshed with "Coarser 4x",
111 nodes in model

temperatures within 0.2˚C

X

Y

Steady State

Figure 14: combined slicing and remeshing

Simplified board models

In the previous section, you saw how slice and remesh can be used to significantly reduce the
number of nodes in the model.  However, the bigger challenge is to reduce the node count in
circuit boards.  Fortunately, Sauna has effective tools for this as well.

Planar board models.  As explained in Introductory Exercise 5: Basics Of Circuit Board Modeling, a
planar board model is a simplified single plane representation of a board.  Basically, it's as if all
the copper layers have been smashed together.  While this may seem to be an over-
simplification, a planar model can provide reasonable answers if all the key components have
integrated heat slugs.  So if the board is primarily DPAK's and quad packages with slugs,
planar models provide a way to obtain a highly simplified model and reasonable temperature
results.  And, of course, a planar model is fine for boards which are low power and/or do not
have critical components.

Simplify layer-by-layer stackup with lumped leads.  Things become more complicated when key
components have a large number of leads and significant heat transfer through the leads.  If you
want to model a quad package with 500 leads, the node count in the model can quickly balloon.
A good first step is to not model each individual lead, rather, make use of lumped leads, as
shown in Figure 15 on the next page.
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lumped leads reduce node count

Figure 15: Use lumped leads to simplify boards models

With lumped leads the node count is reduced but you still maintain an accurate combination of
heat transfer from the top of the package, heat transfer through the leads, and heat flow down
into internal layers.  It's a good approach.

Simplify layer-by-layer stackup by reducing number of internal layers.  Modern circuit boards
have lots of layers.  Any model where 10 copper layers are modeled individually will be a big
model with thousands of nodes.  However, many internal layers are of limited thermal
importance and can be combined.  Ideally, the goal is to combine all internal layers into a single
internal layer.  Typically the heat generating components in the board have thermal vias
connecting to a single ground plane.  So you would retain this gound plane with extra copper
weight to compensate for the layers removed from the model.  Of course, it's not always
possible to reduce down to a single internal layer, but it should be possible to reduce the
internal layer count significantly.

A good approach is to first create a detailed layer-by-layer board model.  This will be the
reference model.  Then create a simplified model and compare with results from the detailed
reference model and make any necessary adjustments.  As discussed earlier, you should also
use remesh and slice to reduce the mesh density.  It really is possible to reduce a board model
with 10,000 nodes down to a model with less than 1,000 nodes, while still retaining good
accuracy.  Feel free to contact Technical Support with any questions about simplifying your
model.

Finally, there is a section in the Sauna User Manual, "Exporting Sauna Models" which provides
some additional tips on exporting Sauna models.  And, of course, Technical Support can
provide assistance when necessary.
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Adjusting LTspice settings

There may be situations where you wish to adjust the circuit simulation settings for LTspice and
other SPICE versions.

If you find that a simulation takes a long time to produce a result, or perhaps doesn't converge
at all, you can try different solver settings.  In LTspice,  click the Gear icon and then the SPICE
tab.  Your first option is to switch between the Normal and Alternate solvers and see if this
improves simulation time and convergence.  Another option is to try increasing Abstol and
Reltol to speed the calculation.  Finally, you can switch between the trapezoidal and Gear
integration methods.

Of course, if your simulations all complete quickly, there's no reason to adjust the settings.  But
cosimulation with a thermal model, which generally contains large time constants, is somewhat
out of the ordinary for SPICE.  At times, some experimentation may be warranted for best
results.

Wrapping up

This concludes the V5.6 Release Notes.  You should exit from both Sauna and LTspice.

Thank you for working through the release notes.
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