
Sauna™ V5.54 Release Notes

Welcome to Version V5.54 of the Sauna thermal modeling package.

Getting started with Sauna V5.54

Please begin by reading “Sauna V5.54 New Features List” on the next page.

When you are ready to begin using Sauna V5.54, work through "Sauna V5.54 Tour", which starts on
page 6.  This is a comprehensive exercise which takes around 4 hours to complete.

Who should install Sauna V5.54?

Everyone.  Sauna V5.54 includes many important new features.

Installation
To install or update Sauna, see the “Installation” chapter in the Sauna User Manual.  The method is the
same as for previous Sauna releases.
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Sauna V5.54 New Features List

Sauna V5.5 provides important new features

• Cylinder, bar and tube assemblies

• Round can enclosures with internal convection and radiation

• Incorporate flow networks (air, water, antifreeze, etc.) in tube assemblies

cylinder

bar
round tube

square tube
round tube,
offset hole

clamshell

Bar and tube assemblies

Cylinder, bar and tube assemblies

• Very easy to create

• Variety of shapes supported (see picture)

• Use bars and tubes for

- cylindrical components (capacitors, resistors, coils)
- liquid cooling applications
- heat loss through wires
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• Multiple node and resistor planes supported

- no need to stack assemblies
- user can adjust plane count with axial remesh
- easy to isolate a specific plane for applying heat loads

• Can have different cooling modes for front face, back face, sides and hole (if applicable)

• Contours shown on all surfaces

• Axial slice for subdividing in axial direction

• Sauna still supports planar assemblies

- can still model with "classic Sauna"
- planar assemblies and bar/tube can coexist in the same model

Can enclosure with components

Round can enclosures

• Easy to create, largely the same as creating a rectangular box

• "Board in can" and "Plate in can" commands provided, just as for rectangular
box

• Convection and gray radiation networks are easy to create
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Bck

Ctr

Frt

Temp ˚C

96.25

89.19

82.13

75.08

68.02

60.96

53.90

46.85

39.79

32.73

25.67

Steady State

Cold plate model incorporates water flow networks

Integrate flow networks inside tube assemblies

• Easy to create, just choose tube assembly and specify flow

• Fluid types: air, water, 50/50 antifreeze, special

• Convection and temperature rise calculated automatically

• Clamshell configurations supported

• Use for cold plates, battery cooling and many other applications

New options for circuit board pads

• Additional pad shapes: triangular, five-sided polygon, six-sided polygon, circular (sliced
and unsliced)

• “Entire board” option for quickly creating ground and power planes
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Even more new features

• New assembly and node shapes: triangular, five-sided polygon, six-sided polygon

• Filled hole command

- similar to creating hole, except that hole is filled with a new assembly with the same
material

- very useful for creating a section with higher mesh density inside a larger assembly
(no slicing required)

- if necessary, can change the material, useful for modeling wires, heat sink with copper
insert, etc.

• Create rectangular assembly by defining 2 points

• Create rectangular hole by defining 2 points

• Improved creation and editing of line labels
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Sauna V5.54 Tour

Introduction: Evolution of Sauna

"Classic Sauna":
- rectangular
- one node thick
- sides have same
  cooling as face

Sauna V5.0:
- rectangle, circular and poly
- one node thick
- sides have same cooling
  as face

Sauna V5.5:
- multiple node planes
- independent side cooling
- rectangle, circular, poly
- flow networks

Figure 1: Evolving from "Classic Sauna" to Sauna V5.5

If you examine Figure 1., you can see how Sauna has evolved from "classic planar Sauna" to the
bars and tubes available in Sauna V5.5.  In the classic version of Sauna, an assembly was always
rectangular, had a single plane of nodes and resistors, and the assembly side areas had the same
cooling mode as either the front face or back face.  Although these are significant simpli-
fications, it was possible to create quite complex models by stacking assemblies and working
with rectangular approximations.  But with classic Sauna, there was no way to separately
manage the side areas.  For example, it was not possible to have forced air cooling on the sides
while using natural cooling for the faces.  For a shape which is basically flat, this is not a major
problem.  But for blocks and tubes, the bulk of the surface area is on the sides, so this becomes a
major limitation.  And, of course, it's a nuisance to model round shapes with rectangular
equivalents, so it's very desirable to have a full set of shapes.

Sauna V5.0 provided incremental improvements.  For the first time, you could have circular
assemblies.  Also, both rectangular and circular holes were allowed.  But you were still limited
to a single plane of nodes and resistors, and the cooling of sides was the same as the front and
back faces.  And there was no simple way to have a fluid blowing on the inside of a tube.

As illustrated above., Sauna V5.5 fully implements multi-layer assemblies in a variety of shapes
(triangular, polygon, circular).  The side area is managed completely separately from the faces
(and contours are shown as well).  It's also easy to integrate flow networks within the assembly
holes.  All of this is illustrated in the following sections.
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Modeling a heat sink: planar assembly vs. bar assembly

150

100

10

TO-247 package,
Q = 20 W,
typical Rjc, Rcs

(50,50)

Fins: length = 20,
spacing = 8,
thickness = 1  

X

Y

Z

Figure 2: Simple heat sink model

You will begin by modeling with a classic planar assembly.  Please be aware that you can continue
to model the old way with planar assemblies.  You are not obligated to use the new bar and tube
assembly types.

Begin creating the planar assembly with:

<F12 Root Menu> ➔ Model ➔ Assembly

You will reach the new version of the Assembly menu:

  ASSEMBLY
1 Board
2 Planar Plate
3 Bar/Tube
4 Box/Can
5 Brd In Bx/Cn
6 Plt In Bx/Cn
7 Surface
8 Trace/Pad

The Assembly menu has changed significantly, but all of the previous options are still available.
And, of course, there's new options for bars and tubes.
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Continue with:

Planar Plate ➔ hit <Enter> to skip ➔ Rectangle ➔ Vertical XY ➔ "150,100,10"
➔ (0,0,0) ➔ Aluminum ➔ Extruded ➔ Anodized

The planar plate assembly will be created.  Note that new assembly shapes (triangle, poly 5,
poly 6) were available on the Plate Shape menu and there was a new "2 point" option on the
Rect Plane menu.

Next, add a TO-247 basic heat source and align the mesh to the heat source:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "20" ➔ "S1" ➔ TO-247 ➔ Typical
➔ Standard ➔ Greased ➔ Plate/Board ➔ One ➔ trap assembly ➔ Coords/Trap ➔ "50,50"

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source
➔ 4 Node Conn ➔ trap heat source ➔ All In Wind ➔ USE

The process for creating a heat source and aligning is largely unchanged from previous Sauna
versions.

As shown in Figure 2, you will be modeling a finned heat sink.  But you will start with a flat
plate calculation.  Add float resistors on both sides of the plate:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Comp+Secdry ➔ All In Wind ➔ USE

click  

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain TS1 junct = 90.29°C.

Converting to a bar assembly

There's two ways to create a bar assembly.  The most obvious way is with Model ➔ Assembly ➔
Bar/Tube.  But it's also quite easy to create a planar assembly and convert to bar.

Before starting, obtain an assembly list report:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

The report indicates that the assembly label is "Plate 1" (auto-generated by Sauna) and the
assembly type is "XY planar plt".

After clearing the report, begin the conversion to bar with:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Convert ➔ Planar > Bar
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You will reach the Node Planes menu:

  NODE PLANES
>1 2
 2 1
 3 3
 4 4
 5 5
 6 6
 7 Enter Planes

Since a bar can have multiple planes of nodes and resistors, it makes sense to specify this
parameter when converting a planar assembly.  However, you might be a little surprised that
you can have a bar with just one node plane.  In fact, bars and tubes can have any number of
planes, including just one (see "So what exactly is the difference between a planar plate and a
bar?" on page 11).  Continue with a single node plane:

1 (2nd selection) ➔ To Component ➔ Same As Comp ➔ All In Wind ➔ USE

Sauna will indicate the "1 planar assembly converted to bar".  But everything still looks the
same.  However, check the assembly list report:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

The report shows that the assembly label has changed from "Plate 1" to "Bar 1" and the type is
"Z axis bar".  So an XY planar plate becomes a Z-axis bar.  While this doesn't seem particularly
logical at first, it would make perfect sense if the assembly were 200 mm deep and had multiple
node planes.  For now, just remember that an XY planar plate converts to a Z-axis bar, a YZ
plate to an X-axis bar and a horizontal assembly converts to a Y-axis bar.

After clearing the report, switch to a perspective view and calculate temperatures:

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

Interestingly enough, you will obtain Tjunct = 96.03°C, an increase of nearly 6°C.  This is worth
investigating.  Get a report for the assembly:

<F7 Info> ➔ Trap ➔ Any Assy ➔ trap assembly

At the top of the first page, the report shows that the assembly type is bar.  If you advance to the
3rd page of the report, you will see a section entitled "-- Outer Side Surface Dissipation --".  This
section is only present for bars and tubes.  The section shows that the outer convection and
radiation area is 0.0.  That's why temperatures are hotter, there's 5,000 mm2 of surface area
which is being ignored.

Clear the report, then turn on fixed nodes:

click  
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Ambients are present for the component and secondary sides, but there's nothing for the side
area.  Create float resistors for the sides with:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Outer Sides ➔ All In Wind ➔ USE

click  

There are now an additional 4 ambients for the sides of the assembly.  Turn off fixed nodes and
calculate temperatures:

click   ➔ click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

Now you will obtain Tjunct = 90.91°C, which is within 0.6°C of the planar model.  Even though
there's a single node plane for both models, you won't obtain exactly the same temperatures
because the convection assumptions are not identical.  But the results will be close.

It's interesting to view the contours, so rotate the view and activate contours:

click   ➔ click  

As the screen clearly shows, contours are drawn on the sides for bar assemblies, a nice
improvement.

Performing an axial remesh

Bar assemblies can have any number of node planes.  And it's easy to change the number of
planes.  Turn on fixed nodes and switch to 2 node planes:

click  

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Remesh ➔ Axial
➔ 2 Planes ➔ All In Wind ➔ USE

The assembly will now have 2 node planes.  This is called an "axial remesh" because the number
of node planes in the axial direction (Z-direction) has changed.

It's a little hard to see what happened to the heat source.  Turn off fixed nodes and switch to a
top view:

click   ➔ click  Top

The screen should be the same as Figure 3 on the next page.  In a top view, you can clearly see
that the heat source is in the plane closest to the component face.  When you converted to a bar,
you chose the "To Component" option, so heat sources are placed on the plane closest to the
component face.
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S1

heat source on component node plane

X

Z

Figure 3: Heat source on component node plane

Now calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

With 2 node planes Tjunct = 91.29°C, which is a slight increase (0.3°C) from the result with one
plane.  For a thin metallic assembly, there is generally only a small change when adding a node
plane.

Now switch to four planes and calculate temperatures:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Remesh ➔ Axial
➔ Finer 2x ➔ All In Wind ➔ USE

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

With 4 planes, Tjunct = 91.61°C, another small increase of 0.3°C.

So what exactly is the difference between a planar plate and a bar?

You have seen that a bar can have just one node plane, the same as for a planar assembly.  So
what is it that makes a bar different?

The key difference is the treatment of edge area.  With a bar, the surface area on the sides of the
assembly is managed independently from the faces.  So the component face can have natural
cooling while there is forced air cooling on the sides (or no cooling at all).  For a flat plate, this
may seem like a subtle difference.  But it's a major difference when working with a cylinder
which is 10 mm in diameter and 300 mm long.  For such a cylinder, there is substantially more
surface area on the sides than on the component/secondary faces.
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Get an Info report again:

<F7 Info> ➔ Trap ➔ Any Assy ➔ trap assembly

At the middle of the first page, the report shows that the side area option is "independent", as
you would expect.

Clear the report before continuing.

Converting to planar assembly and adding fins

You saw that it was easy to convert a planar assembly to a bar assembly.  It's also easy to go in
the other direction.  Modify the view, then make the change

click   ➔ click  

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Convert ➔ Bar > Planar ➔ Divide
➔ All In Wind ➔ USE ➔ click Yes button

Sauna will indicate that "1 bar assembly converted to planar" and the side ambients and float
resistors will be deleted.  Once again, the assembly will have a single node plane.

Now you are ready to add fins.  Fins can be added to both planar and bar assemblies.  Turn off
fixed nodes and add fins:

click  

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Plt/Bar Prop ➔ New Fins ➔ "20,8,1"
➔ Secondary ➔ All In Wind ➔ USE

The fins will be added.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

With the fins, Tjunct is reduced to 72.09°C.

Converting to bar and changing axial spacing

As before, convert to a bar assembly with a single node plane:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Convert ➔ Planar > Bar ➔ 1 (2nd selection)
➔ To Component ➔ Same As Comp ➔ All In Wind ➔ USE

Add float resistors to the outer sides of the assembly:

click  

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Outer Sides ➔ All In Wind ➔ USE
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Turn off fixed nodes and calculate temperatures:

click   ➔ click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

With a one plane bar assembly, Tjunct = 72.30°C.  This is within 0.2°C of the planar temperature.

Now remesh to have 2 planes and calculate temperatures:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Remesh ➔ Axial ➔ 2 Planes
➔ All In Wind ➔ USE

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

With 2 planes, Tjunct = 72.69°C, a small change.  Finally, switch to 4 planes:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Remesh ➔ Axial
➔ Enter Planes ➔ "4" ➔ All In Wind ➔ USE

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

With 4 planes, there is a further small increase to Tjunct =  73.02°C.

Concluding remarks on modeling heat sinks with bar assemblies

In the end, for the heat sink in Figure 2, there are only minor difference between the planar and
bar assembly models.  While it is nice to see contours on the side surfaces, there is the
disadvantage of extra modeling steps.  So you may prefer to continue using planar assemblies
for rectangular plate heat sinks.

So if a bar assembly is not really needed for simple heat sinks, why is this the starting point for the
exercises? This is the starting point because it provides a great way to learn the fundamental
differences between classic Sauna and the new bar assemblies.  It was chosen for educational
purposes, not because bar assemblies are particularly essential for heat sinks.

In the next section you will model a round tube with multiple flow configurations, including a
water flow network.  This is a great use for the new assembly features.

Before moving on, delete the current model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

Some assembly types are always planar

Circuit board assemblies are always planar.  Traces and pads are always planar as well.  There
is no need for multiple node planes for these assemblies because the same effect is achieved
through the stacking of laminate and copper layers.
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Modeling a copper tube

In this section you will model the copper tube shown in Figure 4.  The dimensions are roughly
the same as for USA commercial grade 1/2" copper tube.  You will be simulating for a variety of
cooling conditions: naturally cooled outer surfaces, forced air cooled outer surfaces, and
internal water flow.  With Sauna V5.5, these cooling combinations are easy to handle.

• copper tube, alloy 122
• 16 mm OD, 14 mm ID

Q = 30 W, applied at top-center

100

X

Y

Z

Figure 4: Copper tube model

Begin creating the tube with:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Bar/Tube ➔ hit <Enter> to skip

You will reach the Bar/Tube menu:

   BAR/TUBE
 1 Round Bar
 2 Square Bar
 3 Rect Bar
 4 Round Tube
 5 Square Tube
 6 Sqr/Rnd Tube
 7 Rct/Rct Tube

The menu presents the most common options for bars and tubes.  In particular, note that a
round bar with a centered round hole is not the only type of tube.  You can have square tubes,
rectangular tubes with round holes, and much more (see "What’s a tube?" on page 20).
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Continue with:

Round Tube ➔ Z-Axis ➔ "16,14" ➔ Coords/Trap ➔ "0,0" ➔ Enter Delta ➔ "-100"
➔ Standard ➔ Copper ➔ Tube 122 ➔ Emis=0.5

The tube assembly will be created.  To better see the assembly, switch to a perspective view:

click  

The model will be as shown in Figure 5:

component side (short dash)

secondary side (long dash)

X

Y

Z

Figure 5: Perspective view of tube assembly

Notice that the front face of the assembly is drawn with a short dash.  This is the component
side of the assembly.  There is also a secondary side at the back.  So a tube has a component and
secondary side, just like a planar assembly.  Of course, for a round tube, the component and
secondary faces are of limited importance because almost all of the surface area is associated
with the sides.

For a Z-axis tube, note that the component and secondary faces are in the XY plane.  For certain
Sauna operations, you can continue to select the assembly as an XY assembly.  Similarly, an
X-axis tube can be selected as a YZ assembly and a Y-axis tube can be selected as an XZ
(horizontal) assembly.

Switch to a top view:

click  Top
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Applying heat load to a specific plane

Notice that there are 6 planes of nodes.  We want to put the 30W heat load at the center of the
assembly, so do an axial remesh to obtain 7 planes of nodes and resistors:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Remesh ➔ Axial
➔ Enter Planes ➔ "7" ➔ All In Wind ➔ USE

When the assembly has multiple node planes, you need to be careful about applying the heat
load.  To make sure that wattage is only applied to the center plane, isolate the center node
plane:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Node/Resis ➔ Bar/Tube Pln ➔ Center ➔ trap tube

Now just the center plane of node and resistors is visible.  Note that you can also quickly isolate
the component and secondary planes.  If you need to isolate some other plane, you can use the
"plane number" option, where numbering begins with the secondary plane.

Switch to a front view:

click  Front

Now apply 30W to the 3 topmost nodes:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Node Group ➔ Assy Nodes ➔ "30"
➔ Face Area ➔ Select Regn ➔ grouping rectangle for topmost 3 nodes ➔ USE

Be sure to verify that the message is "Distributed wattage applied to 3 nodes".  If you get a
different number of nodes, you made an error somewhere.

Add the label "max" to the top-center node:

<F12 Root Menu> ➔ Edit ➔ Node ➔ Labels ➔ Trap 1 Node ➔ Any Node
➔ trap top-center node ➔ "max" ➔ click OK

Since you isolated a node plane, be sure to make all nodes visible before adding float resistors:

click   ➔ click  

Analyzing with external natural and forced air cooling

Now that the basic model is created, it's very easy to run through a series of cooling modes.
You will begin with natural cooling on the outer surfaces:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Outer Sides ➔ All In Wind ➔ USE

click  

Now calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"
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You should obtain Tmax = 318.06°C.  It should be noted that Sauna is using convection equations
for cylinders, not some sort of rectangular equivalent.  Next, activate temperature contours:

click  

The contours should be as shown in Figure 6:

X

Y

Z

Temp ˚C

318.06

314.45

310.84

307.23

303.62

300.01

296.40

292.79

289.18

285.57

281.96

Steady State

Figure 6: Tube with temperature contours

The contours very clearly show the hot spot at the top of the tube.  For tubes, it's absolutely
essential to show the contours on the side surfaces and, of course, Sauna V5.5 provides for this.

Before changing the dissipation mode, get a temperature report:

<F7 Info> ➔ Temperature ➔ Current ➔ With Supers ➔ Screen

Note that the average assembly temperature is 289.44°C, so a temperature rise of 264°C.

After clearing the report, turn on float resistors and switch to forced air cooling with an air
velocity of 1000 ft/min:

click  

<F12 Root Menu> ➔ Edit ➔ Resistor ➔ Float ➔ Isoltd->Fix ➔ Dissip Mode ➔ Forced/Rad
➔ Feet/Minute ➔ "1000" ➔ All In Wind ➔ USE

Sauna will inform you that "112 resistors were modified".  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"



18

You should obtain Tmax= 143.84°C, a substantial reduction.  Check the temperature report:

<F7 Info> ➔ Temperature ➔ Current ➔ With Supers ➔ Screen

The average assembly temperature has been reduced to 115.67°C.  This is a ∆T of 91°C, a
reduction of about 2/3.

Analyzing with internal water flow

Next, you will analyze the tube with internal flow (i.e.  pipe flow).  For now, you will be
modeling "internal only" so that you can compare with earlier results.  Later, you will add
natural cooling to the outer surfaces.

After clearing the report, delete the fixed nodes and float resistors:

click  

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

Now you will create a flow network inside the tube.  For internal flow, you will be creating
"channel" float resistors.  Start with:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Channel ➔ Tube Inner ➔ Conn To Fix ➔ Forced

You will reach the Fluid Type menu:

   FLUID TYPE
>1 Air
 2 Water
 3 Eth/Gly 50%
 4 Special

You have several choices for internal flow, including air, water and a 50% ethylene glycol
antifreeze mix.  You can use other fluids as well with the "special" option.

You will be using water, so complete creating the flow network with:

Water ➔ gallons/min ➔ "1" ➔ Frt To Back ➔ Auto ➔ In/Out + 1 ➔ All In Wind ➔ USE

The flow network will be created.  You specified "In/Out + 1" which means that there is an inlet
internal ambient, an outlet internal ambient and another internal ambient at the center of the
tube.

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

The Tmax is now reduced to 47.31°C.  Previously, for 1000 ft/min external cooling, Tmax was
143.84°C, so there is a substantial reduction.
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Activate the contours:

click  

With contours on, you can see that only the center of the tube is substantially above the inlet
temperature.  The Tmax is constrained by the ability of the copper to conduct heat along the axis
of the pipe.  Check the temperature report:

<F7 Info> ➔ Temperature ➔ Current ➔ With Supers ➔ Screen

The temperature report shows an average assembly temperature of just 28.24°C, or a
temperature rise of roughly 3°C.  Let's see what happens if the heat load is distributed evenly
across the tube.  Clear the report, then enter:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Any Assy ➔ "30" ➔ All In Wind ➔ USE

Recalculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the temperature calculation is complete, you will see Tmax = 28.24°C, a significant
decrease.  It's interesting to the contours:

click  

With the contours turned on, you can see the temperature range of 28.21°C to 28.26°C, close to
uniform.  The downstream portion of the tube is slightly warmer due to the small increase in
fluid temperature.

Some additional what-if calculations

Clearly, you can handle a lot of wattage with forced liquid cooling.  Let's try adding 500W to the
tube:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Any Assy ➔ "500" ➔ All In Wind ➔ USE

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

With a distributed 500W load, Tmax = 78.18°C and the outlet temperature is just 26.90°C.  Clearly
you can handle a lot of power with liquid cooling.

Finally, add natural cooling on the outside of the tube and calculate temperatures:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Outer Sides ➔ All In Wind ➔ USE

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

The new Tmax is 77.83°C, a small decrease of just 0.35°C.  There is hardly any impact from
adding cooling on the outside of the tube.  While we could also add dissipation from the
component and secondary faces, it's pretty obvious that this won't make much difference.
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This section of the release notes is complete, delete the model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

So what's a tube?

In the heat sink exercise, you saw that the key difference between a planar assembly and a bar
assembly is that side area is independent from the component and secondary faces.

So what exactly is a tube assembly?  A tube assembly is simply a bar assembly with a hole of
some sort.  The hole does not need to be centered, or even completely within the outer limits of
the assembly.  Some examples are shown in Figure 7:

Figure 7: Examples of tube assemblies

You can add flow networks to any tube.  However, if the hole is clipped, as is the case for the
top row of tubes, you will need matching assemblies which define uniform holes.

Finally, note that since a tube is always a bar, there really is no need for a menu with the title
"Bar/Tube", because "Bar" would actually be sufficient.  But Sauna uses "Bar/Tube" because it's
more natural for the user.

In the next section you will model a naturally cooled round can enclosure.  But you will return
to forced liquid cooling in the final section "Modeling a liquid cooled cold plate".
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Modeling a round can enclosure

You will be modeling the round can enclosure shown in Figure 8:

ABS can, diameter = 150,
height = 50, wall thickness = 2

DPAK package, 5 W,
X=-25, Z=-25,
default Rjc, Rcs DPAK package, 3 W,

X=25, Z=0,
default Rjc, Rcs

Figure 8: Round can enclosure

It's a simple matter to create a round can enclosure.  It's actually easier than creating a
rectangular enclosure, but there are some important differences to explain.  Begin with:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Box/Can ➔ Round Can

You will reach the Can Axis menu:

   CAN AXIS
 1 X-Axis
 2 Y-Axis
 3 Z-Axis

You specify the dimensions of a can in a way which is similar to specifying the dimensions of a
bar or tube.  There's a simple reason for this, a can is just a tube with two end caps.  Complete
creating the can with:

Y-Axis ➔ "150,2" ➔ Coords/Trap ➔ "0,0" ➔ Enter Delta ➔ "50" ➔ Inset Cap ➔ Plastic ➔ ABS

The can will be created.
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To clearly see the new can, switch to a perspective view and activate shade mode:

click   ➔ click  

The can is composed of just three assemblies.  It's useful to obtain an Assembly List report:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

The report shows that there are three assemblies that make up the can: "Can1:Bottom",
"Can1:Shell" and "Can1:Top".  Note that "Can1:Shell" is a Y-axis bar, while the caps are planar
assemblies.  The "Can1:" prefix allows you to easily turn the entire can on or off with layers.  If
you create a second can, the prefix would be "Can2:", a third can would be "Can3:", etc.  Also, if
this were an X-axis can, the caps would be called "Can1:Left" and "Can1:Right" instead of
"Can1:Bottom" and "Can1:Top", and there is a similar adjustment for Z-axis cans.

Clear the report before continuing.

Creating the board

Just as for a rectangular box, there's a command for adding a board to the inside of a can:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Brd In Bx/Cn ➔ Round In Can ➔ hit <Enter> to skip
➔ Y-Axis ➔ Minimum ➔ Enter Value ➔"10" ➔ No Gap ➔ .062"/1.5mm ➔ FR4 ➔ Zer/Lam Only

➔ .025"/0.64mm ➔ One oz. ➔ None ➔ No Join ➔ trap shell assembly

The board will be created.  Next, isolate the board and switch to a top view:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Brd Stackups

click  Top

New options for creating pads

Start by adding pads for the two DPAK's, using a 20 x 20 slug pad:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ trap board ➔ Component
➔ One oz. ➔ Library ➔ DPAK's ➔ DPAK ➔ 2 ➔ 20 x 20 ➔ 10 mm/0.4" ➔ 0.50mm/20mil

➔ No ➔ 0 Degrees ➔ Coords/Trap ➔ "-25,0,-25"

DPAK ➔ 2 ➔ 20 x 20 ➔ 10 mm/0.4" ➔ 0.50mm/20mil ➔ No ➔ 0 Degrees ➔ Coords/Trap ➔ "25,0,0"

The pads will be created.  If you look at Figure 8, you can see that the pads are connected
together.  So you need to create a large connector pad.  Begin with:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad
➔ trap any trace or pad ➔ Pads
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You will reach the Pad Shape menu:

   PAD SHAPE
 1 Rectangle
 2 Round
 3 Triangle
 4 Poly 4
 5 Poly 5
 6 Poly 6
 7 Entire Board

There is a significantly expanded number of options for Sauna V5.5.  Previously, you could only
create rectangular or poly 4 (four-sided polygon) pad.  But now you can create triangular, five-
sided, six-sided and circular pads.  And even more shapes can be obtained with a sliced circular
pad.

You will need a five sided polygon to connect the two 20 x 20 pads.  Note that the heat sources
are separated by 50 mm.  Create the pad with:

Poly 5 ➔ Coords/Trap ➔ trap lower-right corner of left 20 x 20 pad ➔ Coords/Trap
➔ trap upper-right corner of left 20 x 20 pad ➔ Dx ➔ "50" ➔ Coords/Trap

➔ trap upper-right corner of right 20 x 20 pad ➔ Coords/Trap
➔ trap upper-left corner of right 20 x 20 pad

The pad will be created.

Next you will create a ground plane on the other side of the board.  There is a new option for
this, the "entire board" pad:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ trap board ➔ Secondary
➔ One oz. ➔ Pads ➔ Entire Board

A pad will be created for the entire back side of the board.  It's a good idea to verify this, so
obtain a board stackup report:

<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

The report will show that a Copp>2 layer has been added and the area (1.70E+4) matches the
area of Lamin>1, so a full size pad has been added.  Clear the report before continuing.

Adding heat sources and aligning
Now it's time to add the two heat sources.  Start with the 5W heat source on the left:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ DPAK's ➔ "5" ➔ "S1" ➔ DPAK
➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point ➔ trap left pad reference point

The S1 heat source will be created, now add the 3W right source:

DPAK's ➔ "3" ➔ "S2" ➔ DPAK ➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point
➔ trap right pad reference point

The S2 heat source will be created.
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The S1 DPAK has the higher dissipation, so align the board to this component:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source ➔ 4 Node Conn
➔ trap S1 heat source ➔ All In Wind ➔ USE

The board mesh will change and you will see the message "Aligned nodes for 13 assemblies".

Creating external float resistors and ambients

Now you need to add float resistors to the outer surfaces of the can.  At the same time, you do
not want float resistors on the board and internal surfaces.  So you need to modify visibility.
Since the can assembly labels all start with "can1", it's a simple matter to isolate just the can.
Switch to a perspective view and isolate the can with:

click  

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Enter Prefix ➔ "can1"

Just the 3 outer can assemblies will be visible.  Actually, since there is only a single can in the
model, you could have isolated with just "can" (or even just "ca").

For a rectangular box, Sauna has the secondary side facing outward.  This is also the case for the
caps of the can.  Add float resistors and ambients for the top and bottom assemblies:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural ➔ Secondary
➔ All In Wind ➔ Unselect 1 ➔ trap shell assembly to remove from group ➔ USE

You should see the message "2 fixed temp nodes and 296 float resistors created".  You should
see exactly this message.  If not, use Edit ➔ Undo and try again.

Now it's time to add float resistors to the shell assembly.  This is also easy to do:

Isoltd->Fix ➔ "Room Amb" ➔ Natural ➔ Outer Sides ➔ All In Wind ➔ USE

Sauna will indicate "4 fixed temp nodes and 64 float resistors created".  Note that you were able
to use "All In Wind".  That was possible because the grouping menu was only for bars and
tubes, and the can shell is the only assembly which qualifies.

Resize the window to see the entire model:

click  

Note that there are actually two external surfaces without float resistors.  The shell has both
component and secondary faces, which are being skipped for now.
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Adding internal float resistors

The process of adding float resistors is very similar to the method for rectangular boxes.  But
once again there are some differences that you need to know about.

Turn off fixed nodes and switch to a front view:

click   ➔ click  Front

To add gap resistors, start with:

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Float ➔ Gap ➔ Cond/Radtn ➔ Convectn OK
➔ Horizontal ➔ 100% Area ➔ Entire Assy

You will reach the Horiz/Y-axis grouping menu.  This menus lets you select horizontal planar
assemblies and Y-axis bars and tubes.  Note that you don't want the shell in the group, so follow
this procedure:

Select Regn ➔ use grouping rectangle from Figure 9 ➔ Unselect 1 ➔ trap shell assembly ➔ USE

S1 S2

grouping rectangle for
    gap resistors

X

Y

Figure 9: grouping rectangle for gap resistors

The gap resistors will be created and you should see the message "2248 gap resistors created:
area = 1.70E+4".  (On the other hand, if you forget to remove the shell from the group, the
resistor creation will fail and you will see a "XZ plane: unable to calculate gap" message.)

For the convection and radiation above the board, it's very similar to the method for a
rectangular box (see Figure 10 on next page):

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Horiz Para ➔ Cnv/Rd Ntwk ➔ 1 Ambient ➔ 100% Area
➔ Y-Axis Can ➔ trap shell assembly ➔ Select Regn ➔ grouping rectangle from Figure 10 ➔ USE
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S1 S2

grouping rectangle

X

Y

Figure 10: Grouping rectangle for convection and radiation above board

The convection and radiation network will be created.  Note that there a total of 18 radiation
nodes, which will make the temperature calculation a bit slower.

Calculating temperatures and viewing contours

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain TS1 = 217.66°C and TS2 = 147.85°C.  Switch to a perspective view and activate
contours:

click   ➔ click  

You can't see much, so turn off the top cap assembly and turn the view:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Click Surf ➔ click top cap

click   ➔ click  

The contours should be as shown in Figure 11 on the next page.  The DPAK's are rather hot, but
this is just a preliminary calculation.  Normally, there are vias under the chips and probably
additional traces and pads.  But you will stop here, since the goal is only to illustrate the V5.5
features.  However, before moving on, please complete the simple what-if in the next section.
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X

Y

Z

S1

S2
Temp ˚C

213.49

195.19

176.90

158.60

140.31

122.01

103.71

 85.42

 67.12

 48.82

 30.53

Steady State

Figure 11: Can model temperature contours

What-if #1: adding convection/radiation to shell faces

As mentioned above, we did not include float resistors for the component and secondary sides
of the shell.  But that's easy to do.  Start by turning off contours and returning to a front view:

click   ➔ click  Front

Create the float resistors:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Natural
➔ Comp+Secdry ➔ Select 1 ➔ trap shell assembly ➔ USE

Ambients will be added above and below the shell.  Turn off fixed nodes and calculate
temperatures:

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the temperature calculation is complete, you should obtain TS1 = 217.48°C and
TS2 = 147.67°C.  Temperature are slightly cooler, about 0.2°C.

This exercise is complete, delete the model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button
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Modeling a liquid cooled cold plate

In the final part of the release notes, you will model the aluminum cold plate shown in Figure
12.  The initial version of the cold plate will have a simple flow path, and the fluid is directly in
contact with the aluminum.  Later in the exercise you will create a more complex flow path and
add a copper tube embedded in the block.

200

200
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water cooling,
1 gallon/minute

Diam = 16 mm,
Center = (20,12)

100

50

50

50

25 x 25 power module,
Q = 250 W, Rjc = 0.1˚C/W,
Rcs = 0.05˚C/W water out

aluminum,
6061 T0

Figure 12: Cold plate model, part 1

Looking at Figure 12, you can see that the geometry is basically horizontal.  But with front-to-
back flow, you will need to create a Z-axis tube and combine this tube with horizontal
assemblies.  As this exercise will show, the easiest way to build this geometry is to start with a
tube and build outward.

If necessary, switch to a front view.  Then create a “square/round” Z-axis tube with the label
"Tube>1":

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Bar/Tube ➔ "Tube>1" ➔ Sqr/Rnd Tube ➔ Z-Axis
➔ "24,16" ➔ Coords/Trap ➔ "20,12" ➔ Enter Delta ➔ "-200" ➔ Standard

➔ Aluminum ➔ 6061 T0 ➔ Unfin Sheet

The tube will be created.  Activate node outlines:

<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Assy Node

The node outlines shown that Sauna has created a radial transition mesh around the hole which
is desirable for accurately modeling the radial heat flow around the circular hole.
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Turn off node outlines and switch to a perspective view:

Turn Off

click  

In the perspective view, you can see that there are 8 planes of nodes.  You will do an axial
remesh later in the exercise to change the number of planes.

Creating "surface" assemblies

Now that the tube has been created, you will create a horizontal assembly to the left of the tube.
You can use Sauna’s surface assembly command:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Surface ➔ Neg X ➔ Horizontal ➔ Planar Plate
➔ Enter Dimen ➔ "8" ➔ Auto ➔ Auto ➔ Same ➔ All In Wind ➔ USE

The assembly will be created.  Obtain an assembly report:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

The report shows a new XZ planar assembly with the dimensions of 8.0 x 24.0 x 200.0.  After
clearing the report, create the right assembly:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Surface ➔ Pos X ➔ Horizontal ➔ Planar Plate
➔ Enter Dimen ➔ "168" ➔ Auto ➔ Auto ➔ Same ➔ Select 1 - trap tube ➔ USE

The right assembly will be created.  Switch to a front view:

click  Front

There is an abrupt change in mesh density between the hole area and the new assemblies.  This
can lead to errors when temperatures are calculated.  To correct this, convert the left/right
assemblies to bars with 2 node planes:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Convert ➔ Planar > Bar ➔ 2 ➔ To Component
➔ Same As Comp ➔ All In Wind ➔ USE

The horizontal assemblies will now have 2 node planes.  Obtain the assembly report:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

Since the planar plates have been converted, there's now two Y-axis bars (equivalent to XZ
planar) and the Z-axis tube.  The assembly labels were adjusted to reflect the conversion ("Plate
1" became "Bar 2", etc.).  The label conversion only occurs when you are using an auto-
generated label.

After clearing the report, switch to a perspective view and activate shade mode:

click   ➔ click  
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Notice that the shading is not uniform.  This occurs because there is a Z-axis bar and two Y-axis
bars.  This is useful for quickly identifying that the assemblies are in different planes/axes.  But
it may not look great in a report.  When necessary, you can change the shading scheme with
Setup ➔ Display ➔ Shade Mode ➔ Side Shades.

Now it's time to add planar assemblies across the top.  Once again you will use the surface
assembly command, but this time with the “auto plane” option:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Surface ➔ Pos Y ➔ Auto ➔ Planar Plate
➔ Enter Dimen ➔ "2" ➔ Auto ➔ Auto ➔ Same ➔ All In Wind ➔ USE

Three horizontal planar assemblies will be created.

Adding heat sources

Now you will add the heat sources.  You will be using basic heat sources.  First, isolate the
upper-right horizontal plate:

click  Front

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only ➔ Any Assy Grp
➔ Select 1 ➔ trap upper-right plate ➔ USE

Switch to a top view:

click  Top

Note that since the upper-right plate is in a superassembly, the superassembly outline is visible.

Add the front heat source as a "special":

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "250" ➔ "Frt" ➔ Special ➔ Specify
➔ ".1" ➔ Square ➔ "625" ➔ hit <Enter> to skip ➔ Enter Rth ➔ ".05" ➔ Plate/Board

➔ Multiple ➔ trap plate ➔ Coords/Trap ➔ "100,,-50"

The front heat source will be created.  (Note that Sauna interprets "100,,-50" as "100,0,-50".  Also,
heat sources always snap to the appropriate plane, so the Y-coordinate is actually irrelevant.)

Continue on to create the center and back heat sources:

Coords/Trap ➔ "100,,-100"

Coords/Trap ➔ "100,,-150"

You now have 3 heat sources, but you need to change the labels:

<F12 Root Menu> ➔ Edit ➔ Node ➔ Labels ➔ Trap 1 Node ➔ Has Label
➔ trap center heat source ➔ type Ctr in text box ➔ click OK

Has Label ➔ trap back heat source ➔ type Bck in text box ➔ click OK
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Aligning and adjusting axial spacing

The plate currently has a coarse node spacing, so the heat sources are only connected with a
single case-to-sink resistor.  To obtain the desired 4 case-to-sink resistors, you will need to align
to one of the heat sources.  The center heat source will normally be hottest, so you will align to
this node.  You will be aligning all of the assemblies except the square/round tube.  The tube
already has a uniform radial spacing, so there's no need to change that.  Note that you entered
"Tube>1" as the label for the tube assembly.

Turn on all assemblies and align to the center heat source:

click  

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source ➔ 4 Node Conn
➔ trap Ctr heat source ➔ All In Wind ➔ Unselect 1 ➔ "tube>1" ➔ USE

The assemblies will be aligned to the center heat source.  However, the axial spacing of the tube
does not match the rest of the model.  You can fix this by performing an axial remesh with the
"match reference assembly" option:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Remesh ➔ Axial ➔ Match Assy
➔ trap one of the right assemblies ➔ Select 1 ➔ "tube>1" ➔ USE

The axial spacing of the tube will be changed to align with the other assemblies in the model.

Adding the flow network and calculating temperatures

It's a simple matter to add a 1 gal/min flow network:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Channel ➔ Tube Inner ➔ Conn To Fix ➔ Forced
➔ Water ➔ gallons/min  ➔ "1" ➔ Frt To Back ➔ Auto ➔ In/Out + 1 ➔ All In Wind ➔ USE

The "front to back" (negative-Z direction) flow network will be created.  Currently, you are
using a round hole for the flow network, but square and rectangular holes are also supported.

Now you can calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the calculation is complete, you should obtain Tctr-junct = 193.90°C.  As expected, the
center heat source is the hottest.  While a Tjunct of 194°C is pretty hot, the Toutlet for the water is
just 27.85°C.

Switch to a perspective view, then rotate upward:

click   ➔ click  

Activate contours:

click  

The temperature contours show a large ∆T of 80°C between the heat sources and the tube hole.
Clearly there would be a benefit to using a two pass flow approach.
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Before moving on to the two-pass model, notice the thin strip of blue around the top layer of the
cold plate.  This is present because the top layer is modeled with planar assemblies and Sauna
doesn't draw contours on the side surfaces of planar assemblies.  But you can convert to a bar
with a single node plane and thus obtain contours on all sides.

Do the conversion now:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Convert ➔ Planar > Bar ➔ 1 (2nd selection)
➔ To Component ➔ Same As Comp ➔ All In Wind ➔ USE

Sauna should indicate "3 planar assemblies converted to bar".

Now recalculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

As before, you should obtain Tctr-junct = 193.90°C and Toutlet = 27.85°C.  This is expected because
there are no float resistors connected to the top layer, so nothing changes when you switch to a
bar.  But the modification will impact the contours, so activate now:

click  

Now there are contours for all surfaces, as shown in Figure 13:

Bck

Ctr

Frt

X

Y

Z

Temp ˚C

157.50

148.11

138.72

129.32

119.93

110.53

101.14

 91.75

 82.35

 72.96

 63.56

Steady State

Figure 13: Contours after modifying to bar assemblies

Do you need to continue?

The exercise on cold plate models continues for another 10 pages.  It’s valuable information.
However, if you’re not interested in liquid cooling, it’s safe to skip this material.  If this is you,
please glance through the remainder of the exercise, then delete the model and exit.
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Converting to a two pass model

Now you will modify the model to be as shown in Figure 14

water in,
1 gpm

water out

Figure 14: Two pass flow configuration

This modification will be easier than you expect.  You may want to look ahead at Figure 15 before
starting.

Turn off contours and switch to a front view:

click   ➔ click  Front

The return tube will be in a symmetric position.  So you need to start by reducing the width of
the right two assemblies by 32 mm:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Dimensions ➔ In Plane ➔ Modify X ➔ Enter Delta
➔ "-32" ➔ Origin ➔ Select Regn ➔ grouping rectangle for two right assemblies ➔ USE

The right assemblies will be modified.  Copy the tube and the 2 mm thick assembly just above:

<F12 Root Menu> ➔ Move/Copy ➔ Copy ➔ One ➔ Assembly ➔ Any Assy ➔ Select Regn
➔ grouping rectangle for tube and 2 mm thick assembly above ➔ USE ➔ Trap Dx

➔ trap left edge of tube assembly ➔ trap far-right edge of model

The two assemblies will be copied.
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Next, copy the two leftmost assemblies:

Copy ➔ One ➔ Assembly ➔ Any Assy ➔ Select Regn ➔ grouping rectangle for 2 left assemblies
➔ USE ➔ Trap Dx ➔ trap far-left edge of model ➔ trap far-right edge of model

The assemblies will be copied and the model should appear as shown in Figure 15.

Room AmbInletInletOutletOutletRoom AmbOutletInletRoom AmbRoom Amb

FrtCtrBck

X

Y

Figure 15: Model after resizing and copying assemblies

There's one last step before creating flow networks, you need to create edge joins for the newly
copied assemblies:

<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Zero Resis ➔ Grp To Grp ➔ All In Wind ➔ USE

Sauna should indicate that 4 new joins were created.  You don't need to create any stack joins,
these were copied along with the assemblies.

Creating the flow network
Switch to a perspective view:

click  

In a perspective view, you can see that the flow network is still present on the left side.  In a
moment, you will create a flow network on the right side.  Then it's relatively simple to combine
the two networks together.

However, before beginning, check the assembly list report:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

Notice that there is now a "Tube>2" assembly, which you created by copying.



35

Clear the report and create a "back to front" flow network for "Tube>2":

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Channel ➔ Tube Inner ➔ Conn To Fix ➔ Forced
➔ Water ➔ gallons/min  ➔ "1" ➔ Back To Frt ➔ Auto ➔ In/Out + 1

➔ Select 1 ➔ "Tube>2" ➔ USE

A new flow network will be created on the right.  Switch to a top view and isolate the flow
networks:

click  Top

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Flow Netwks ➔ Path Only ➔ All Netwks

Now you are ready to combine the flow networks.  It’s a good idea to look at Figure 16 on the
next page to see the final network.

Begin by deleting the back fixed nodes:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ Select Regn
➔ grouping rectangle for back fixed nodes ➔ USE

Make these changes to the node labels:

<F12 Root Menu> ➔ Edit ➔ Node ➔ Labels ➔ Trap 1 Node ➔ Has Label ➔ trap left inlet node
➔ change label to "Inlet #1" ➔ click OK

Has Label ➔ trap left outlet node ➔ change label to "Outlet #1" ➔ click OK

Has Label ➔ trap right inlet node ➔ change label to "Inlet #2" ➔ click OK

Has Label ➔ trap right outlet node ➔ change label to "Outlet #2" ➔ click OK

Make copies of Outlet #1 and Inlet #2:

<F12 Root Menu> ➔ Move/Copy ➔ Copy ➔ One ➔ Node ➔ Any Node ➔ Select Regn
➔ grouping rectangle for Outlet #1 and Inlet #2 ➔ USE ➔ Dz ➔ "-50"

Modify the labels of the newly copied nodes:

<F12 Root Menu> ➔ Edit ➔ Node ➔ Labels ➔ Trap 1 Node ➔ Has Label ➔ trap copy of Outlet #1
➔ change label to "Back-Left" ➔ click OK

Has Label ➔ trap copy of Inlet #2 ➔ change label to "Back-Right" ➔ click OK

All that remains is to connect the two flow networks:

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Flow ➔ Extend Path ➔ Chain ➔ trap Outlet #1
➔ trap Back-Left ➔ trap Back-Right ➔ trap Inlet #2 ➔ hit <F2 Backup>
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You are done modifying the flow network.  The network should be as shown in Figure 16:

Room Amb

Inlet #1Inlet #1

IA #2IA #2

Outlet #1 Inlet #2

IA #2IA #2
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Figure 16: Completed two-pass flow network

Calculating temperatures

Restore visibility and calculate temperatures:

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain Tctr-junct = 138.60°C, a significant reduction of 55°C.  Clearly there are benefits
to allowing the heat to conduct in two different directions.  The outlet temperature is 27.85°C,
the same as before.  This is just basic physics.  The flow stayed constant at 1 gpm, so the total
temperature rise has to be the same to allow for 750 watts of total dissipation.

Activate contours:

click  

The contours clearly show that heat is flowing outward in two directions.

Comment about connecting tube

For this cold plate to exist in the real world, there would have to be some sort of connecting
tube between the left outlet and the right inlet.  And if there's a connecting tube, there will be
heat loss from the connecting tube.  However, as you saw in the modeling of an isolated tube,
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the impact from natural cooling on the exterior of a small tube will be minor when compared
with the impact of internal cooling with water.  So it's a reasonable approach to simply ignore
the connecting tube.

Before continuing, turn off contours and switch to a perspective view:

click   ➔ click  

Embedding copper pipes in the cold plate
In the final portion of this exercise, you will embed copper pipes in the cold plate, as shown in
Figure 17:
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Frt

Copper pipe,
16 mm OD, 14 mm ID

X

Y

Z

Figure 17: cold plate with embedded pipes (tubes)

Begin by deleting the flow network:

<F12 Root Menu> ➔ Delete ➔ Special Del ➔ Flow Netwk ➔ All Netwks

Activate shade mode:

click  

Note that there is a red reference point at the entrance to the left hole.  You will use this when
creating the copper pipe.  Create the left copper pipe:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Bar/Tube ➔ "Pipe>1" ➔ Round Tube ➔ Z-Axis
➔ "16,14" ➔ Ref/Dz ➔ trap left reference point ➔ "50" ➔ Enter Delta ➔ "-300"

➔ Standard ➔ Copper ➔ Tube 122 ➔ Emis=0.5

The copper pipe will be created.
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Next, activate shade mode:

click  

If you look at the intersection between the pipe and the block, you can see that there is a
drawing error.  This occurs because Sauna’s shaded drawing is based on an algorithm that sorts
from back-to-front and inside-to-out.  The algorithm doesn't work well when you have an
assembly partially inside another assembly.

But there is a straightforward solution: slice the pipe at the limits of the cold plate.  Switch to a
top view and perform an axial slice:

click  Top

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Subdivide ➔ Axial Slice ➔ Double Z-Axs
➔ Trap ➔ trap front edge of cold plate ➔ Trap ➔ trap back edge of cold plate

➔ Select 1 ➔ trap pipe ➔ USE

The pipe will be sliced.  Now return to a perspective view and activate shade mode:

click   ➔ click  

The pipe and cold plate are now drawn correctly.  Check the assembly list report:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

After slicing, there are now assemblies "Pipe>1", "Pipe>2" and "Pipe>3".  This will make it easy
to select for copying.  Notice that Pipe>2 is 200 mm long, so this is the internal pipe assembly.

After clearing the report, switch to a top view:

click  Top

As you did earlier, adjust the axial spacing of Pipe>2 to match the rest of the model:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Remesh ➔ Axial ➔ Match Assy
➔ trap one of the center assemblies ➔ Select 1 ➔ "pipe>2" ➔ USE

The Pipe>2 axial spacing will now match the other assemblies in the model.

Now it's time to copy the left pipes to create the right pipes.  Switch to a front view and copy
the three pipe assemblies:

click  Front

<F12 Root Menu> ➔ Move/Copy ➔ Copy ➔ One ➔ Assembly ➔ Any Assy ➔ Select 1 ➔ "pipe*"
➔ Select 1 ➔ "pipe*" ➔ Select 1 ➔ "pipe*" ➔ USE ➔ Trap Dx ➔ trap left reference point

➔ trap right reference point ➔ click No to decline prefix increment

The pipes will be copied.  You took advantage of Sauna's wildcard feature to select "Pipe>1",
"Pipe>2" and "Pipe>3".
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Once again, check the assembly list report:

<F7 Info> ➔ Assemblies ➔ List/Supers ➔ Screen

After copying, there are Pipe>1 through Pipe>6 assemblies.  Pipe>2 and Pipe>5 are internal to
the block.

After clearing the report, create joins:

<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Zero Resis ➔ Grp To Grp ➔ All In Wind ➔ USE

Sauna should indicate "12 possible joins: 10 already joined, 2 new joins".

You're ready to create the flow network.  But first, switch to a perspective view and activate
shade mode:

click   ➔ click  

The image should be similar to Figure 17 on page 37.

Creating flow networks
To create the flow network, you will follow the same basic approach as previously.  So you will
start by creating separate flow networks on the left and right, then you will combine into a
single network.

As you saw above, the pipe assembly labels are "Pipe>1" through "Pipe>6".  So you have
created a "Pipe" layer.  Switch to a top view and isolate the layer with:

click  Top

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Enter Prefix ➔ "pipe"

Only the pipe assemblies are visible now, so selection will be easy when creating the flow
networks.  Create a "front to back" flow network on the left with:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Channel ➔ Tube Inner ➔ Conn To Fix ➔ Forced
➔ Water ➔ gallons/min  ➔ "1" ➔ Frt To Back ➔ Auto ➔ In/Out + 1 ➔ Select Regn

➔ grouping rectangle for 3 left pipe assemblies ➔ USE

The left flow network will be created.  Create the right flow network:

Conn To Fix ➔ Forced ➔ Water ➔ gallons/min  ➔ "1" ➔ Back To Frt ➔ Auto ➔ In/Out + 1
➔ Select Regn ➔ grouping rectangle for 3 right pipe assemblies ➔ USE

The right flow network will be created.  As you did before, zoom out and delete the back fixed
nodes:

click  

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ Select Regn
➔ grouping rectangle for back fixed nodes ➔ USE

The back fixed nodes will be deleted.
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Now all you need to do is connect the two networks:

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Flow ➔ Extend Path ➔ Single
➔ trap left outlet node ➔ trap right inlet node

The model is complete.  While it is probably a good idea to rename some of the internal
ambients, we will skip that step.

Turn on the entire model and switch to a perspective view:

click   ➔ click  

Calculating temperatures

Before calculating, it's interesting to question whether temperatures will increase or decrease.
The volume flow rate is unchanged at 1 gal/min.  On one hand, the pipe itself adds another
thermal resistance between the fluid and the heat sources.  Counteracting that, there is the fact
that the actual water velocity increases because the copper pipe diameter is smaller.  This
reduces the pipe-to-fluid thermal resistance.

The temperature calculation will indicate which factor is more important:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the temperature calculation is complete, you should obtain Tctr-junct = 133.77°C.  This is a
reduction of about 5°C from the non-pipe model.  So it does appear that the most significant
impact is from the increased water velocity.  In the next section, you will perform a what-if
which more directly measures the impact of flow velocity.

You should note that the Toutlet is unchanged at 27.85°C, which is the same as before.  This is just
basic physics.  The only heat flow path is the fluid and flow rate is unchanged, so you obtain the
same temperature rise.

Turn the view upward and activate contours:

click   ➔ click  

The image should be as shown as Figure 18 on the next page:
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Figure 18: Temperature contours for embedded pipe model

It may appear that the pipe sections outside the cold plate are at the inlet fluid temperature.  But
actually there is an increase in temperature that you can see if you change the contour range.
Change the contour range to 25°C to 50°C:

<F6 Setup> ➔ Display ➔ Contours ➔ On ➔ Enter Range ➔ "25,50"

With the adjusted contour range, you can see that the external pipe sections are in fact a few
degrees above ambient.

Turn off the contours:

click  

What-if #1: Doubling the flow rate

If you increase or decrease the flow rate, the pipe-to-fluid thermal resistance will change.  While
the water outlet temperature rise is just a few degrees, that doesn't mean that there is only a
small ∆T between pipe and fluid.  Obtain a temperature report:

<F7 Info> ➔ Temperature ➔ Current ➔ With Supers ➔ Screen

In the "Assembly Temperatures" section, you can see that Tpipe>2-avg = 44.42°C and Tpip>5-avg =
45.06°C.  So the pipe-to-fluid ∆T is around 20°C.  In general, if the outlet temperature is modest,
there is a fairly linear relationship between fluid velocity and thermal resistance.  So if we
double the flow rate, the ∆T might be reduced by 9°C or so.
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It's really easy to double the flow rate.  Clear the report and enter:

<F12 Root Menu> ➔ Edit ➔ Resistor ➔ Flow ➔ Flow Rate ➔ Scale Flow ➔ "2"
➔ Trap Netwk ➔ trap a flow resistor

Sauna will indicate "modified 7 flow resistors and 704 float resistors".  When you modify the
flow resistors, the associated float resistors are automatically updated.

Now calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

When the temperature calculation is complete, you should obtain Tctr-junct = 124.45°C.  This is a
reduction of 9.3°C, which clearly illustrates a fairly linear relationship between flow rate and
thermal resistance, provided that there is only a modest temperature rise for Toutlet.  Actually,
speaking of Toutlet, note that Toutlet is now 26.43°C, down from 27.85°C previously.  The water
temperature rise was cut in half, which is exactly what you would expect with a doubling of
flow volume.

What-if #2: Pipe-to-block interface

You have just seen that doubling the flow rate had a relatively modest impact on the
performance of the cold plate.  What about the thermal interface between the pipe and the
block?  At the moment, the interface is "zero-resistance", which is the best possible situation.

It's not always easy to obtain a value for this type of thermal interface.  But you can certainly
use Sauna to make some preliminary estimates for a less-than-perfect interface.  You will try
introducing a 0.02 mm (0.001") air gap between the pipe and the block.  Edit the join interface
with:

<F12 Root Menu> ➔ Edit ➔ Join Intrfc ➔ Edge ➔ Air Gap ➔ 0.02mm/.001" ➔ 25
➔ Grp To Model ➔ Select 1 ➔ "pipe>2" ➔ Select 1 ➔ "pipe>5" ➔ USE

Sauna will indicate that "2 edge joins modified".  Now calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain Tctr-junct = 154.30°C, an increase of roughly 30°C.  This clearly show that this
interface is important and requires attention when designing a cold plate.  A thermal epoxy or
gap compound can be very useful for improving this interface.
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Other flow configurations
You have just modeled a cold plate with a simple one-pass configuration, which was followed
by a two-pass configuration.  As you saw, it's not difficult to model these problems.  But there
are lots of other possibilities for cold plates.  For example, consider the flow paths shown in
Figure 19:

Flow In Flow Out

cold plate

Flow In Flow Out

cold plate

Figure 19: Other cold plate flow paths

You may be thinking that these flow paths shown are difficult to handle, but that is not the case.
Some extra steps, and a few assumptions, are required, but Sauna can handle the Figure 19
configurations and many others.

Wrapping up

This exercise is complete, you should delete the model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes
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