Thermal
Solutions
Sauna™ V4.5 Release Notes
Welcome to Version V4.5 of the Sauna thermal modeling package.

Getting started with Sauna V4.5
Please begin by reading “Sauna V4.5 New Features List” on the next page.
When you are ready to begin using Sauna V4.5, work through "Using Raw Data Control Elements", which
starts on page 4. This is a brief exercise which takes around 20 minutes to complete.

Installation
To install or update Sauna, see the “Installation” chapter in the Sauna User Manual. The method is the
same as for previous Sauna releases.

Sauna is a trademark of Thermal Solutions Inc.
Thermal Solutions Inc., 3135 S. State St., Suite 350C, Ann Arbor MI 48108 www.thermalsoftware.com 734-761-1956

Sauna V4.5 New Features List
Much larger models are possible
•

100,000 nodes for Sauna Modeling System (previously 15,000 node limit)

•

20,000 nodes for Sauna Standard (previously 7,500 nodes)

More complex duty cycle problems (Sauna MS feature)
•

1,000,000 steps allowed (1,000 previously)
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Random power profile, model with “raw data” control elements

New raw data control elements (Sauna MS feature)
•

use for random power data from experimental measurements or simulations

•

scripting is not required, input is from a tab or comma delineated spreadsheet file
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Simplify raw data control elements to obtain results quickly

New tools for simplifying complex raw data control elements
•

define a simplification factor

•

apply to entire dataset or only a portion

•

obtain preliminary results in minutes

Product refinements
•

faster drawing of models

•

easier to change layer visibility

•

bug fixes

Available December 2017
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Using Raw Data Control Elements
The Sauna Modeling System version is required to work this exercise.
For a number of years, Sauna has provided the ability to define power and temperature duty
cycles. This has been handled with control elements which make use of a simple scripting
language. The scripting language makes it easy to create square waves, ramps and loops. This
classic Sauna method is described in Supplemental Exercise 1: Transient And Duty Cycle Modeling.
The scripting method has performed well over the years. However, it was awkward to work
with a large set of random data, such as the power curve shown in Figure 1:
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Figure 1: Random power curve

The power curve in Figure 1 has 1000 steps, which means that it can be converted into a script.
But a number of users indicated that they would prefer to work with raw data in a simple
spreadsheet format, without having to add a script header or commands. With Sauna V4.5 this
is now possible.
But raw data input quickly introduces another issue: calculation time. The raw data is typically
generated from measurements or a simulation program. This tends to produce large numbers
of data points, 50K or 100K data points is not unusual. So while Sauna has been modified to
accept this number of points, the calculation times can be be unwieldly. A product goal with
Sauna has always been to provide results quickly. But a medium sized model with 50K point
duty cycle may need hours to complete the calculation. So an important part of the raw data
enhancement was to provide simplification tools so that a preliminary result can be obtained in
minutes, not hours.
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A simple example: ramp.dty
The Reference Models folder contains the file "ramp.dty". This file contains this power-time
data (and nothing else):
0,0
1,.1
2,.2
3,.3
4,.4
5,.5
...
25,2.5
26,2.6
27,2.7
28,2.8
29,2.9
30,3.0

So ramp.dty is a simple series of data points which can be opened and edited with any
spreadsheet program.
Now you will create a control element which is based on this data. Begin with:
<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ File Link

You will reach the File Link menu:
FILE LINK
>1 Full Script
2 Raw Data

"Full Script" is the old method. You will be using the new method, "Raw Data". Because you
are using this option, you will be required to supply some additional information such as
control type, time units, etc. With "Full Script" this information is contained in the external file,
but with "Raw Data" you define this information within Sauna.
Continue with:
Raw Data ➔ Q vs Time ➔ "ramp1" ➔ Seconds ➔ 1 ➔ Fixed Node ➔ Comma
➔ navigate to Reference Models folder ➔ select "ramp.dty" ➔ click Open

Sauna will indicate that "Control element "ramp1" successfully created."
This is a control element, so there is nothing on the screen to see. Start by obtaining a basic text
report:
<F7 Info> ➔ Control Element ➔ Text Report ➔ Enter Label ➔ "ramp1" ➔ Screen

There is some useful information at the top of the report. Note that the report shows the total
time (30 seconds), the time average value (1.5), and the total number of steps (30). Notice that
simplification is currently off. At the bottom of the report you will see the time/value data for
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the 30 steps. You should note that ", ramp" was added for each pair. This was not in the
original file but was added automatically by Sauna.
Clear the report from the screen, then obtain a graph:
Graph ➔ Time Base ➔ Stairsteps ➔ Seconds ➔ All ➔ Screen

The graph is shown in Figure 2. You can clearly see a linearly increasing series of steps, varying
between 0.0 and 3.0 over 30 seconds. The time interval is uniform at 1 seconds, but uniform
time interval is not a requirement for raw data control elements. The time average value is 1.5,
which was shown in the text report.
Clear the graph before moving to the next section.
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Figure 2: Ramp duty cycle

Simplifying raw data control elements
Although the current control is rather simple, it is useful for learning about the different raw
data simplification options. To simplify, begin with:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw
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You will reach the Simplify menu:

>1
2
3
4
5
6
7
8

SIMPLIFY
Simplif Off
x 2
x 5
x 10
x 100
x 1000
Enter Factor
Max Possible

If you choose "x 2", each two steps will be combined together. For "x 5", five steps will be
combined, etc. The "Max Possible" option is probably intriguing. This option combines all of
the steps into a single square step at the time average value. This may seem odd at first, but it's
very useful for simplify a portion of the raw data.
Use the "x 5" option, then graph the simplified control element:
x 5 ➔ Entire Ctrl ➔ All
<F7 Info> ➔ Control Element ➔ Graph ➔ Time Base ➔ Stairsteps ➔ Seconds ➔ All ➔ Screen

Now the graph shows 6 steps, instead of 30 previously.
Clear the graph and try the "Max possible" option:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ Max Possible
➔ Entire Ctrl ➔ All
<F7 Info> ➔ Control Element ➔ Graph ➔ Time Base ➔ Stairsteps ➔ Seconds ➔ All ➔ Screen

Now the graph shows a single step at the time average value of 1.5. This doesn't make a lot of
sense for this control element, but as you will see, it's useful in other situations. Clear the graph
before continuing.

Simplifying a portion of the control
It's quite common to have random data where there is high power for just 5 or 10% of the total
duty cycle (for example, see Figure 1). So it's extremely useful to be able to simplify the
unimportant ranges and use fine resolution only for the area of high power. For this reason you
can simplify just a portion of the control element.
Simplify the first half of the control element as follows:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ x 5 ➔ Specify Time
➔ Seconds ➔ "0,15" ➔ All
<F7 Info> ➔ Control Element ➔ Graph ➔ Time Base ➔ Stairsteps ➔ Seconds ➔ All ➔ Screen

The graph will be as shown in Figure 3 on the next page:
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Figure 3: Simplified ramp control element

With this change, you can see how some control elements can be simplified dramatically.

Working with more complicated raw data
Now you will move on to something significantly more complex. Begin by deleting the existing
control element:
<F12 Root Menu> ➔ Delete ➔ Control Elem ➔ Delete All ➔ click Yes button

Open new_sink.smf from the Reference Models folder:
<F12 Root Menu> ➔ File ➔ Open ➔ navigate to Reference Models folder
➔ select new_sink.smf ➔ click Open button
click

"new_sink.smf" is the model created in the first introductory exercise. Now create a raw data
control element using random.dty from the Reference Models folder:
<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ File Link ➔ Raw Data ➔ Q vs Time
➔ "random1" ➔ Seconds ➔ 1 ➔ Fixed Node ➔ Comma ➔ select "random.dty" ➔ click Open

Sauna will indicate that "Control element "random1" successfully created".
Obtain a graph of the control element:
<F7 Info> ➔ Control Element ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Seconds ➔ All ➔ Screen
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The graph will be as shown in Figure 1. Examination of the graph will show that it is identical
to Figure 1. Clear the graph, then obtain a text report:
<F7 Info> ➔ Control Element ➔ Text Report ➔ Enter Label ➔ "*" ➔ Screen

The report will indicate that the duration is 100 seconds, the time average value is 0.46 and there
are a total of 1000 steps.
Fortunately this model is relatively simple, so it's possible to do a full calculation in a minute or
so. After clearing the report, assign the control element to the heat source:
<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔ Time Base ➔ Q vs Time ➔ "*"
➔ Heat Source ➔ All In Wind ➔ USE

Next, control elements provide a wattage ratio. At the moment, the wattage of the heat source
is 40W and the maximum wattage ratio of the control element is 24, providing a peak wattage of
960W. This is clearly too much. So reduce the wattage to 5 watts, which brings the peak
wattage down to 120 watts. Make the change:
<F12 Root Menu> ➔ Edit ➔ Heat Input ➔ Basic Source ➔ Wattage ➔ "5" ➔ All In Wind ➔ USE

Now is a good time to save the model with a new name:
<F12 Root Menu> ➔ File ➔ Save As ➔ navigate to a new working folder
➔ type "sink_raw" in file name box ➔ click Save button

Now perform the full duty cycle calculation:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default ➔ Natural ➔ "25"

When the calculation is complete, you will see TS1-junct = 26.55°C. But you need to obtain a
transient report:
<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Seconds ➔ Graph ➔ Screen

The graph will be as shown in Figure 4 on the next page. Note that the peak TS1-junct is 90°C and
this value is reached at about 57 seconds. If you are only interested in peak temperatures,
everything after this could be deleted. This could easily be done by opening random.dty in a
spreadsheet program, or even a text editor, and deleting all the cells from 58 seconds onward.
No changes are necessary within Sauna. You won't do this now, but it's easy to accomplish.
Clear the graph before continuing.

9

Temperature vs. Time Plot
-------------------------

Temp (˚C)
100

S1 (junct)
S1 (case)

90

80

70

60

50

40

30

20
0.00

20.00

40.00

60.00

80.00

100.00

Time (seconds)

Figure 4: Temperature vs. time for heat source

Simplifying the control element
Now you will experiment with simplification. It did not take long to perform the duty cycle
calculation with this model, but that will certainly not be the case for all models.
Try simplifying the entire duty cycle by a factor of 10:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ x 10 ➔ Entire Ctrl ➔ All

Graph the simplified control element:
<F7 Info> ➔ Control Element ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Seconds ➔ All ➔ Screen

The graph will be as shown in Figure 5 on the next page. With the graph on the screen, you will
see that the peak wattage ratio has dropped from 24 to 6.3. So you can't use the simplified
control element to accurately predict temperatures in this case. But it's still interesting to
calculate temperatures.
Clear the graph, then recalculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default ➔ Natural ➔ "25"

The calculation will be substantially quicker, because the number of steps has been reduced by
a factor of 10. As before, TS1-junct = 26.55°C.
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Figure 5: Simplified control element

Obtain a temperature graph:
<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Seconds ➔ Graph ➔ Screen

The graph shows the same general pattern as before. But the peak temperature has been
reduced from 90°C to 52°C. So was this calculation a waste of time? Not really. This graph
clearly shows that the peak occurs at around 56 seconds. For many sets of data, it is not obvious
where peak temperatures will occur. A simplified duty cycle can be very valuable for
identifying the time period where peak temperatures occur. It can be concluded that an
excellent strategy for this data set is to simplify everything before 40 seconds, than calculate at
full resolution for the latter part of the duty cycle.
Clear the graph before continuing.
Edit the control element to simplify only the first 40 seconds and graph the result:
<F12 Root Menu> ➔ Edit ➔ Control Elem ➔ Time Base ➔ Simplify Raw ➔ x 10
➔ Specify Time ➔ Seconds ➔ "0,40" ➔ All
<F7 Info> ➔ Control Element ➔ Graph ➔ Time Base ➔ Show Ramp ➔ Seconds ➔ All ➔ Screen

The graph will be as shown in Figure 6 on the next page.
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Figure 6: Simplified control, first 40 seconds only

Clear the graph and calculate temperatures:
<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized ➔ Default ➔ Natural ➔ "25"

Once again, TS1-junct = 26.55°C. But, as always, a graph is necessary:
<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE
➔ Seconds ➔ Graph ➔ Screen

While temperatures in the first half of the curve are different due to the simplification, the same
TS1-junct = 90°C is reached. The simplification was successful.
This exercise is complete, you can delete the model:
<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button
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