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Sauna™ V4.40 Release Notes
Welcome to Version V4.40 of the Sauna thermal modeling package.

Getting started with Sauna V4.40
Please begin by reading “Sauna V4.40 New Features List” on the next page.
When you are ready to begin using Sauna V4.40, work through "Sauna V4.40 Tour", which starts on
page 6. This is a brief exercise which takes around 15 minutes to complete.
If you will be modeling LED components, be sure to work through "Modeling LED Boards with Sauna".
This is a comprehensive 20 page exercise which provides valuable information about LED package
construction, the correct use of LED datasheets and, of course, complete information on the methods and
assumptions used by Sauna.

Installation
To install or update Sauna, see the “Installation” chapter in the Sauna User Manual. The method is the
same as for previous Sauna releases.

Sauna is a trademark of Thermal Solutions Inc.
Thermal Solutions Inc., 3135 S. State St., Suite 350C, Ann Arbor MI 48108 www.thermalsoftware.com 734-761-1956

Sauna V4.40 New Features List
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Figure 1: Many new packages for Sauna's library

Significant expansion of Sauna's component library
•

more power MOSFET packages (TOLL, TDSON-8, TSDSON-8 (shrink), TDSON-8 Dual,
Super SO8, S308)

•

diodes (SMA, SMB, SMC, SOD123F)

•

many more LED packages
- PLCC generic (PLCC-2, Mini PLCC-2, 3x1.4 PLCC-2, PLCC-4, PLCC-4/Slug, PLCC-6/RGB)
- Nichia (PLCC-2, 2x1.4 Plastic, 3x1.4 Plastic, 3x3 Plastic, 3x3 Ceramic, 3.5x3.5 Ceramic,
3.5x3.5 Ceramic with thermal pad)
- Osram (TopLED, PowerTopLED, Mini TopLED, 3x1.4 TopLED, MULTILED,
Duris E2/E5/P5/P8/P10/S2/S5/S10, Oslon Black, Oslon Signal, Oslon Square)
- Cree (ML-E, XB-D, XH-B, XM-L, XP-C, XT-E)

2

More detailed thermal data for library components
•

power MOSFETS: separate thermal resistance for source and gate, in addition to the Rjc for the drain

•

LED's: thermal resistance data provided for both cathode and anode

Multi-die packages now supported
•

Sauna V4.4 includes TDSON dual and PLCC-6/RGB,

•

entire multi-die package is added in one step, but you can separately modify wattage and duty
cycle for each die

•

additional multi-die packages in future releases
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with offset
heat slug

Figure 2: New single package type

New single package type
•

lower/center/upper lead options

•

slug pad may be included

•

new options for offset leads and slug pad

•

many uses:
- "DPAK-style" devices
- LED packages with large cathode pad
- can be used to model coils and leaded resistors
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Faster creation of heatsinking pads and traces
•

when pads are first created, you can specify a special heatsinking pad size and create traces,
all with a single command

•

these features available for all component types, including SOT-223, LED's, diodes, etc.

Smarter mesh alignment
•

for components which are cooled through external tabs, such as the SOT-223 and PLCC-2/4,
Sauna aligns the mesh to match the external tab

•

greatly simplifies mesh alignment for these components

New editing options for enhanced sources
•

directly specify junction-to-top resistance

•

edit interface type underneath component (air gap, greased, epoxy, etc.)

•

edit body material to easily switch between plastic, ceramic or user defined material

Easy to change visibility of multiple layers
•

instead of turning on or off a single layer, you can now specify multiple layers

•

use ";;" separator to specify multiple layers

•

example: to turn off the left and top walls of a box, specify "left;;top"

Even more useful new features
•

better shade mode drawing of traces and pads (smart edge suppression)

•

for traces and pads underneath enhanced sources, can now update dimensions without
first disconnecting the heat source (source is disconnected and reconnected automatically)

•

can add labels to ref points

•

added 1.5 pt lines

•

if Rlead-pad is non-uniform, the report lists out individual values (can also obtain Rlead_pad with
Info ➔ Trap ➔ Plate ➔ trap a lead pad)

•

lines can be linked to an enhanced source body assembly
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•

can turn off contours for board nodes, while showing contours for traces

•

new materials
- silicon carbide 4H (k = 0.37°W/mm-°C)
- silicon nitride SN90 (k = 0.09°W/mm-°C)
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Sauna V4.40 Tour
This exercise introduces the new features found in Sauna V4.40 and highlights the way that the
software has evolved from Sauna V4.35.

Larger library, new tools for creating pads
You will be start by creating the pad configuration shown in Figure 3. This is much easier to do
with Sauna V4.40.
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Figure 3: DPAK and PLCC-2 with oversized pads

Begin by creating a 75 mm x 75 mm circuit board:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Circuit Brd ➔ hit <Enter> to skip ➔ Rectangle
➔ Vertical XY ➔ "75,75" ➔ .062"/1.57mm ➔ (0,0,0) ➔ FR4 ➔ Zer/Lam Only
➔ .025"/0.64mm ➔ One oz. ➔ None

The board will be created. Now you will create the DPAK pads and traces. With Sauna V4.35
this was a five step process: (1) create default slug pad and lead pads, (2) enlarge slug pad and
(3-5) create three traces. With Sauna V4.40, it's all done with a single command. Begin with:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side
➔ trap circuit board ➔ Component ➔ One oz. ➔ Pad Library
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You will reach the Pad Library menu:
PAD LIBRARY
DPAK's
TDSON/TOLL
Single/Dual
Quad
Diodes
LED's
Resistor

1
2
3
4
5
6
7

This menu has been reorganized to reflect the new packages in the library. The "Diodes" and
"TDSON/TOLL" categories are new and the "Dual Plastic" category has become "Single/Dual".
The SOT-223 package is found in "Single/Dual".
Finish creating the pads and traces with:
DPAK's ➔ DPAK ➔ 2 ➔ Specify ➔ "12,9" ➔ 15 mm/0.6 ➔ 0.50mm/20mil ➔ Yes ➔ 0 Degrees
➔ Coords/Trap ➔ "15,55"

The pads and traces will be created.
Now create the rotated version of the pads:
DPAK ➔ 2 ➔ Specify ➔ "12,9" ➔ 15 mm/0.6 ➔ 0.50mm/20mil ➔ Yes ➔ +90
➔ Coords/Trap ➔ "35,55"

The rotated pads will be created. Notice that when you specified the pad size for the slug, you
specified 12 wide x 9 high for both cases, even though the the final size of the right pad is
9 wide x 12 high. With Sauna you specify pad size before rotation.
Sauna V4.40 also makes it easy to specify enlarged pads and traces for LED's and diodes. Begin
creating the PLCC-2 pads:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad
➔ trap trace or pad on front layer ➔ Pad Library ➔ LED's

You will reach the LED's menu:

1
2
3
4
5
6

LED'S
PLCC
Cree
Nichia
Osram
Spec Dual
Spec Single

Many LED packages have been added for Sauna V4.40. With Sauna V4.35, only the PLCC-2 and
PLCC-4 packages were available. Now there are a total of 36 LED packages.
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Continue with:
PLCC ➔ PLCC-2 ➔ Specify ➔ "8,5" ➔ 15 mm/0.4" ➔ 0.50mm/20mil ➔ 0 Degrees
➔ Coords/Trap ➔ "60,25"

The LED pads and traces will be created.

More detailed thermal data for library components
Begin creating a 1W enhanced heat source for the left DPAK pads:
<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ DPAK's ➔ "1" ➔ "S1" ➔ DPAK
➔ 2 ➔ Typical

You will reach the R_lead_pad menu:
R_LEAD_PAD
Typ-1500 C/W
Enter Resis
Enter R_para
No Lead Conn

>1
2
3
4

You will be using "Typ-1500 C/W" which will establish a thermal resistance of 1500°C/W
between the junction and both lead pads. This should be considered a generic value that works
for a variety of package styles where currents do not exceed one or two amperes. While DPAK
packages are sometimes used for high current applications, they are also used for lower current
devices. So, for DPAK’s, it makes sense to use Rlead-pad = 1500°C/W as a typical value for both
leads. Other packages, however, will require a more detailed approach, as discussed below.
Complete creating the DPAK source:
Typ-1500 C/W ➔ Ref Point ➔ trap reference point for left DPAK

The left DPAK source will be created. Now create the middle DPAK:
DPAK's ➔ "1" ➔ "S2" ➔ DPAK ➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point
➔ trap reference point for middle DPAK

The middle DPAK source will be created.
Next you will create the LED device. The thermal specification of LED's is a bit different from
other devices. If you expect to do simulations with LED's, be sure to read "Modeling LED
Boards with Sauna", which is included with the release notes. With an LED in a PLCC-2
package, the thermal resistance for one lead (the "thermal lead") is substantially less than for the
other lead.
Begin creating the LED source:
<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ LED's ➔ ".2" ➔ "S3" ➔ PLCC
➔ PLCC-2 ➔ Typ (0.1 mm)
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You will reach a different version of the R_lead_pad menu:
R_LEAD_PAD
Typ/Library
Enter Resis
Enter R-Para
No Lead Conn

>1
2
3
4

With "Typ/Library" Sauna provides Rlead-pad values from the library which better match the
specific package. Also, R lead-pad is not necessarily the same for all leads. Complete creation of
the source with:
Typ/Library ➔ Ref Point ➔ trap PLCC reference point

The heat source will be created. It's very informative to get a report for the LED heat source:
<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ trap LED source

On the second page of the report, at the bottom of the page, the report lists out the Rlead-pad
values, from bottom to top (pre-rotation). For an LED, the "thermal lead" is always in the
bottom position (pre-rotation). With 180°C/W for the thermal lead and 1000°C/W for the nonthermal lead, you will obtain around 400°C/W for Rja with 16mm2 pads for both pads. This
matches the Rja provided by LED vendors (some vendors a bit higher, some a bit lower).
There is another way to check Rlead-pad. After clearing the heat source report, isolate the front
laminate layer and zoom in around the PLCC-2 source:
<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Copp>1
<F3 Zoom In> ➔ zoom in to match Figure 4

trap
here

Y
X

Figure 4: Trapping lower lead pad
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Now get a report for the lower lead pad:
<F7 Info> ➔ Trap ➔ Plate ➔ trap as shown in Figure 4

Under "-- Trace/Pad Properties --" on the first page, you should see "Assigned as lead pad : Yes"
and the source-to-pad resistance of 180°C/W will be listed. (If it's not assigned as a lead pad,
you trapped the wrong pad, so try again). If you want to get the correct result, you need to
properly assign Rlead-pad, so be sure to check values.
After clearing the report, restore visiblity and zoom out:
click

➔ click

For all of the newly-added LED packages, you will see "Typ/Library" when specifying Rlead-pad.
This is also the case for the new power mosfet packages (TDSON, TSDSON, TOLL) and new
diode packages.

New tools for modifying pads and traces
Now, as shown in Figure 5, you will modify the traces and pads for the middle DPAK.
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pad is 15 wide x 20 high
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X

Figure 5: New trace and pad configuration for middle DPAK

You will start by resizing the slug pad to 15 mm wide x 20 mm high. In Sauna V4.35, you had
to start by disconnecting the heat source. But this is no longer necessary. Change the
Y-dimension first:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Dimensions ➔ Modify Y ➔ Enter Dimen ➔ "20"
➔ Center ➔ Select 1 ➔ trap slug pad for middle DPAK ➔ USE

10

The height of the pad will be modified. Now change the X-dimension:
Modify X ➔ Enter Dimen ➔ "15" ➔ End ➔ Select 1 ➔ trap slug pad for middle DPAK ➔ USE

The pad will have the size shown in Figure 5.
Whenever the dimensions of a trace or pad are changed, Sauna checks to see if the trace or pad
is underneath an enhanced source. If so, the enhanced source is disconnected, then reconnected
when the modification is complete. So it is extremely easy to try multiple sizes for a slug pad.
Things, however, are a bit more complicated for the lead pads. As explained in Introductory
Exercise 5: Basics Of Circuit Board Modeling, lead pad dimensions should not be modified. You
have to modify the pads around the lead pad, not the lead pad itself.
Now you need to extend the traces. Sauna has a command for shifting the endpoint of a trace
( Edit ➔ Plate/Board ➔ Dimensions ➔ Trace/Pad ➔ Shift Endpt). But with this command you have
to modify the traces one-by-one. The better way is to follow the same approach as for
modifying slug pad dimensions:
Modify X ➔ Limit Point ➔ Trap ➔ trap right edge of board ➔ Origin ➔ Select Regn
➔ grouping rectangle to include 3 traces ➔ USE

The three traces will be extended to the edge of the board to match Figure 5.

Single package style
As shown in Figure 6, Sauna V4.40 includes a new single package style.

Center leads,
no heat slug

Lower leads
with heat slug
(Dpak-style)

Upper leads
with offset
heat slug

Figure 6: Single package style

If you examine Figure 6, it should seem logical that all of these packages are classified as
"singles". If you create such a package yourself, Sauna lets you specifiy offsets so that the slug
pad and lead pads are moved relative to the center of the part.
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But single packages are used in other situations that are not so obvious. Figure 7 shows the pad
configuration for a Nichia 3 x 3 package. This LED device could be modeled as either a “single”
or a “double”.
Begin creating pads for the Nichia package:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad
➔ trap trace or pad on front layer ➔ Pad Library ➔ LED's ➔ Nichia
➔ 3x3 Plastic ➔ Minimum ➔ 15 mm/0.6" ➔ 0.50mm/20mil

You will reach the Slug Pad menu:
SLUG PAD
>1 Default
2 Specify
3 Not Used

When you see this menu, you can be assured that Sauna is handling the LED package as a
"single". The cathode (thermal pad) is treated as the heat slug while the anode is an ordinary
lead. Complete creation of the pads:
Default ➔ 0 Degrees ➔ Coords/Trap ➔ "30,25"

The pads will be created. Return to the Root menu, then zoom in and turn on shade mode:
<F12 Root Menu>
<F3 Zoom In> ➔ zoom in to match Figure 7
click

The screen will match Figure 7.

anode is ordinary lead

cathode (thermal lead)
handled as heat slug

Y
X

Figure 7: Pads for Nichia 3x3 plastic package
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Now add the heat source (notice the position of the reference point):
<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ LED's ➔ ".2" ➔ "S4" ➔ Nichia
➔ 3x3 Plastic ➔ Use Library ➔ Typ (0.1 mm) ➔ Typ-1500 C/W ➔ Ref Point ➔ trap ref point

The heat source will be created. Get an info report:
<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ trap S4 source

On the first page, note that the number of leads is "1". Since the cathode is treated as a heat
slug, there is only one ordinary lead, the anode. If you go to the second page, you will see that
the diepad dimensions are 2.4 x 1.6, which matches the size of the cathode.
This part could have been modeled as either a single or a dual. But by modeling as a single
component with heat slug, it's much easiier to try different pad sizes for the cathode. That is the
advantage of modeling as a single.

New ways to specify layers
To illustrate the layer specification enhancement, you will create a simple box model. Begin by
deleting the current model:
<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

Now create a six-sided box:
<F12 Root Menu> ➔ Model ➔ Assembly ➔ Box ➔ Multi-Plate ➔ "100,50,100" ➔ (0,0,0)
➔ Uniform ➔ "2" ➔ Mainly Horz ➔ Aluminum ➔ Extruded ➔ Anodized ➔ Anodized

The box will be created. Next, slice the back wall:
<F12 Root Menu> ➔ Edit ➔ Plate/Board ➔ Subdivide ➔ Line Slice ➔ Dbl X-Coord ➔ Enter Value
➔ "20" ➔ Enter Value ➔ "50" ➔ Select 1 ➔ "back" ➔ USE

Switch to a perspective view:
click

In the perspective view, you can see that the back wall has been sliced. Now get a detailed list
of all assemblies in the model:
<F7 Info> ➔ Assemblies ➔ List/Detail ➔ Screen

In the report, notice that the back wall is made up of three assemblies: "Back", "Back>2",
"Back>3". All of the assemblies start with "back", so if you enter a layer as "back", all of these
assemblies will be in the layer. After clearing the report, isolate the back wall assemblies:
<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Enter Prefix ➔ "back"

Just the three back wall assemblies will be visible.
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With Sauna V4.40 you can specify multiple layers by using the ";;" separator. To isolate the left
and back walls, enter:
Enter Prefix ➔ "back;;left"

You will see the three back wall assemblies and the left wall. Actually, you can specify a layer
with even fewer characters. For example, isolate the bottom and back walls with:
Enter Prefix ➔ "bo;;ba"

You will see the bottom and back wall assemblies.
For complicated models, layers are extremely useful for modifying visibility. However, since
layering is based on assembly labels, it’s important that you assign organized labels to your
assemblies. If you take the time to do this, you will be able to change visibility efficiently. And
it will make your reports much easier to understand.
This concludes the Sauna V4.40 Tour. You should delete the model:
<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button
16 Mar 17

14

