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Introductory Exercise 3: A Non-Uniform Heat Sink

In the third introductory exercise, you will be modeling this heat sink:

15

75

70

25 W, TO-218 package, 
greased interface, Rjc = 1.5

modified sink from first exercise

•  Material:  cast 380 aluminum
•  Surface:  white paint and bare aluminum
•  Cooling:  natural convection and radiation
•  Ambient temperature  =  25°C
•  Assume dissipation from only the finned side of the sink
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Figure 2-12: Heat sink for exercise 3

In this exercise, you will be creating a thermal model which is comprised of 3 plate assemblies
joined together.  The left finned plate will be obtained by loading the sink from the first exercise
and modifying it to have the proper dimensions and material.  The right vertical plate and
horizontal shelf will be created as part of the exercise.

You will start by loading the model (“new_sink.smf”) that you saved in the first exercise.  The
same model is available at “C:Program Files (x86)\Sauna Thermal Modeling\Reference Models”.
Load the model now:

<F12 Root Menu> ➔ File ➔ Open ➔ select new_sink.smf ➔ click Open button

The model will be loaded and drawn on the screen.

Deleting the heat source, additional grouping options

To create the complex sink, you will need to modify the plate model that you just loaded.  The
first step will be to delete the footprint heat source.  At the same time, you will learn some
additional ways to use the grouping menus.
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If you are not currently using a front orthogonal view, change the view:

click  Front

Make these menu selections:

<F12 Root Menu> ➔ Delete ➔ Node

You will reach the Node Type menu which let's you choose the type of node to delete.  Choose
"Any Node" (not "Heat Source").  You will go to the Node Group grouping menu.

In a moment, you will be choosing "Select Regn" (select region).  With "Select Regn" you define
a grouping rectangle in the same way that you defined a zoom rectangle in the first exercise.
You will digitize two times to define the grouping rectangle.  (With Sauna, digitize means “click
and release”, it’s not “hold the mouse button down and drag”.)

“Select Regn” lets you to select a number of nodes at the same time.  You will be defining the
grouping rectangle shown in Figure 2-13:
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Figure 2-13: Use this grouping rectangle

Now, group the nodes with:

Select Regn ➔ digitize upper-left corner of grouping rectangle
➔ digitize lower-right corner

A total of 26 nodes will be added to the group, the heat source plus 25 nodes from the plate.
This is clearly not what you want.  The Node Group grouping menu let's you choose any node
type, while you only want to delete the heat source node.

Choose "Clear Group".  Sauna will empty out the group so that no damage has been done.  Since
you never chose "USE", nothing has changed in the thermal model.  (If for some reason you got
confused and did choose "USE", just use Edit ➔ Undo and try again!)
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Now go to the proper grouping menu:

<F2 Backup> ➔ Heat Source ➔ Any Source

You will be at the Source Node menu.  With this menu you can only select heat source nodes.

Notice that there is just one heat source node in the entire thermal model.  This gives us an
opportunity to try a useful shortcut.  Choose "All In Wind".  The one and only heat source will be
placed in the group.  "All In Wind" causes Sauna to place all elements of a particular type in the
group, provided that the elements are visible in the current graphics window.

Finally, choose "USE" to delete the heat source.

Additional modifications to the finned plate

Switch to a perspective view:

click  

In the new model the finned section has a width of 100 mm, compared with 200 mm for the
initial model.  To change the width of the finned plate, begin with these commands:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Dimensions ➔ In Plane ➔ Modify X
➔ Enter Dimen ➔ "100"

You will reach the Keep Point menu.  This menu controls whether the finned plate shrinks from
both ends or whether one side of the plate is held constant.  There is a reference picture which
explains this:

click  Picture

For this model, you need to retain the origin point.  After clearing the picture from the screen,
complete the modification with:

Origin ➔ All In Wind ➔ USE

Since the finned plate is now narrower, move the room ambient node over to the left:

<F12 Root Menu> ➔ Move/Copy ➔ Move ➔ Trap 1 Node
➔ trap room ambient node ➔ Dx ➔ "-50"

It isn’t really necessary to move the fixed node.  But the model appears more logical if the fixed
node is positioned closer to the center of the left plate.

Change the plate material to cast aluminum:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Plt/Bar Prop ➔ Material
➔ Aluminum ➔ Cast 380 ➔ All In Wind ➔ USE

To keep the model organized, change the assembly label:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Label/Color ➔ Trap 1 Assy ➔ trap the plate
➔ type "Sink:Left" (no quotes) in text box ➔ click OK button

The label "Sink:Left" was not chosen at random.  When complete, the model will have three
assemblies and all the labels will start with "Sink:".  This will establish a layer within Sauna,
which is very useful for modifying visibility (see the end of the exercise).
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Creating the right vertical plate

Now, you will create the right side of the heat sink.  Begin with:

click  

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Planar Plate ➔ "Sink:Right" ➔ Rectangle
➔ Vertical XY ➔ "70,75,5" ➔ Coords/Trap

Now you are ready to trap the origin point for the new plate.  To properly position the right
plate relative to the left plate, you should trap the point shown in Figure 2-14.  (Remember that
the origin point is the left, front, bottom corner of an assembly.)
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Figure 2-14: Trapping to obtain origin point

Click on the point.  The trapped point will be identified with a small box.  If you inadvertently
trap another point, use <F2 Backup> and try again.

When trapping a point in the thermal model, you are not required to click directly on
top of the desired point.  If you trap along an assembly line segment, Sauna will
automatically snap to the nearest endpoint.  This can be quite useful when there are a
number of assembly lines present.

Besides assemblies, you can trap points from reference points, lines, nodes and resistors.
However, Sauna has a trap priority.  Reference points have the highest priority.  If a reference
point is not available, Sauna will then try to obtain a point from an assembly.  If this is also
unsuccessful, Sauna will try lines, nodes and resistors (in that order).
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Finish creating the right vertical plate with:

Aluminum ➔ Cast 380 ➔ Paint/White

The new plate will be created and the window will be automatically resized to show the entire
model.  To quickly check that the plate was created in the proper position, turn on shade mode:

click  

The shade image should show the right plate in the proper position.  If not, use Edit ➔ Undo and
try again.

Joining plates

Now the left and right plates need to be joined together.  Switch to a front orthogonal view and
join the plates as follows:

click  Front

<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Zero Resis ➔ Trap 2 Assy
➔ trap the left plate ➔ trap the right plate

The necessary resistors will be connected between the two assemblies.  Sauna automatically
checks to ensure that a join is possible between assemblies and compensates for nodes which
are not aligned.

Get an Info Report:

<F7 Info> ➔ Trap ➔ Any Assy ➔ trap right plate

Under the heading "-- Edge Joins --" on the second page, you will see that Sauna also keeps
track of the interface type, join area and total interface resistance.

The Join command is extremely useful, you will use it frequently.  Clear the report from the
screen before continuing.

Creating the horizontal shelf

Now you need to create the horizontal shelf and join it to the right vertical plate.  This will be
done in 3 steps.  First, you will create the horizontal shelf with an origin point of (0,0,0).  Second,
you will move the plate to its proper position relative to the right vertical plate.  Finally, the
horizontal shelf will be joined to the right vertical plate.

Switch to a perspective view and create the horizontal shelf:

click  

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Planar Plate ➔ "Sink:Shelf" ➔ Rectangle
➔ Horizontal ➔ "60,40,10" ➔ (0,0,0) ➔ Aluminum ➔ Cast 380 ➔ Paint/White

The plate has been created with an origin point of (0,0,0).  Notice also that the horizontal shelf
extends into the left finned plate.  Generally speaking, this isn’t legal with Sauna.  You will not
be able to calculate temperatures, or even switch into shade mode, if there is interference
between any two assemblies.
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In a moment, you will move the horizontal shelf to the proper position.  To make this a bit
easier, make fixed nodes and the left finned plate temporarily invisible:

click  

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Any Assy Grp ➔ Select 1
➔ trap finned plate ➔ USE

As models become more complex, it is a good idea to temporarily turn off part of the model.
You will make fewer errors this way.

Begin the move of the horizontal shelf with:

<F12 Root Menu> ➔ Move/Copy ➔ Move ➔ Trap 1 Assy ➔ trap the horizontal shelf

The Offset menu will be displayed:

  OFFSET
1 Dx
2 Dy
3 Dz
4 Dx-Dy-Dz
5 Trap Dx
6 Trap Dy
7 Trap Dz
8 From-To

This menu is used to define the X-Y-Z distances that the selected elements will be moved.  You
will be using "From-To".  As shown in Figure 2-15, the "from" point will be the right, back,
bottom corner of the horizontal shelf.  The "to" point will be 5 mm to left and 15 mm above the
right, front, bottom corner of the right vertical plate.

"From" point

"To" point
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Z

Figure 2-15: "From" and "To" points
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Continue with:

From-To ➔ Coords/Trap ➔ trap right-back-bottom corner of horizontal shelf

The To Point menu will be displayed:

  TO POINT
1 Coords/Trap
2 Digitize
3 Midpoint
4 Ref/Dx
5 Ref/Dy
6 Ref/Dz
7 Ref/Dx-Dy-Dz

The "from" point could be directly trapped.  For the "to" point, you need to trap a reference
point and then enter a Dx-Dy-Dz offset relative to the reference point.  Complete the move with:

Ref/Dx-Dy-Dz ➔ trap right-front-bottom corner of vertical plate ➔ "-5,15"

The plate will be moved.  However, it's probably a good idea to verify that the plate is actually
in the proper position.  Start by resizing the window:

click  

Check the distance between the two corner points:

<F7 Info> ➔ More Info ➔ Measure ➔ Distance ➔ trap right-front-bottom corner of vertical plate
 ➔ trap right-back-bottom corner of horizontal shelf

Sauna should indicate the proper distance (∆x = -5, ∆y = 15, ∆z = 0) between the two corners.  If
you make a mistake, use Undo and try again!

Clear the report before moving to the next section.

Using “Select Regn” to join plates

Switch to a top view and turn on all model elements:

click  Top  ➔ click  

Join the two plates with (see Figure 2-16 on next page):

<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Zero Resis ➔ Group 2 Assy ➔ Select Regn
➔ digitize point (see Figure 2-16) ➔ digitize point ➔ USE

The assemblies will be joined.  Note that “Group 2 Assy” stands for “Group 2 Assemblies”
(place two assemblies in the group).
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grouping rectangle
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Figure 2-16: Grouping rectangle for joining assemblies

You may be wondering why “Select Regn” was used instead of “Trap 2 Assy”.  For a simple
model, like the current model, either method will work fine.  However, as models become
complicated, the use of “Trap 2 Assy” can be dangerous.  If assemblies are close together, you
may inadvertently trap the wrong assembly when using “Trap 2 Assy”.  However, with
“Select Regn”, you have the opportunity to correct errors in selection prior to choosing “USE”.
Also, very importantly, you can select an unlimited number of assemblies with “Select Regn”,
not just one assembly at a time.  For these and other reasons, you must become comfortable
with “Select Regn”.  There is no alternative when you have to work with complex models.

One final comment should be made about grouping regions.  Above, the grouping rectangle did
not fully enclose either plate, yet both plates were selected.  With Sauna, an assembly will be
selected if the grouping rectangle intersects (overlaps) any edge of the assembly.  It isn’t
necessary that the grouping rectangle completely enclose an assembly.  This is different from
some other software packages that require that the selection rectangle completely enclose the
object.  There are advantages and disadvantages to each method.  When you use Sauna, you just
need to be aware that Sauna uses the intersect method.

Completing the model

You are now working in a top orthogonal view.  Keep in mind that although you can easily
switch between a front view, top view, right view, etc., Sauna’s basic coordinate system never
rotates.  You can see this by looking at the coordinate axes in the lower left of the current
window.  You have changed your viewpoint but the coordinate system has not changed.  The
coordinate system is global.  Furthermore, instructions in this manual always refer to this global
coordinate system.  For example, if Sauna instructs you to “trap a horizontal” plate, that means
“trap a plate in the X-Z plane”.  The plate may not look horizontal in the current view, but if the
plate exists in the X-Z plane, it is a horizontal plate.  Similarly, “trap the right edge” means
“trap the edge with the largest X-coordinate”, “trap the front edge” means “trap the edge with
the largest Z-coordinate”, etc.  If you remember these simple rules, you will be comfortable
working in a top view, right view or any other view.
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Returning to the model, begin placing the heat source (Rjc = 1.5°C/W) with:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "25" ➔ "S1" ➔ TO-218 ➔ Specify
➔ “1.5” ➔ Standard ➔ Greased ➔ Plate/Board ➔ One ➔ trap horizontal shelf

You will reach the Position menu:

  POSITION
1 Coords/Trap
2 Digitize
3 Midpoint
4 Ref/Dx
5 Ref/Dy
6 Ref/Dz
7 Ref/Dx-Dy-Dz
8 Ref/Options

Just as above for defining the "to" point, choose "Ref/Dx-Dy-Dz":

Ref/Dx-Dy-Dz ➔ trap left-front corner of horizontal shelf ➔ "44,0,-22"

The heat source will be placed as shown in Figure 2-17:
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Figure 2-17: Heat source on shelf

If you look at the figure, you will see that the heat source is attached to the shelf with
2 case-›sink resistors.  As you did in the first exercise, you should align the mesh to the heat
source, so you obtain the desired 4 case-to-sink resistors:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source
➔ 4 Node Conn ➔ trap S1 source ➔ Select 1 ➔ trap horizontal shelf ➔ USE

With the finer mesh, there will be 4 case-to-sink resistors.  All that remains is to add an ambient
connection for the right vertical plate:

click  

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd-›Fix ➔ "Room Amb" ➔ Enter Later
➔ Secondary ➔ Select 1 ➔ trap right vertical plate ➔ USE
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Now you can calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain a junction temperature of 160.43°C.  It is always interesting to view the
temperature contours

click   ➔ click  

Deleting joins

Now it is time to learn about deleting joins.  Turn off the contours, modify visibility and switch
to a front view:

click   ➔ click   ➔ click  Front

You will delete the join resistors between the left and right vertical plates.  Once again, you will
use “Group 2 Assy” and define a grouping rectangle which intersects the two vertical plates
(see Figure 2-18):

<F12 Root Menu> ➔ Delete ➔  Join ➔ Edge ➔ Group 2 Assy ➔ Any Assy ➔ Select Regn
➔ digitize point (see Figure 2-18) ➔ digitize point ➔ USE
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Figure 2-18: Grouping rectangle for deleting join

The join will be deleted.

You just deleted a complete join between two assemblies.  However, there are situations where
you may wish to delete individual join resistors.  To do this, perform an ordinary delete and
place only certain edge join resistors in the group (Delete ➔ Resistor ➔ Constant ➔ Edge Join...).

Interference between assemblies

Now that the join has been deleted, you will create interference between the two vertical plates.
Move the left vertical plate:

<F12 Root Menu> ➔ Move/Copy ➔ Move ➔ Trap 1 Assy ➔ trap the left plate ➔ Dx ➔ "5"
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Now, try a join:

<F12 Root Menu> ➔ Model ➔ Join ➔ Edge ➔ Zero Resis ➔ Group 2 Assy ➔ Select Regn
➔ digitize point (see Figure 2-18) ➔ digitize point ➔ USE

The join will be rejected.  These messages will be displayed in the prompt zone:

Interference between Sink:Left, Sink:Right
0 joins created

With Sauna, no interference is allowed between assemblies.  With some solids modeling
programs, this would be an acceptable operation, but not with Sauna.  Try switching into shade
mode:

click  

You won’t be able to switch into shade mode either.  So the interference between assemblies
will need to be corrected.

What-If #1: moving the shelf to the left

In the final part of this exercise, you will do some manipulations to give you practice using
Move/Copy and Join.  When complete, the model will appear as shown in Figure 2-18b on the
next page.  As you make changes, try switching into shade mode from time to time.  This gives
you a good way to do a preliminary check of your model.

First, move the left assembly back to its original position.  Then, re-join the left assembly to the
right assembly with a "zero resistance" interface.  Remember to use Model ➔ Join, not Edit.  (You
use Model commands to create new elements such as nodes or resistors, while the Edit
commands are for modifying existing elements.)

Next, disconnect the horizontal shelf and move it 40 mm to the left.  Finally, join the horizontal
shelf to both vertical plates and recalculate temperatures.  You should obtain a junction
temperature of 144.78°C.
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Figure 2-18b: What-if #1 model
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What-If #2: thicker vertical plates

For the second manipulation, you will modify both vertical plates to have a thickness of 8 mm.
(Tip: if done correctly, this is a very easy modification.)  When you recalculate temperatures you
should obtain a junction temperature of 140.49°C.

Introducing layers

There are three assemblies in the model and all have assembly labels which start with "Sink:".
When one or more assembly labels start with the same characters, there is a layer in the model
and a layer can be used to modify visibility.  To illustrate, enter:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Layer ➔ Enter Prefix ➔ "sink:"

All of the assemblies in the model will be turned off because all of the assembly labels start with
"sink:".  Actually, you didn't even have to type in "sink:", you could just type in "sink" or "si" or
even just "s".  It's all based on starting characters, or prefix.  Restore visiblity with:

<F12 Root Menu> ➔ Visibility ➔ Turn On ➔ Layer ➔ Enter Prefix ➔ "s"

The entire model will be visible again.

The current model is relatively simple, so layers aren't essential.  But as you will see in future
exercises, layers are extremely important when working with circuit boards and complex boxes.

Take a quiz

At this point, you have completed three exercises.  You should be getting comfortable with the
basic concepts used by Sauna, such as origin point, component/secondary side, etc.

There's an easy way to test your knowledge.  Go to the reference picture menu for Sauna basics:

<F11 Help> ➔ Ref Picts ➔ Basics

With this menu you can view the pictures for Sauna basics.  These pictures are associated with
the Picture button for various menus, but they can be also be viewed here.

Thus far, you have been introduced to 6 of the first 7 items: "Origin/End" through "Resis
Types", excluding “Circ Origin”.  You should view each of these 6 pictures.  When you look at
the picture, you should think: "Yes, I know what that is about".  If this is the case for all 6
pictures, you have passed the quiz.  If you are puzzled by a picture, you may want to review the
exercises again or you can contact Technical Support with your questions.  Don't neglect the
basic concepts, you will need this understanding for the next exercise.

Wrapping up

The exercise is now complete.  You should delete the entire thermal model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click the Yes button


