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Introductory Exercise 6: Rectangular Box With Internal Board

In this exercise you will add a board to the box modeled in Introductory Exercise 4: Rectangular
Boxes, as shown in Figure 2-41:

D2PAK package,
2 W, solder interface,
(120,11.6,-120), typ. Rjc

10

Four layer board, 140 x 140,
FR4, 1 oz. plating,
top/bott layers: 10% copper,
internal layers: full plane

14 x 14 LQFP, 2 watts,
100 leads, no heat slug,
Rja = 32˚C/W on 4 lyr brd,
(40,11.6,-40)

box from earlier exercise, front
and top covers not shown 5 watts distributed

over 60 mm x 80 mm

(80,11.6,-20)

Figure 2-41: box with internal board

In Introductory Exercise 4: Rectangular Boxes, rectangular boxes were modeled without dealing
with the details of internal convection and radiation.  This is a reasonable approach provided
that the box is metallic and that all heat sources are directly mounted to the metallic surfaces.
In this case, internal convection and radiation will only have a minor impact on the heat source
temperatures.

However, most electronic boxes have internal circuit boards.  And these circuit boards have
relatively low thermal conductivity.  For these configurations, internal convection and radiation
are of vital importance.

Fortunately, as you will see in this exercise, Sauna is a highly effective modeling program for
boxes with internal boards.  Gap resistors, automatic generation of internal ambient networks,
and gray radiation networks provide the capabilities you need to quickly and accurately model
complete boxes.

Loading the rectangular box

The starting point for this exercise is the first model created in Introductory Exercise 4:
Rectangular Boxes.  This model should be available on your hard disk with the name
"new_box.smf".  (The same model is available in “C:\Program Files (x86)\Sauna Thermal
Modeling\Reference Models”.)
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Open the model file:

<F12 Root Menu> ➔ File ➔ Open ➔ select new_box.smf ➔ click Open button

Turn off fixed nodes, change the view and switch to abbreviated symbols:

click   ➔ click  

<F6 Setup> ➔ Display ➔ Symbols ➔ Abbreviated

In Figure 2-41, there is only one heat source on the back wall.  Delete the right heat source:

<F12 Root Menu> ➔ Delete ➔ Node ➔ Heat Source ➔ Any Source
➔ Select 1 ➔trap right heat source ➔ USE

Adding a planar board to the box

In this exercise, you will try two different approaches with the circuit board: planar and
detailed stackup.  With the planar method, however, there is a complicating factor.  Notice that
there is a quad flat pack (QFP) device on the circuit board.  After working through Introductory
Exercise 5: Basics Of Circuit Board Modeling, you may think that a planar board analysis is not
suitable for this type of component.  But for a first pass analysis, a planar board is acceptable, as
you will see.

You will be using the Brd In Box/Cn ➔ Rect In Box command to create the circuit board.  The
circuit board is 140 mm x 140 mm, which is smaller than the internal dimensions of the box (142
x 142).  So, when you reach the Gap To Wall menu, you will choose an option which allows for
a gap between the wall and the board.

Begin with:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Brd In Box/Cn ➔ Rect In Box ➔ "Main Brd"
➔ Horizontal➔ Minimum ➔ Enter Value ➔ "10" ➔ Enter Gap ➔ "1" ➔ .062”/1.57mm

➔ FR4 ➔ Four ➔ One oz.

You will reach the Cu Coverage (copper coverage) menu:

 CU COVERAGE
>1 5%
 2 0%
 3 10%
 4 25%
 5 50%
 6 75%
 7 100%
 8 Enter

Since you are creating a planar board, you need to specify the average copper coverage over the
four layers of the board.  With two full internal planes and 10% coverage on the outer planes,
the average copper coverage is (2 ∗ 1.0) + (2 ∗ 0.1) / 4 = 55%.  Continue with:

 Enter ➔ “55” ➔ No Join
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Now you will reach the XY/YZ Assy menu.  Note that with this menu you can only select
assemblies in the XY or YZ planes.  Horizontal assemblies can't be added to the group.  This is
logical.  Since you specified that the board is horizontal, only assemblies in the XY and YZ
planes will be used to calculate the circuit board dimensions and origin point.  There are other
Sauna commands which use grouping menus limited to certain planes.

Complete creation of the board with:

All In Wind ➔ USE

The board will be created in the proper position inside the box.  Verify that the board has the
proper characteristics:

<F7 Info> ➔ Trap ➔ Board ➔ trap the board

Make sure that the board dimensions are 140 mm x 140 mm and that the proper copper
properties were used.

Adding the D2PAK device

After clearing the report from the screen, add the D2PAK heat source to the board:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Basic Source ➔ "2" ➔ "S1" ➔ D2PAK ➔ Typical
➔ Solder 0.1mm ➔ Plate/Board ➔ One ➔ trap board ➔ Coords/Trap ➔ "120,,-120"

The heat source will be added to the back-right section of the board.  Although difficult to see in
the current view, there are 4 case-to-sink resistors.  So you do not need to realign the board.

Adding distributed wattage, modeling quad flat pack

Figure 2-41 shows a section of the board with 5 watts of distributed wattage.  On a real board,
this might correspond to a zone of components with modest dissipation and operating well
within the component limits.  The only challenge here is to properly select the board nodes.

But there is still the issue of the quad flat pack.  As explained in Introductory Exercise 5: Basics Of
Circuit Board Modeling, there is no effective way to model this type of quad package with a basic
source.  So you will simply apply distributed wattage over an enlarged footprint for the device.
When the analysis is complete, you will make a rough estimate of Tjunct by using Rja and a local
internal ambient temperature.  In the second half of the exercise, you will perform a more
detailed (and accurate) analysis with an enhanced source.

Isolate the circuit board, then switch to a top view:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Assy Only
➔ Board Group ➔ All In Wind ➔ USE

click  Top

Just the board will be visible.  As mentioned earlier, there are four case-to-sink resistors for S1.

Before adding the distributed wattage, you will create two reference rectangles.  The rectangles
are an aid for selecting the board nodes.  Rectangles are simply line elements that have no effect
on thermal characteristics.

Create a rectangle for the 60 mm x 80 mm area of dissipation:

<F12 Root Menu> ➔ Line/Point ➔ Line ➔ New Line ➔ Rectangle ➔ Coords/Trap ➔ "80,10,-20"
➔ Dx-Dy-Dz ➔ "60,,-80"
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The rectangle will be created.  Now you need to define the heat dissipation area for the QFP.
The body size is 14 x 14, but the leads will certainly assist in spreading the heat over a wider
area.  Since you have seen that the first 10-15 mm of traces are most important, you will
distribute the heat over a 36 x 36 area.  Add the rectangle with:

Rectangle ➔ Coords/Trap ➔ "22,10,-22" ➔ Dx-Dy-Dz ➔ "36,,-36"

The rectangle for the QFP will be added.  Now that the two reference rectangles have been
created, you can easily select the correct nodes.  Begin by adding distributed wattage for the
QFP (see Figure 2-42):

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Node Group ➔ Board Nodes ➔ "2"
➔ Face Area ➔ Select Regn ➔ use digitize point #1 ➔ use digitize point #2 ➔ USE

S1

digitize  
point #1

digitze point #2
X

Z

Figure 2-42: Selecting nodes for distributed wattage

Sauna will indicate that "distributed wattage applied to 64 nodes".  If you got a different
number of nodes, use Edit ➔ Undo and try again.

Now add the distributed wattage for the 60 x 80 rectangle:

Node Group ➔ Board Nodes ➔ "5" ➔ Face Area ➔ Select Regn
➔ use right rectangle for grouping ➔ USE

This time you should see the message "distributed wattage applied to 192 nodes".  Verify the
model wattage:

<F7 Info> ➔ Heat Load ➔ Input ➔ With Supers ➔ Screen

Under the heading "-- Wattage Totals --", the report should indicate that Qtotal = 24W.  After
verifying the total heat load, clear the report.
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The rectangles can now be deleted:

<F12 Root Menu> ➔ Delete ➔ Line/Point ➔ Line ➔ All In Wind ➔ USE

The rectangles will be deleted.  Of course, since the rectangles have no impact on thermal
characteristics, it is not actually necessary to delete these elements

Before moving on, it should be noted that there is an even quicker way to model the board
dissipation.  Instead of defining two zones of dissipation, you could simply assign a total of 7
watts to the entire board.  For a quick model, this would be fine.

Gap resistors

In today's dense electronic packages, it is very common to find parallel boards or plates
separated by air gaps of between 2 and 10 mm (0.1" to 0.4").  In the box that you are now
modeling, there is such a gap between the main board and the bottom cover.

When thin air gaps (less than about 10 mm) are present, the air enclosed between the parallel
surfaces is largely stationary.  Heat is transferred only through direct conduction and radiation.
Although air is not moving, significant amounts of heat can be dissipated through gaps.  And,
the thinner the gap, the better the heat transfer.  Heat transfer across gaps is an important part of
enclosure heat flow.

To model this parallel surface configuration, Sauna provides "gap resistors".  As you are about
to see, gap resistors are extremely easy to use.

Begin creating the gap resistors with:

click   ➔ click  Front

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Float ➔ Gap ➔ Cond/Radtn
➔ Convectn OK ➔ Horizontal ➔ 100% Area

You will reach the Conn Type menu:

  CONN TYPE
>1 Entire Assy
 2 Zone Points

There are 2 connection options when you create gap resistors.  Most commonly, you will use
the default, "Entire Assy".  With "Entire Assy", gap resistors will be created between any part of
the assemblies which overlap.  However, for complex enclosures you may wish to have gap
resistors (or other float resistor types) over only a portion of the possible area.  In this case, you
would choose "Zone Points".  With zone points you use 2 points to specify the rectangular zone
where gap resistors are to be created.  For this exercise, you will use "Entire Assy".

Continue creating the gap resistors with:

 Entire Assy

You will reach the Horz Plt/Bd menu.  Since you specified "Horizontal" earlier on, you will use
a grouping menu limited to horizontal assemblies.
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Finish creating the gap resistors with:

place board and bottom cover in group ➔ USE

If the instruction “place board and bottom cover in group” does not make sense, please refer to the
top of page 2-56 in Introductory Exercise 4: Rectangular Boxes.

Sauna will indicate “1024 gap resistors created, area = 1.96E+4”.  To better see how Sauna has
created the gap resistors, modify visibility as follows:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Assembly ➔ Intrnl Flt ➔ By Plane
➔ Any Assy ➔ Horiz/Y-Axis

The screen will appear as shown in Figure 2-43:

S1

gap resistors

X

Y

Figure 2-43: gap resistors between bottom cover and board

Gap resistors are very easy to create.  One of the nice features of gap resistors is that you are not
required to have the same node spacing on both assemblies.  Sauna automatically determines
which nodes overlap and creates resistors accordingly.

Even though the model is not complete, calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔"25"

For the D2PAK transistor, you should obtain TS1-junct = 114.90°C.

For some electronic boxes, the inside of the box is completely comprised of closely spaced
internal boards.  If this is your product, all internal dissipation can be quickly modeled using
gap resistors.
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Horizontal Parallel resistors

The top of the board and the top cover are separated by roughly 35 mm.  Air will circulate in
this region so you can't use gap resistors.

Above the board, you will need to establish a network of internal ambients and float resistors.
Once again, Sauna has tools to make this easy.

Switch to a perspective view:

click  

To define a network of 4 internal ambients and parallel plate resistors, enter these commands:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Horiz Para ➔ Conv Ntwk ➔ 4 Ambients ➔ 100% Area
➔ Parallel Srf ➔ Entire Assy ➔ place board and top cover in group ➔ USE

The internal ambients and float resistors will be created.  You will see that the newly created
float resistors have a different color.  That's because Sauna assigns colors to float resistors based
on the dissipation mode.  Float resistors which combine both convection (or conduction
through air) and radiation are dark blue in color.  The gap resistors are drawn in dark blue
because the resistors incorporate both conduction through air and radiation.  In the previous
exercises, all of the float resistors connected to room ambient were drawn in dark blue because
both convection and radiation were represented.  The parallel plate resistors that you just
created, however, are convection-only.  To indicate this, Sauna assigns a light blue color.
Radiation-only resistors, which you will create later on, are gray in color.

When the internal ambient nodes were created, Sauna automatically assigned a label (Frt/left,
Frt/right, etc.).  By adding a label, the node temperature will be displayed after temperatures
are calculated.  If you wish to change to a different label, you can do so by using the usual
commands for editing labels.

For details on how Sauna calculates heat transfer coefficients for parallel plate resistors, see the
Sauna Technical Reference chapter.

Side walls to internal ambient

Now you need to create resistors between the side walls and the internal ambients.

Before starting, modify visibility and the view as follows:

click   ➔ click   ➔ click  

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Any Assy Grp ➔ Select 1 ➔ “top”
➔ Select 1 ➔ “bottom” ➔ USE

The board, 4 side walls, and internal ambients will be visible.  The top and bottom cover will be
turned off.

Begin with the following:

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Float ➔ Isoltd-›Int ➔ Natural
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You will reach this menu:

  LAMINR/TURB
>1 Calculate
 2 Use Turb

This menu is used to specify whether air flow will be laminar or turbulent.  Most of the time,
you would select "Calculate" and Sauna would determine if the flow is laminar or turbulent
based on thermal parameters.  Inside a box, though, some special considerations need to be
made.  The float resistor type is "Isolated plate/board to internal ambient".  However, the side
wall of a box is not an isolated surface.  In particular, the top cover blocks air circulation,
reducing the heat transfer coefficient.  To compensate, you will choose "Use Turb" to assume
turbulence with a thick boundary layer.  This is a conservative approach.

Continue with:

Use Turb ➔ 100% Area

This brings you to the Conn Type menu:

 CONN TYPE
1 Ambient Zone
2 Entire Assy
3 Zone Points

When you created gap resistors, you chose between "Entire Assy" and "Zone Points".  Zone
points let you create float resistors over just a specific zone of an assembly.  For Isltd-›Int
resistors, there is an additional option, "Ambient Zone".  This is also a zone point option.
However, you don't enter the zone points yourself.  Sauna calculates zone points for you based
on the parallel plate resistors which are connected to the internal ambient node.  "Ambient
Zone" will be your choice.

Finish with:

Ambient Zone ➔ place front wall and left wall in group ➔ USE ➔ trap front-left ambient

Resistors will be created between the left, front ambient and the front and left walls.

Repeat the process for the left, back ambient:

Isoltd-›Int ➔ Natural ➔ Use Turb ➔ 100% Area ➔ Ambient Zone
➔ place left and back wall in group ➔ USE ➔ trap back-left ambient

Finally, create resistors for the front-right internal ambient and create resistors for the back-right
internal ambient.

When Sauna creates resistors using a zone, it may be necessary to split up the surface area of a
node.  To illustrate, switch to a top orthogonal view.  If you look at the front part of the box, as
shown in Figure 2-44 on the next page, you will see that certain front plate nodes are connected
to two different ambients.  These nodes lie on the boundary between the two ambient zones.
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Frt/left Frt/right

node connected to 2 ambients

X

Z

Figure 2-44: node connected to 2 internal ambients

This ability to divide up surface area can be quite useful.  When you are modeling the board,
you don't have to be concerned with aligning with an internal ambient node later on.  No
matter what node spacing is used on the board, you will be able to create float resistors without
difficulty.

A quick review of gray radiation analysis

Now that the convection network has been created, it's time to deal with radiation.  Inside an
enclosure, radiation heat transfer becomes more complex.

Most engineers are familiar with this basic radiation equation:

q = σσσσ    · εεεε    · A · (T1
4 - Tamb

4)

This equation applies when there is an isolated flat surface radiating heat to the environment.
Sauna, for example, uses this equation to calculate radiation heat transfer from the outer
surfaces of the box.

The basic radiation equation has a simple form for two reasons:

• Only 2 surfaces are involved, the hot surface and the ambient environment.  The hot
surface "sees" only the ambient environment.  Put another way, the view  factor between
the hot surface and the environment is 1.0.  Thus, 100% of the radiation leaving the hot
surface arrives at the environment.

• There are no reflections.  Because the environment is much larger than the dissipating
surface, it can safely be assumed that radiated heat does not bounce back.

In an enclosure, these two simplifying conditions no longer apply.  First, an analysis has to
consider that multiple surfaces are present.  View factors are less than 1 because each surface is
radiating to several other surfaces simultaneously.  Second, if any surface has emissivity less
than 1, reflections must also be considered.
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To analyze enclosure radiation, a method known as diffuse gray radiation analysis is used.
With gray radiation analysis, a resistance network is constructed as shown in Figure 2-45:

space resistor

surface resistor

surface resistor

radiosity nodes

X

Y

Figure 2-45: a gray radiation network

As shown in Figure 2-45, a gray radiation network is composed of surface resistors, space
resistors and radiosity nodes

• Surface resistor values are calculated by considering the surface area and emissivity.  A
surface which has low emissivity will have a large surface resistance.

• Space resistors values are calculated by considering the view factor between surfaces as
well as the respective surface areas.

• Radiosity nodes are connected to each surface.  The radiosity nodes make it possible for
reflections to be considered.  Even though a surface has low emissivity (and high surface
resistance), it is still an important part of a gray radiation network.  Heat from other
surfaces is reflected from these surfaces.

This concludes the quick review of gray radiation heat transfer.  The principles of gray
radiation are discussed in a variety of heat transfer textbooks.  For more details on Sauna's
methods, see Equivalent Gray Radiation in the Using Sauna chapter.

Creating a gray radiation network

While gray radiation analysis can be a difficult subject for many, it's easy to include in a Sauna
thermal model.

Prior to creating the radiation network, modify visibility as follows:

click  Front  ➔ click  

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Node/Resis ➔ All Int Amb

Notice that the  button was used to turn on assemblies.  This is possible because the
 button is the exact equivalent of Visibility ➔ Turn On ➔ All/No Fix.
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Now you're ready to create a gray radiation network.  To create such a network, you only need
to add to the group the 6 assemblies which define the radiation "cavity".  You should use the
grouping rectangle shown in Figure 2-46.

Left

S1

grouping rectangle for creating gray radiation network

X

Y

Figure 2-46: grouping rectangle for gray radiation network

Create the gray radiation network:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Gray Radtn ➔ Full Network ➔ 100% Area
➔ 6 Surf Box ➔ Select Regn ➔ grouping rectangle shown in Figure 2-46 ➔ USE

The network will be created with 6 radiosity nodes and 963 float resistors.  Sauna checks to
make sure that at least 6 assemblies are in the group and that these assemblies define a valid
cavity.  Based on the dimensions of the cavity, Sauna creates the necessary radiosity nodes and
radiation resistors.  View factors are calculated automatically.

To better see what was just created, turn off the front and back walls:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ By Plane ➔ Any Assy ➔ XY/Z-Axis

The screen will appear as shown in Figure 2-47 on the next page.  Sauna has added radiosity
nodes, surface resistors and space resistors.  Note that although the front and back wall are
invisible, the radiosity nodes for these surfaces can still be seen at the center of the box.
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S1

surface resistors

space resistors

radiosity nodes

X

Y

Figure 2-47: gray radiation network inside the box

Convection and radiation the easy way

You may have wondered: "If Sauna can create a gray radiation network in a single step, why
can't it create the natural convection network at the same time?"  Happily, Sauna can do just
that.  You didn't use this feature earlier because it was important to understand each step of the
modeling process.

Restore visibility and then delete the existing convection/radiation network:

click  

<F12 Root Menu> ➔ Delete ➔ Special Del ➔ Gray Netwk ➔ All Netwks

<F2 Backup> ➔ Node ➔ General ➔ Internl Amb ➔ All In Wind ➔ USE

Now, create the convection/radiation network:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Horiz Para ➔ Cnv/Rd Ntwk
➔ 4 Ambients ➔ 100% Area ➔ 6 Surf Box ➔ Select Regn

➔  use grouping rectangle from Figure 2-46 ➔ USE

The complete convection/radiation network will be created.  Notice how easy it was to group
assemblies with a single “Select Regn” in an orthogonal view.  This is much easier, and less
error-prone, than clicking on individual assemblies.

Calculating temperatures

Switch to a top view, then calculate temperatures:

click  Top

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔"25"
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You should obtain TLeft-junct = 74.44°C and TS1-junct = 93.06°C.  Internal ambient temperatures
will range from 52.91°C to 57.68°C.

With internal convection and radiation, it takes a while longer to calculate temperatures.  Still,
depending on your hardware, it’s doubtful that the calculation time will exceed 5 seconds.  This
is indeed quick considering that many thermal modeling and finite element programs can't
perform gray radiation analysis at all.  And for the programs that have this capability, you can
expect that the calculation will take much longer than with Sauna.

Estimating the QFP junction temperature

Figure 2-41 shows a junction-to-ambient resistance (Rja) of 32°C/W for the QFP device on a no-
via, four layer board.  The local internal ambient temperature is 54.39°C.  Since Q = 2 watts,
Tjunction = 2 ∗ 32 + 54.39 = 118.39°C.  As stated earlier, this should be considered a first pass
temperature estimate (see discussion later in the exercise).

Preparing to create the detailed stackup

It is a simple matter to delete the planar board:

click  Front

<F12 Root Menu> ➔ Delete ➔ Assembly ➔ Board ➔ All In Wind ➔ USE

Delete the gray radiation network and internal ambients:

<F12 Root Menu> ➔ Delete ➔ Special Del ➔ Gray Netwk ➔ All Netwks

<F12 Root Menu> ➔ Delete ➔ Node ➔ General ➔ Internal Amb ➔ All In Wind ➔ USE

Now you are ready to create the board stackup.

Brd In Box/Cn vs. appending

In a moment you will use the Brd In Box/Cn ➔ Rect In Box command to create the first laminate
layer in the stackup.  Then you will add traces and pads, place components, and subdivide to
create internal layers.  This “one model” approach works fine for a simple board like the board
you are working with.  But boards can be significantly more complicated than this.

For complex boards, you are strongly urged to create the board stackup in a separate model file.
When the board model is complete, and verified by performing a temperature calculation, you
can use the Append command (File ➔ Append...) to combine the board with the box.  Most users
will find this approach to be easier for complex boards.

Creating initial laminate layer

For the most part, you will be following the checklist provided on page 2-66 of Introductory
Exercise 5: Basics Of Circuit Board Modeling.  Start by using the Brd In Box/Cn ➔ Rect In Box
command to create the initial laminate layer:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Brd In Box/Cn ➔ Rect In Box ➔ hit <Enter> to skip
➔ Horizontal➔ Minimum ➔ Enter Value ➔ "10" ➔ Enter Gap ➔ "1" ➔ .062”/1.57mm ➔ FR4

➔ Zer/Lam Only ➔ .025"/0.64mm ➔ One oz. ➔ None ➔ No Join ➔ All In Wind ➔ USE
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The board will be created.  You did not specify a label, as recommeded, so the label will be
"Lamin>1".  Isolate the board and switch to a top view:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Brd Stackups

click  Top

Adding traces and pads

Add the trace pattern for the D2PAK:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ trap board ➔ Component
➔ One oz. ➔ Library ➔ DPAK's ➔ D2PAK ➔ 2 ➔ Same As Body ➔ Pad Only

➔ 0 Degrees ➔ Coords/Trap ➔ "120,,-120"

The D2PAK pads will be added.  Now add pads for the QFP, using a 15 mm flare pattern:

<F2 Backup>

Quad ➔ LQFP ➔ 14 x 14 ➔ 100 Leads ➔ Detail/Flare ➔ 15 mm/0.6" ➔ No
➔ Coords/Trap ➔ "40,,-40"

The trace pattern will be added to the board.

There is one more pad to create.  With the planar board, you assigned wattage directly to the
board nodes.  But with a board stackup, it makes more sense to assign the wattage to a pad.
Create a 60 x 80 pad:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc/Pad ➔ trap a trace or pad
➔ Pads ➔ Rectangle ➔ Coords/Trap ➔ “80,,-20” ➔ Dx-Dy-Dz  “60,,-80”

Since the 60 x 80 pad represents an area of components and traces, you will reduce the copper
coverage, to better match the effective thermal conductivity of this zone.  Modify the copper
coverage to 25%:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Plt/Bar Prop ➔ Trace/Pad ➔ Coverage ➔ Both Direc
➔ 25% ➔ Entire Assy ➔ place 60 x 80 pad in group ➔ USE

Sauna will inform you that "copper coverage modified for 1 trace/pad".

Adding heat sources

Begin by adding the D2PAK package device:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ DPAK's ➔ "2" ➔ "S1"
➔ D2PAK ➔ 2 ➔ Typical ➔ Typ-1500 C/W ➔ Ref Point ➔ trap D2PAK ref point

The D2PAK heat source will be added.  Next, begin creating the QFP source:

Quad ➔ “2” ➔ “S2” ➔ LQFP ➔ 14 x 14 ➔ 100 Leads ➔ Middle ➔ Typical/36% ➔ Typ (0.1 mm)

You will reach the familiar R_lead_pad menu:
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  R_LEAD_PAD
>1 Typ-1500 C/W
 2 Enter Resis
 3 R_para
 4 No Lead Conn

Up until now, you have always used "Typ-1500 C/W".  But as stated in the board exercise,
Rjunct-to-lead-pad is an important parameter, particularly for components without heat slugs.  The
recommended way to obtain Rjunct-to-lead-pad is to "reverse engineer" the  Rjunct-to-amb, taking into
account the vendor's test board.  This method, which provides an excellent match with
published data, is explained in Intermediate Exercise 3: More On Circuit Board Modeling.  In the
intermediate exercise, an analysis is performed for a 14 x 14, 100 lead QFP with an Rja of
32°C/W, the same as shown in Figure 2-41.  A value of Rjunct-to-lead-pad = 2000°C/W is obtained.
You will use this value for the exercise.  Continue with:

Enter Resis ➔ "2000" ➔ Ref Point ➔ trap QFP ref point

The QFP device will be added.  Finally, you need to add the distributed wattage:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Distribute ➔ Planar Plate ➔ "5"
➔ place 60 x 80 pad in group ➔ USE

Distributed wattage will be applied.  You should verify that the total wattage is correct:

<F7 Info> ➔ Heat Load ➔ Input ➔ With Supers ➔ Screen

With all the traces, the report will extend over several pages.  But at the end, you should see 24
watts of total dissipation.  Clear the report before continuing.

Since the D2PAK is a heat slug component, you should align the board stackup to this source:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source
➔ 4 Node Conn ➔ trap S1 heat source ➔ All In Wind ➔ USE

Sauna will inform you that "aligned nodes for 205 assemblies".  However, everything will look
the same.  That's because the D2PAK placement point already matched the mesh.  So, in this
case, the alignment was not actually necessary.

Single layer board calculation

You have now reached step #7 in the checklist on page 2-66.  In this step you perform a
preliminary calculation.  Once again, you need to add gap resistors and internal ambients.

Turn on model elements and switch to a front view:

click   ➔ click  Front

At the moment, there are no traces on the bottom of the board.  So you only need to create gap
resistors between the bottom of the board and the bottom cover, which means you only need
the "Lamin>1" board and the "Bottom" plate in the group.  Nonetheless, it is recommended that
you use the grouping rectangle shown in Figure 2-48 on the next page.  With this grouping
rectangle you will add the top-side traces to the group, but since these traces are stack joined to
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the board, they will be ignored.  Also, even though the grouping rectangle includes the body
assemblies for the enhanced sources, body assemblies will not be added to the group.  Create
the gap resistors:

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Float ➔ Gap ➔ Cond/Radtn ➔ Convectn OK
➔ Horizontal ➔ 100% Area ➔ Entire Assy ➔ Select Regn

➔ use grouping rectangle from Figure 2-48 ➔ USE

Left

S1S2

recommended grouping rectangle

X

Y

Figure 2-48: Recommended grouping rectangle for gap resistors

Sauna will inform you that 1024 gap resistors were created, with a total area of 1.96E+4 mm2

(board size = 140 x 140 = 19,600 mm2).

It's easy to create the convection and radiation networks.  The grouping rectangle is the same as
before (see Figure 2-46):

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Horiz Para ➔ Cnv/Rd Ntwk
➔ 4 Ambients ➔ 100% Area ➔ 6 Surf Box ➔ Select Regn

➔ grouping rectangle from Figure 2-46 ➔ USE

Sauna will inform you that "10 nodes and 2925 float resistors created".

Calculating temperatures and comparing with planar model

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain TLeft-junct = 74.33°C, TS1-D2PAK = 316.06°C and TS2-QFP = 142.91°C.  Note that
TS1-D2PAK and TS2-QFP are both junction temperatures.  For an enhanced source, the heat source
node always represents the device junction.
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Compared with the planar model, TLeft-junct is about the same.  This is not surprising, as this
component is directly mounted to a metallic outer wall.  Temperatures of wall mounted
components are only slightly impacted by the details of internal dissipation.

On the other hand, the D2PAK device (S1) is dramatically hotter.  There is, however, a simple
explanation.  This is a heat slug device and the current model does not include any internal
planes or thermal vias.

Finally, the QFP device (S2) is moderately hotter than estimated with the planar model.  While
the QFP device does not have a heat slug, there is still an impact from the missing internal
planes.

Deleting ambients and float resistors

Before subdividing to create the board stackup, you need to delete all of the internal ambients
and float resistors.  Delete the gap resistors first:

<F12 Root Menu> ➔ Delete ➔ Resistor ➔ Float ➔ Gap ➔ All In Wind ➔ USE

Now delete the internal ambients and gray radiation network:

<F12 Root Menu> ➔ Delete ➔ Special Del ➔ Gray Netwk ➔ All Netwks

<F12 Root Menu> ➔ Delete ➔ Node ➔ General ➔ Internal Amb ➔ All In Wind ➔ USE

Isolating board stackups, labels for box with multiple board stackups

When you are working with a board inside a box, you need to be able to quickly isolate the
board stackup.  Enter these commands:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Brd Stackups

click  Top

Just the board stackup will be visible.  Note that this method works fine when there is only a
single stackup in the model.  If there are two or more board stackups, however, the preceding
command would simply isolate all of the board stackups.  This is probably not what you want,
as you would normally be working with one board stackup at a time.

If you have a model with more than one board stackup, it is important that you assign unique
label prefixes with Edit ➔ Assembly ➔ Label/Color ➔ Add Prefix...  For example, if there are two
board stackups, you could edit the labels in the first board stackup to start with "Bd1:" and the
labels in the second stackup to start with "Bd2:".  This would let you quickly isolate the first
board stackup with Visibility ➔ Isolate ➔ Layer ➔ Enter ➔ "Bd1".  Label prefixes make it much
easier to work with models containing multiple board stackups.
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Adding layers to the stackup

With the board isolated, you are ready to create the internal board layers:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Subdivide ➔ Stackup ➔ Board ➔ Intern Layer
➔ Two ➔ Uniform ➔ One oz. ➔ Typical ➔ All In Wind ➔ USE

The internal layers will be created.  You should obtain a board stackup report:

<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

Notice that copper coverage for the Copp>1 layer is less than 100%, because of the 25% copper
coverage on the large pad.  The Copp>1 layer has copper area = 5,385.22 mm2, less than full-
plane.  On the other hand, the internal layers, Copp>2 and Copp>3, have 100% copper coverage
and are full-plane (area = 19,600 mm2).  This information matches Figure 2-41.

But something is missing, there is no Copp>4 layer.  Figure 2-41 calls for a fourth copper layer
with 10% copper coverage.  You will need to add this layer.  Clear the report from the screen.

To add an outer layer, you just need to create a large pad.  Enter:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side ➔ "Lamin>3"
➔ Secondary ➔ One oz. ➔ Pads ➔ Entire Board

The pad will be added, but it is difficult to see, since it is on the bottom of the stackup.  Get the
report again:

<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

Now the report now shows a Copp>4 layer.  However, the copper coverage is still 100%.  Clear
the report, then edit the copper coverage to 10%:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Plt/Bar Prop ➔ Trace/Pad ➔ Coverage ➔ Both Direc
➔ 10% ➔ Entire Assy ➔ Select 1 ➔ "copp>4>1" ➔ USE

Sauna will inform you that "copper coverage modified for 1 trace/pad".

Modifying via density

Now you need to add vias under the D2PAK device.  As you have done before, isolate the
Lamin>1 layer, turn on via density and show enhanced diepad outlines.

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Lamin>1

<F6 Setup> ➔ Display ➔ Node ➔ Via Density ➔ Vias/In2

<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Enhan Diepad

Modify the via density underneath the D2PAK:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Board Props ➔ Vias ➔ Density ➔ High (100)
➔ Node Group ➔ Select Regn ➔ grouping rectangle matches D2PAK red outline ➔ USE

Sauna should indicate that 4 nodes were modified.
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Restore the default display setup, turn on model elements and switch to a front view:

<F6 Setup> ➔ Display ➔ Use Default

click   ➔ click  Front  ➔ click  

One last time, check the board stackup:

<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

The report should show that the Lamin>1 layer has vias, while the other layers do not.  Also,
due to the earlier modification, the report should show that the copper coverage for the Copp>4
layer is 10%.  Clear the report before continuing.

Completing the model and calculating temperatures

You will follow the same procedure as before for adding ambients and float resistors, beginning
with the gap resistors:

<F12 Root Menu> ➔ Model ➔ Resistor ➔ Float ➔ Gap ➔ Cond/Radtn ➔ Convectn OK
➔ Horizontal ➔ 100% Area ➔ Entire Assy ➔ Select Regn

➔ use grouping rectangle from Figure 2-48 ➔ USE

Sauna will inform you that “1024 gap resistors created, area = 1.96E+4”.  Now create convection
and radiation networks above the board:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Horiz Para ➔ Cnv/Rd Ntwk ➔ 4 Ambients
➔ 100% Area ➔ 6 Surf Box ➔ Select Regn ➔ grouping rectangle from Fig. 2-46 ➔ USE

Convection and radiation networks will be created.  Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

The calculation will take longer, due to the larger model size with additional layers.  When
complete,  you should obtain TLeft-junct = 74.44°C, TS1-D2PAK = 100.17°C and TS2-QFP = 113.89°C.

Comparing detailed stackup with planar model, recommendations

Table 2-2 summarizes the junction temperatures for the planar and detailed stackup models:

Heat Source Stackup Planar ∆∆∆∆T Percentage
Tjunct Tjunct Change

Left (wall 74.44 74.44 0.00 0.0%
mounted TO-218)

S1 (D2PAK) 100.17 93.06 -7.11 -9.5%

S2 (QFP) 113.89 118.39 +4.50 +5.1%

Table 2-2: Planar and detailed stackup results
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Some conclusions can be drawn.  First, for a wall mounted device, the details of board modeling
are not important.  There will be little impact.

Second, for a device with a large heat slug and few leads, like the D2PAK, the planar
assumption is optimistic because, effectively, the planar model provides infinite vias to all
layers.  The same behavior was seen in Introductory Exercise 5: Basics Of Circuit Board Modeling.
Although the planar model is optimistic, temperatures were still within 10% for the D2PAK
device.

However, it's not so easy to make a conclusion about the non-heat slug QFP, or any component
that relies heavily on cooling through the leads.  For this specific case, the temperatures are
fairly close.  But there are several different factors which can cause results to vary.  First and
foremost, it's difficult to model the details of traces and pads with a planar model.  While it is
possible to adjust copper coverage, this is no substitute for modeling individual leads and pads.
Also, there's the question of the effective ambient.  In the planar analysis, the local air
temperature was used to estimate the junction temperature.  Inside a box, however, there's both
convection and radiation, and radiation effects are quite significant (see next section).  So
properties like the emissivity of the box and the heat load distribution will affect the validity of
the junction temperature calculation.  Because of these factors, you should only use the planar
model for preliminary estimates for non-heat slug devices.

Finally, there's this question: what about modeling components with small heat slugs on a planar
board?  For example, you might be modeling a 10 x 10, 64 lead QFP with a 6 x 6 heat slug.  In
this case, the heat slug is just 36% of the body footprint.  One approach would be to model this
component as a 6 x 6 basic source.  However, you would be ignoring heat transfer from the
larger body area and the contribution from the leads, making the planar model conservative.
But opposing this is the tendency for the planar model to be optimistic for heat slug devices.  So
it is not easy to draw a firm conclusion.  The general recommendation for modeling a small heat
slug device on a planar board is this: use a basic source with a footprint which is slightly larger
(approx.  20%) than the actual heat slug.  If the planar model shows an area of concern, be sure
to follow up with a detailed stackup analysis.

What-if #1: how important is gray radiation?

Since radiation heat transfer inside an enclosure is complex, some engineers deal with the
problem by simply ignoring it.  This approach is particularly tempting when the walls of the
box have low emissivity.  Let's experiment with different emissivities and see how
temperatures change.

Get an Info report for one of the walls of the box:

<F7 Info> ➔ Trap ➔ Any Assy ➔ trap one of the walls

On the second page of the report, you will see that the wall has a white paint surface for both
sides.  White paint has a high emissivity of 0.94.  Let's try switching to emissivity = 0.1.  This is a
typical value for bare metals.  When editing the walls of a rectangular box, keep in mind that, by
default, the component side faces in.  Clear the report from the screen before continuing.

So you need to change the emissivity of the component side of the box walls.  The box walls are
all plate assemblies.  But these are not the only plate assemblies in the model.  The traces and
pads on the board are also plate assembliess.  So to edit the model, you will start by turning off
the board stackup.  Then you will be able to use "All In Wind" to select assemblies.
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Make the change:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Assembly ➔ Brd Stackups

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Plt/Bar Prop ➔ Surf Type ➔ Other ➔ Emis=0.1
➔ Component ➔ All In Wind ➔ USE

Sauna will indicate that “surface type modified for 6 assemblies”.  Restore visibility and
calculate temperatures:

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ "25"

You should obtain TLeft-junct = 74.58°C, TS1-D2PAK = 120.56°C and TS2-QFP = 133.40°C.  While the
wall mounted component is little changed, the QFP and D2PAK are 20°C hotter.  The internal
emissivity of the box has a strong impact on temperatures.

Now comes the tricky question.  Since the emissivity of the inner walls is now 0.1, is it safe to
neglect internal radiation?

Working on your own, change the emissivity of the box to 0.0.  You should use the same
method as above.  You should obtain TLeft-junct = 74.58°C, TS1-D2PAK = 130.29°C and TS2-QFP =
143.29°C.  For the board mounted components, there is a further 10°C increase in temperature.

If you're not used to gray radiation analysis, these temperatures are surprising.  The temp-
erature change indicates that, even with an internal box emissivity of only 0.1, there is still
significant radiation heat transfer.  This illustrates an interesting phenomenon: reflections in an
enclosure increase the "apparent" emissivity of the enclosure walls.  To understand, consider
how the circuit board radiates heat to a low emissivity top cover.  When the board radiates heat
to the top cover, much of this heat immediately reflects back to the board.  However, at least
some of the reflected heat goes to the side walls.  At the side walls, the heat has another chance
to get absorbed.  Thus, the net effect of reflections is to increase the amount of heat absorbed.

There is a simple lesson to be learned.  Use gray radiation networks, even when emissivities are
low.

What-if #2: testing assumptions in previous exercise

Now you have the opportunity to test the assumption that you used throughout Introductory
Exercise 4: Rectangular Boxes.  In that exercise, internal convection and radiation were neglected
because the entire box was made of metal.  Also, all heat sources were mounted directly to
metal surfaces.

You will use the model “new_shelf.smf” saved during the exercise.   (The same model is
available in “C:\Program Files (x86)\Sauna Thermal Modeling\Reference Models”.)  Begin by
loading the model:

<F12 Root Menu> ➔ File ➔ Open ➔ select new_shelf.smf ➔ click Open button ➔ click Yes button

Now you can add internal convection and radiation.  You should use gap resistors underneath
the shelf.  Above the shelf, create convection and gray radiation networks.
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Calculate temperatures @25°C.  The heat source junction temperatures will decrease from
74.40°C to 74.29°C, only a 0.1°C change.  For this model it was a good assumption to neglect
internal radiation and convection.

Combining gray radiation with gap resistors for plastic boxes

In this exercise you used gap resistors which combined both convection and radiation.
Another, somewhat more accurate approach, is to use gap resistors for convection while
creating a gray network to handle radiation.  The gray radiation network more accurately
represents the diffused nature of thermal radiation.  You probably won’t see much difference
for metal boxes but the difference will be more noticeable for a plastic box.  (The combined
gap/gray radiation approach will tend to produce cooler temperatures.)

Fan cooled boxes and flow networks

This exercise dealt with naturally cooled boxes.  For fan cooled boxes, please work through
Intermediate Exercise 7: Channel Resistors And Flow Networks and Intermediate Exercise 8: Plastic Box
With Forced Air Cooling.

Non-uniform boxes

In the current model, the circuit board is just slightly smaller than the overall box.  Many “real
world” boxes are like this.  But there are also many other boxes which have mother/daughter
boards, partial shelves, and other non-uniform geometries.  When you model these non-
uniform boxes with Sauna, there is a useful technique to learn: “the phantom wall method”.
This method is actually quite easy to use.  For details, see Intermediate Exercise 9: Phantom Walls,
Daughter Boards, Box In A Box, L-Shaped Box.

Wrapping up

This exercise is now complete.  Delete the model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button


