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Introductory Exercise 1: A Simple Finned Heat Sink

In the first exercise you will create a thermal model for the heat sink shown in Figure 2-2:

25
5

200 mm (7.9")

2

10

40W power transistor,
TO-247 package,
(20,60,0)

80 mm (3.1")

          material: extruded aluminum
fin surface: white paint

(0,0,0)

X

Y

Z

Figure 2-2: Heat sink for exercise 1

The units that you will be using for the introductory exercises are millimeters, °C, and watts.
(Sauna also supports English units.)

At this point, you should be at the Root menu.  If not, return there with the <F12 Root Menu>
selection on the Interrupt menu.

Creating a plate assembly

The error beep on your computer should be turned on (not muted).

The first step is to create the plate assembly which represents the vertical transistor mounting
surface.  Begin with these menu selections:

Model ➔ Assembly

As shown on the next page, you will reach the Assembly menu:
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  ASSEMBLY
1 Board
2 Planar Plate
3 Bar/Tube
4 Box/Can
5 Brd In Bx/Cn
6 Plt In Bx/Cn
7 Surface
8 Trace/Pad

As you can see, Sauna provides a number of assembly types.  You will be creating a "planar
plate" assembly, which will have a single plane of nodes and resistors.  Continue with:

Planar Plate

You will be prompted with:

Enter the plate label (<Enter> = Sauna assigns)

Each assembly in the thermal model has a unique label assigned to it.  You can type in your
own label or you can simply hit <Enter>.   If you hit <Enter>, Sauna will choose a label for you.
It’s best to enter your own label, so type in “Sink” (don’t type the quotes) and hit <Enter>.

Now you must define the plate orientation, plate dimensions, and the origin point.  Continue
with:

Rectangle ➔ Vertical XY

This prompt will be displayed:

Enter the vertical plate width, height, and thickness

In response, type in "200,80,5" (no quotes) and hit <Enter>.

Next, the Origin Pt menu will appear:

  ORIGIN PT
>1 (0,0,0)
 2 Coords/Trap
 3 Digitize
 4 Midpoint
 5 Ref/Dx
 6 Ref/Dy
 7 Ref/Dz
 8 Ref/Dx-Dy-Dz

The origin point is the left, front, bottom point of the assembly.  This is the case for all
rectangular assemblies, regardless of the plane of the assembly.

Notice that there is an arrow to the left of "(0,0,0)".  The arrow tells you that this menu selection
is a default.  Default menu selections can be chosen by simply hitting <Enter>.

Complete creating the plate assembly as follows:

(0,0,0) ➔ Aluminum ➔ Extruded ➔ Paint/White

The plate assembly will be created.



Introductory Exercise 1: A Simple Finned Heat Sink 2-7

If you look at the screen, you will see that Sauna has drawn the outline of the assembly with a
thick dashed line and that the inside of the plate has been filled with a uniform array of nodes
and resistors.

But Sauna has done much more than simply create a series of nodes and resistors.  At the same
time, Sauna has created an intelligent assembly which retains all of the information used to
create the thermal model.

To obtain details on the plate characteristics, use the Info command on the Interrupt menu:

<F7 Info> ➔ Trap ➔ Any Assy

You will be prompted with

Trap an assembly

To trap the assembly, move the cursor (arrow) directly on top of one of the assembly dashed lines.
Then click the mouse button.  You must click on the dashed  lines.  Clicking on the interior of the
plate assembly will not work.

A comprehensive listing of the assembly characteristics will be displayed on the screen.  Since
this listing is too large to fit on the screen at one time, you will need to advance to the second
page of the report.  Click the Next button to read the second page of  the report.  When you
have finished reading the report, click the Done button to return to the menus.

Adding fins

When you have finished reading the Info report, switch from a "front orthogonal" view to a
"front, twisted perspective" view.  This is accomplished using <F1 Window> on the Interrupt
menu:

<F1 Window> ➔ Set View ➔ Front ➔ Persp/Twist

The plate will be redrawn in a 3D perspective view as shown below:

Component side (short dash)

Secondary side (long dash)
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Figure 2-3: Perspective view of the plate
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In the perspective view, you will see that different types of dashed lines are used to draw the
plate outline.  The front face of the plate has been drawn with a short dashed line.  This
indicates that the front face of the plate is the component     side.  The back face of the plate is
drawn with a long dashed line.  The back face is the secondary       side.  By default, Sauna defines
the component side to be in the positive direction for the axis which is perpendicular to the
plate.  This may seem complicated, but in practice you just look at the screen to see which side
has the short dash and which side has the long dash.

Since the fins on the plate extend in the negative Z-direction, you will need to edit the
secondary side of the plate.  Start with these commands:

 <F12 Root Menu> ➔ Edit ➔ Assembly ➔ Plt/Bar Prop ➔ New Fins ➔ "25,10,2" ➔ Secondary

You will reach this grouping menu:

  RECT PLT/BAR
>1 Select 1
 2 Select Regn
 3 Select Mult
 4 All In Wind
 5 Unselect 1
 6 Unsel Regn
 7 Clear Group
 8 USE

The above menu is used to graphically select the plate which will be modified.  You may be
wondering: "Why do I need this menu?  Can't I just click on the plate and have it change?"

However, a grouping menu really is a necessity.  Right now, there is only 1 plate, so selection is
simple.  However, what if there were 10 plates on the screen and you only wanted to add fins to
five of them?  This is why you need a grouping menu.  A grouping menu lets you select just the
plates you want from among the many plates contained in the thermal model.

Using a grouping menu will always be a two  step process.  The first step is selection.  For
example, in a moment you will choose "Select 1" and you will trap, or click on, the assembly
outline.  This will cause the plate to be placed in the group.  If you make a mistake, you can use
"Unselect 1", "Unsel Regn" (unselect region), or "Clear Group" to take plates out of the group.

As the second step in using a grouping menu, you will select "USE".  This indicates to Sauna
that the proper plates are in the group and that it's time to proceed.  Remember, no changes will
be made until you select "USE".

Place the plate in the group and complete the modification with:

Select 1 ➔ trap the plate outline ➔ USE

To indicate that the plate has fins, additional dashed lines will be drawn which show the
maximum outline of the fins.
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Activating shade mode

When you added fins to the plate, you may have been disappointed that you couldn’t see each
individual fin.  In fact, it is possible to see the individual fins.  You just need to switch from the
current display mode, wireframe mode, to the shaded mode.  The necessary command is on the
Interrupt menu.  Switch to shade mode now:

<F5 Shade Mode>

In shade mode, you can clearly see each fin on the sink, as shown in Figure 2-4:
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Figure 2-4: Shade mode view of the heat sink

To return to wireframe mode, repeat the selection:

<F5 Shade Mode>

It’s all very simple.  Note that the <F5 Shade Mode> selection is a “toggle”.  If shade mode is off,
shade mode will be activated.  If shade mode is already on, it is turned off.

It is expected that you will frequently switch into shade mode.  It’s quick and easy and makes
creating models more efficient.

Changing the view

Currently, you are in a “front, twisted perspective view”.  This does sound strange, but you will
see the logic momentarily.  You should switch to shade mode and then try the other standard
perspective view:

<F5 Shade Mode>

<F1 Window> ➔ Set View ➔ Front ➔ Persp/Symm

With the “front, symmetric view”, the viewpoint is directly from the front.  With this viewpoint,
the model is drawn symmetrically around the center of the screen.  So now you can see the
difference between “persp/symm” and “persp/twist”.  With “persp/twist”, there is a partial
rotation, or twist, of the view.
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Since you will change views frequently, Sauna provides shorcuts with the menu buttons on the
lower-left of the Sauna window.  For example, you can return to a twisted perspective view
with the top-right menu button.  Do this now:

click      (top-right button)

There are also menu buttons for “turning” the view.  To view the model from a higher reference
point, use the “move up” button:

click      (4th row, left button)

For a complete description of the menu buttons, see Figure 2-11 on page 2-25.

Adding the power transistor

Switch back to wireframe mode and return to a front, orthogonal view:

<F5 Shade Mode>

click  Front

Now add the power transistor:

<F12 Root Menu> ➔ Model ➔ Heat Input

You will see the Heat Input menu:

  HEAT INPUT
 1 Basic Source
 2 Enhanced Src
 3 Device Sink
 4 Distribute
 5 Clear Dstrb

Sauna provides two different ways to model a power component: "basic source" and "enhanced
source".  With a "basic source", Sauna assumes that all of the heat flows through the base (heat
slug) of the component.  Any heat flow through the leads is ignored.  When you are using a
TO-247 package and mounting to a metallic plate, the basic source is a good choice, since the
leads are not an important heat flow path.

The other choice, "enhanced source", is used for components mounted on circuit boards.  In this
case, heat flow through the leads is an important factor.  Sauna's enhanced sources are an easy
and accurate way to model components such as DPAK's, quad flat packs and many other
component types.  Enhanced heat sources are introduced in Introductory Exercise 5: Basics Of
Circuit Board Modeling.

Continue with a basic source:

Basic Source ➔ "40" ➔ "S1" ➔ TO-247
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You will reach the R_junct_case menu:

  R_JUNCT_CASE
 1 Typical
 2 Specify
 3 Omit

This menu is for specifying the Rjunction-to-case (Rjc, also know as θjc, Rθjc) for the power device.  In
a moment, you will select "Typical", which will result in Rjc = 0.6°C/W, a reasonable value for a
TO-247 power device.  While it's extremely easy to use the typical value, Rjc is an important
thermal parameter.  When possible, use an exact value from the component datasheet.  You will
frequently use "Typical" as part of the Sauna User Manual exercises, but this is for convenience
only.

Complete creating the heat source with:

Typical ➔ Standard ➔ Greased ➔ Plate/Board ➔ One ➔ trap the plate ➔ Coords/Trap ➔ "20,60,0"

A 40 watt heat source will be added to the heat sink.  Just as for the complete assembly, Sauna
has created an intelligent heat source and manages all relevant information. Use the Info
command to obtain a heat source report:

<F7 Info> ➔ Heat Load ➔ Input ➔ With Supers ➔ Screen

When you read the report, you will see that a TO-247 package heat source with the label "S1"
has been added.  Thermal grease will be used.  The values for junction-to-case thermal
resistance (Rjc) and case-to-sink resistance (Rcs) are also given.  (In later exercises you will learn
the significance of the "With Supers" option that you used.)  When you have finished reading
the report, click the Done button to return to the menus.

The name footprint source is used because the contact area between the heat source and heat
sink is taken into account when creating thermal resistors.  To see this, use the Zoom In
command on the Interrupt menu:

<F3 Zoom In>

The “Zoom In” selection on the Interrupt menu will be highlighted and the main menu zone
will be deactivated (redrawn in gray).  This prompt will be displayed:

Digitize the first corner of the zoom rectangle

Use the mouse to move the cursor to the upper left corner of the heat sink.  Then click the mouse to
define the first corner of the new window.  (Don’t keep the mouse button down, it must be
released.)  A second prompt will be displayed:

 Digitize the opposite corner of the zoom rectangle

Move the cursor (arrow) to the right and down.  As you move the cursor, a rectangle will be drawn
to indicate which elements will be contained in the new window. Keep moving the cursor until
the rectangle encloses about 16 of the nodes around the heat source.  Then click the mouse.  The
new window will appear similar to Figure 2-5 on the next page.
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Figure 2-5: Zooming in on the footprint heat source

You will see that 2 resistors have been used to connect the heat source to the backplane.  When
the source was added, Sauna determined that 2 resistors were needed based on the TO-247
package size and the spacing between backplane nodes.  If the source package were some other
size, the number of connecting resistors would change accordingly.

Aligning the mesh to the heat source

At the present time, there are two case-to-sink resistors for S1.  As explained in Introductory
Exercise 8: Modeling Errors, it is recommended that major heat sources have at least 3 case-to-sink
resistors, with 4 case-to-sink resistors as the desired goal.  Sauna has a command, the "Align
Mesh" command, to quickly resize the plate mesh to match the size and location of the heat
source.  Align the mesh with:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source
➔ 4 Node Conn ➔ trap heat source ➔ Select 1 ➔ trap plate ➔ USE

The node and resistor mesh will become finer, so that there will be 4 case-to-sink resistors.

(If you have a heat sink with multiple heat sources, you would either align to the highest power
component, or you would slice the plate so that you could align to more than one heat source.
This subject is discussed later in the exercises.)

Calculating temperatures

Now that the heat source has been added, it's time to calculate temperatures.  Enter these
commands:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady

Oops!  Sauna will beep at you and this message will be displayed in the prompt zone:

Invalid model: no fixed temperature nodes

The calculation cannot be performed because no heat flow path has been established between
the heat sink and the ambient temperature environment.  A "fixed temperature" node is
required to represent the room environment.  The name "fixed temperature" comes from the fact
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that ambient nodes have temperatures which are defined prior to calculating temperatures.
Other nodes in the thermal model will have their temperatures calculated by Sauna.

Adding a fixed temperature node and float resistors

You will be using the "Amb + Float" command to establish a heat flow path to the environment.
"Amb + Float" will create both the fixed temperature (ambient) node as well as float resistors
between the plate and the fixed node (more on float resistors later).  Sauna provides commands
to separately create the node and float resistors, but Amb + Float provides a simple method to
create both at the same time.

Switch to a front perspective view:

click  

Begin with:

<F12 Root Menu> ➔ Model ➔ Amb + Float

You will reach this menu:

  AMB + FLOAT
1 Isoltd->Fix
2 Isoltd->Int
3 Channel
4 Gray Radtn
5 Horiz Para
6 Vert Para
7 Sink Network

As you can see, there are a number of possibilities.  For an explanation, click the Menu Ref
button (located just below the menu):

click  Menu Ref

You will be using the first choice, "Isoltd-›Fix".  With this type of float resistor Sauna will use
heat transfer equations which apply for surfaces which are considered isolated.  Put another
way, with "Isoltd-›Fix" you will be assuming that there are no adjacent surfaces to reduce heat
dissipation from the assembly.

After clearing the Menu Ref window, continue with:

Isoltd-›Fix ➔ "Room Amb" ➔ Enter Later

Now you are at the Connect To menu, which is used to choose the side to receive float resistors.
If you have forgotten the difference between the component and secondary side, you can view a
reference picture.  (Reference pictures are available for some, but not all, menus.)  Click the
Picture button (located to the right of the Menu Ref button):

click  Picture
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You are using the secondary side, so clear the Picture window and continue with:

Secondary ➔ Select 1 ➔ trap the plate ➔ USE

A fixed node with the label "Room Amb" will be created and float resistors will be created
between the plate nodes and the ambient node.  To get a clear view of the new elements, switch
to a top, orthogonal view:

click  Top

In the top view, you can clearly see the new float resistors and room ambient node.

You probably noticed that the resistors have a new color.  The new resistors are float thermal
resistors.  The name float is given because Sauna recalculates resistances each time that
temperatures are calculated.  On the other hand, constant thermal resistors, such as the resistors
contained in the plate assembly, are not recalculated.  The new float resistors are dark blue in
color.  This indicates that the resistors incorporate both convection and radiation.

Get a report on the assembly properties:

<F7 Info> ➔ Trap ➔ Any Assy ➔ trap the assembly

Under the heading "-- Secondary Side Dissipation --" on the second page, Sauna now indicates
that the dissipation type is "Isolated plate/board to ambient".

After clearing the report from the screen, switch back to a front, orthogonal view:

click  Front

To make the screen display clearer, it’s possible to make elements temporarily invisible.
Experienced Sauna users frequently make parts of the model invisible.  (Invisible elements are
still used when calculating temperatures.)

Turn off the fixed node and connected resistors with:

<F12 Root Menu> ➔ Visibility ➔ Turn Off ➔ Fixed Nodes

Calculating temperatures

Now you are ready to calculate temperatures.  When you used Amb + Float, you chose
"Enter Later" for the dissipation mode.  With this option, you will choose the cooling mode each
time that temperatures are calculated.  Calculate temperatures for natural cooling in a 25°C
environment:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

Sauna will first check the model.  Then, temperatures will be calculated.  For this model, the
entire process takes less than a second on any contemporary computer.

This message will be displayed: "Temperatures successfully calculated".  Notice that Sauna
automatically calculated all the necessary convection and radiation coefficients for the float
resistors.  The float resistor convergence error, in this case 0.0018%, is displayed at the bottom of
the screen.  Also, at the upper left of the graphics window, Sauna now displays “Steady State”.
This tells you that the current temperatures are “steady state”, meaning that the heat sink is
fully warmed up and all temperatures have stabilized.  (Transient calculations are discussed
later in the exercise.)
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Two temperatures will be displayed for the heat source.  The top temperature, 136.98°C, is the
device junction temperature.  The lower temperature, 112.98°C, is the case temperature.  (Of
course, these temperatures are rather high.  In the next exercise you will use Sauna to find
improved cooling methods.)

Use <F7 Info> to get a complete temperature report for the sink:

<F7 Info> ➔ Temperature ➔ Current ➔ With Supers ➔ Screen

This report lists out temperatures for fixed nodes, heat sources, and a summary of plate
temperatures.

You can also obtain a summary report which incorporates the assembly, heat load and
temperature reports.  Simply choose "Full Report" on the Info menu.  Several output options are
available with these reports.  The report can be displayed on the screen, sent to a printer or
written to a text file.

By default, Sauna will only display temperatures for heat sources and any nodes which have
been separately labeled.  But other options are available.  After clearing the Info window, enter
these commands:

click  

  <F6 Setup> ➔ Display ➔ Contours ➔ On ➔ Auto Calc

S1

X
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Z

Temp ˚C

102.15

 97.93

 93.71

 89.49

 85.28

 81.06

 76.84

 72.62

 68.40

 64.18

 59.96

Steady State

Figure 2-6: surface temperature contours

The screen will appear as shown in Figure 2-6.  Notice that the screen display was very quick, so
that you can easily turn the view, just as you did in regular shade mode.  Sauna supports
several different options for the contour mode.  You can turn off isotherms or you can turn off
the colors while retaining the isotherms.  And it is easy to export these graphics to a word
processing file because Sauna supports the creation of Windows metafiles, BMP files and Post-
script files.  For more details, see More On The Display Of Temperature Contours in the Using
Sauna chapter.
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Saving the thermal model

Before proceeding further, let's save the model file on your hard disk.  You will be using the
current model in the third exercise which covers non-uniform heat sinks.  Save the model with:

<F12 Root Menu> ➔ File ➔ Save As ➔ type "new_sink" in File name box ➔ click Save button

The model will be saved in the file "new_sink.smf".  "smf" is the default file extension used by
Sauna and stands for Sauna Model File.

Adding a node label

You will now add a label to the node shown in Figure 2-7a.  This will allow you to monitor the
temperature of this node, which will be useful when the transient calculation is performed
below.  As mentioned above, by default, Sauna only displays temperatures for heat sources and
labeled nodes.

S1

112.98
136.98

mid_sink

69.65

Add a label to this node

X

Y

Steady State

Figure 2-7a: Adding the node label

First, turn off temperature contours and return to a front, orthogonal view:

<F6 Setup> ➔ Display ➔ Contours ➔ Off/Wirefrm

click  Front

Now, add the node label (the X-coordinate of this node is 100 mm):

<F12 Root Menu> ➔ Edit ➔ Node ➔ Labels ➔ Trap 1 Node ➔ Any Node
➔ trap node shown in Figure 2-7a ➔ type “mid-sink” in text box ➔ click OK button

Once you have added the node label, you will see the current temperature of 69.65°C.
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Modeling power shutback

Many electronic parts have integrated power shutback circuitry.  This can be handled easily and
efficiently with Sauna.  You will now implement a power shutback circuit for the power
transistor.  It will be assumed  that the transistor runs at full power when Tjunction is less than
100°C.  There will be a linear decrease in power between Tj = 100°C and Tj = 130°C.  Above
Tj = 130°C, the transistor will be turned off.

To implement the power shutback, you will create a control element.  Control elements are a
signature feature of Sauna.  Control elements can be used to modify wattage and boundary
temperatures.  For example, you can use control elements to have wattage change with
temperature, or with time, or a combination of both time and temperature.

To model power shutback, you need to create a "Q vs Temp" control element:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ With Menus ➔ Temp Base
➔ Q vs Temp ➔ “SB #1” ➔ Shutback ➔ "100,130" ➔ “0”

These messages will be displayed in the prompt zone:

Control element “SB #1” successfully created
Node temperatures and float resistors were cleared

As indicated, the control element was created.  (The 2nd message tells you that Sauna
automatically cleared node temperatures and float resistor values due to a change in the
model.)  However, unlike nodes and resistors, there isn’t anything to be seen on the screen.  You
will need to get a report to find out more about the control element just created.  To obtain a
graph of the new control element, enter:

<F7 Info> ➔ Control Elem ➔ Graph ➔ Temp Base ➔ All ➔ Screen

The graph will be as shown in Figure 2-7b, showing shutback between 100°C and 130°C.

Control Element Plot
--------------------

0.00 50.00 100.00 150.00 200.00

0.0

1.0

2.0

Temp (˚C)

Wattage ratio SB #1
(not used)

Figure 2-7b: Shutback control curve
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After clearing the report from the screen, assign the control element to the heat source:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔ Temp Base ➔ Q vs Temp ➔ "SB #1"
➔ Heat Source ➔ Select 1 ➔ trap heat source ➔ USE

If you look at the heat source node, you will see that the symbol has changed, indicating that
the control element has been assigned. (Note that “SB #1” is an abbreviation for “shutback #1”.)

Now you are ready to calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain Tjunction = 108.36°C.  In the prompt zone you will see this message:

Final model wattage = 28.85

It is important to know the final wattage for each part, so that the operating point can be
determined.  Under extreme operating conditions, many products will shut back power.
However, there is quite a difference between shutting back to near zero power, and having a
product which is useless to the end user, and shutting back to a level which still provides basic
product functionality.

As you have just seen, it’s quite easy to handle power which varies with temperature.  Besides
the simple linear shutback just modeled, Sauna can easily handle much more complicated
configurations.  If you are interested in this topic, be sure to work through Intermediate
Exercise 12: Control Elements.  Also, you will create a time base control element later in this
exercise.

You should delete the control element:

<F12 Root Menu> ➔ Delete ➔ Control Elem ➔ Delete All ➔ click Yes button

Simple transient

Now you’re ready to do a transient calculation.  To perform transient calculations, you need the
Sauna Modeling System version of Sauna.  If you are a Sauna Standard user, you should jump
ahead to the second exercise now.  (The Sauna Evaluation package can also perform transient
calculations, but only for a limited set of model dimensions.)

You will start with “simple transient”.  In a simple transient calculation, the model is initially at
room temperature.  Power is turned on and the model gradually warms up to the final steady
state temperatures.

Enter these commands to perform a transient analysis which lasts 30 minutes:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Transient ➔ Optimized ➔ Minutes ➔ “30”

This brings up the Float Steps menu:
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  FLOAT STEPS
>1 60
 2 20
 3 100
 4 200
 5 600
 6 1000
 7 1800
 8 Enter Steps

This menu controls two parameters: (1) how frequently float resistors are recalculated and (2)
how often Sauna saves temperatures.  To explain the first parameter, consider that model
temperatures can vary quite significantly during the course of a transient analysis.  Since
model temperatures change, it becomes necessary to recalculate temperature-dependent float
resistors.  If you choose “60”, Sauna will use 60 float steps, meaning that float resistors will be
recalculated 60 times (every 30 seconds for a 30 minute analysis).

This brings up the 2nd parameter.  At every float step, Sauna saves a complete set of model
temperatures in the result file.  These are the only temperatures that Sauna saves.  If you want
to be able to plot an attractive curve of temperature vs. time, it’s a good idea to use 60 float
steps.  You might achieve good accuracy with just 10 float steps, but there won’t be many data
points to graph.

Finish specifying the transient calculation with:

60 ➔ Default ➔ Fixed Node ➔ Natural ➔ “25”

The transient calculation will begin.  Notice that since you chose “Default” on the Result File
menu, Sauna will write the temperature results in a text file with the name “new_sink.srf”.  The
file extension, “srf”, comes from Sauna result file.  The result file is an ordinary text file which
can be viewed with any word processor.

At the beginning of the transient calculation, you will see messages indicating that the model is
being checked and various solver parameters are being assigned.  After a few seconds, you will
start to see this type of status message:

Completed float step 1 of 60.  Dt = 0.29 sec (explic)
To cancel the temperature calculation, type “c”

These status messages let you track the progress of your calculation.  Besides indicating the
float step, the message also indicates the current time step and solver method.  More details on
these topics are given later in the manual.

When the calculation is complete, you should obtain Tjunct = 136.50°C and Tmid-sink = 69.17°C.
These temperatures are within 0.5°C of the steady state temperatures.  Note that "Transient,
Optimized, Time = 30:00.00" is displayed in the top left portion of the graphics window.  This
indicates that the currently displayed temperatures are from the final time step in the analysis.

Viewing results

While it’s certainly interesting to know the final temperatures in a transient analysis, it’s equally
important to have temperature vs. time data.  To obtain this information, start with:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp ➔ All In Wind ➔ USE ➔ Minutes
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This will bring up the Output Type menu:

  OUTPUT TYPE
>1 Graph
 2 Graph/Limits
 3 Text
 4 Spreadsheet

If you select “Graph” or “Graph/Limits”, Sauna will generate a graph of temperature vs. time
for the selected nodes.  You will have the choice of displaying the graph on the screen, printing
the graph, or saving the graph in a graphics file.  “Text” is used to generate a temperature vs.
time table which can also be displayed, printed or saved in a file.  “Spreadsheet” generates a
table in the tab-delineated spreadsheet format.  This type of report can be directly loaded into
virtually any spreadsheet or graphing program.

Most users will want to start with a graph of data to the screen:  Continue with:

Graph ➔ Screen

The graph will be as shown in Figure 2-8:

Temperature vs. Time Plot
-------------------------
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Figure 2-8: Temperature vs. time graph

Notice that in the upper-right key box, the hottest curve is placed in the top position.  The
second hottest curve is in the next position, etc.  This makes the graph easier to interpret.  When
you have cleared the graph from the screen, you can generate a temperature vs. time table with:

Text ➔ Screen

Sauna will display a temperature vs. time table.  Note that when generating temperature vs.
time graphs or reports, there can be a maximum of 8 different temperature sets.

Before moving on, you should know about an additional way to view transient data.  If you
wish, you can use <F12 Root Menu> ➔ File ➔ Import to view complete data from any float step in
the analysis.
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As you have just seen, it’s easy to perform a transient analysis with Sauna.  Now you will move
on to Sauna’s duty cycle transient features.  Before continuing, clear any reports from the
screen.

What is duty cycle transient?

It can be said that there are three types of temperature calculations: steady state, simple transient,
and duty cycle transient.  You’ve already used Sauna to perform steady state and simple transient
calculations.

For many real world problems, however, simple transient is not  enough.  Consider antilock
brake (ABS) circuitry in an automobile.  When the driver of a car hits the brake pedal and ABS
activates, the control circuitry pulses the brakes.  This causes heat dissipation to rise and fall
rapidly.  To predict temperatures for an ABS module, duty cycle transient is a requirement.
Wattages must be allowed to vary with time.  There are many other real world problems where
duty cycle capability is essential.

Creating a time base control element

For duty cycle transient to be efficient, there needs to be a simple way to define the variation of
wattages and fixed nodes with time.  This task is handled with time base control elements.  You
have already used temperature base control elements to define a power shutback scheme.

As the next step in this exercise, you will create a control element which defines a square wave
power vs. time relationship.  The square wave will consist of 5 pulses which are “1 minute on”
and “1 minute off” (total time is 10 minutes).

Create the time base control element with these commands:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Create ➔ With Menus ➔ Time Base ➔ Q vs Time
➔ “square #1” ➔ Minutes ➔ Square Wave ➔ “5” ➔ “1,1” ➔ “1,0”

➔ 4 (the default) ➔ Fixed Node

Sauna will indicate that the control element was created successfully.  To find out more about
the control element, begin with a listing of all control elements in the model:

<F7 Info> ➔ Control Elem ➔ List All ➔ Screen

The report will be displayed on the screen.  You will see that there is currently one control
element: “square #1”.

Now let’s get some detailed information on the control element.  After clearing the control
element list from the screen, make these selections:

Graph ➔ Time Base ➔ Show Ramp ➔ Minutes ➔ All ➔ Full Graph ➔ Screen

The square wave control element will be graphed as shown in Figure 2-9 on the next page.
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Control Element Plot
--------------------
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Figure 2-9: Graph of square wave control element

In the graph, you can see that there are 5 pulses for a total control element duration of 10
minutes.   Notice that the Y-axis label is “Wattage ratio”.  This means that the control element
provides a wattage ratio, not an absolute wattage.  For the square wave just defined, the
wattage during the “on” portion of the square wave will be the current node wattage multiplied
by one.  If the control element is applied to the heat source, the wattage during the “on” portion
will be 40 x 1 = 40 watts.  It’s very practical to use wattage ratios because a single control
element can control a number of nodes with varying wattages.

Now let’s look at a control element from a different standpoint.  After clearing the graph from
the screen, enter these commands:

Text Report ➔ Enter Label ➔  “square #1” ➔ Screen

The text description of the control element will be displayed on the screen.  Control elements in
Sauna are based on a simple scripting language.  When you used the menus to create the
control element, Sauna generated the control element script which is now displayed.  Notice
that there is a loop defined by the “begin_loop = 5” and “end_loop” instructions.

If you wish, you can use Sauna’s scripting language to directly define control elements.  You
can also define control elements based on spreadsheet data.  These subjects are discussed in
Supplemental Exercise 1: Transient And Duty Cycle Analysis in the Sauna User Manual.  Before
moving on, clear the report from the screen.

Assigning control elements and calculating temperatures

Try performing a duty cycle calculation:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized
➔ Default ➔ Natural ➔ “25”

You will receive these error messages:

Warning: control element “square #1 is not in use”
Duty cycle calc: no time base control elements in use
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To perform a duty cycle calculation, you need at least one time base control element, which
defines the time characteristics of the calculation.  At this point, you have created a control
element, but it isn’t assigned to any nodes.  Assign the control element to the heat source with:

<F12 Root Menu> ➔ Model ➔ Control Elem ➔ Assign ➔  Time Base ➔ Q vs Time
➔ “square #1” ➔ Heat Source ➔ Select 1 ➔ trap heat source ➔ USE

To show that the control element has been assigned, Sauna changes the symbol for the heat
source node.

Now you can calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Duty Cycle ➔ Optimized
➔ Default ➔ Natural ➔ “25”

After 10 minutes of on/off cycling, you should obtain Tjunct = 49.33°C and Tmid-sink = 43.39°C.
The temperatures are similar because the analysis ends with a one minute “off” period.  To get a
clear picture of how temperatures vary with time, obtain a temperature vs. time graph:

<F7 Info> ➔ Temperature ➔ Transient ➔ Default ➔ Lbl Nd Grp
➔ All In Wind ➔ USE ➔ Minutes ➔ Graph ➔ Screen

The graph will be as shown in Figure 2-10:

Temperature vs. Time Plot
-------------------------
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Figure 2-10: temperatures from square wave control element

With the graph, it can be seen that the heat source temperatures rise and fall significantly while
the “mid-sink” temperature shows a gradual increase with few up and down variations.  The
mid-sink node is responding to the time average dissipation, not the instantaneous dissipation.
These trends become very clear with the graphing capability.

When you look at the graph, notice that there are 4 temperatures points for each “on” pulse and
each “off” pulse.  There are four temperatures for each pulse because you chose 4 float steps
when creating the control element.  As discussed earlier, when you specify the number of float
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steps, you are also specifying the number of output temperatures because Sauna only saves
temperatures at the end of each float step.  Clear the graph from the screen before continuing.

Some comments on transient and duty cycle calculations

You have just seen that it’s rather easy to model power shutback, simple transient and duty
cycles.  Also, the calculation times were short.  Sauna has made easy work of this problem,
which would be much more difficult with any other thermal modeling software package.  With
Sauna you can save many hours of modeling time.

The examples worked above are actually quite basic.  Many more possibilities are allowed.  To
learn more, see Intermediate Exercise 12: Control Elements and Supplemental Exercise 1: Transient
And Duty Cycle Analysis.  These exercises gives a comprehensive discussion of the many
available options.

Please note that simple transient and duty cycle transient are only available for the Sauna
Modeling System package.  Sauna Standard only permits steady state analysis.

Wrapping up

This exercise is now complete.  You should delete all control element elements from the model:

<F12 Root Menu> ➔ Delete ➔ Control element ➔ Delete All ➔ click Yes button

The main purpose of the first exercise was to provide an overview of Sauna’s capabilities and to
teach the basic Sauna concepts.  Now that you’ve had a good introduction, you are ready for
exercises which are more “hands on”.  Instead of being told menu-by-menu which commands
are required, you will have more opportunities to enter commands on your own.


