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Sauna™ Quick Tour #2: Circuit Board Modeling

About Sauna Quick Tours

The Sauna Quick Tours let you preview the features provided by the Sauna thermal modeling
program.  You will create actual models, just like an experienced Sauna user.  The documen-
tation explains all modeling steps, so no background with Sauna is required.  However, as the
name implies, the Sauna Quick Tours are not detailed introductions to the software.  Many
important topics are skipped over or discussed briefly.  To become a skilled user, you need to
work the tutorial exercises found in the Sauna User Manuals.  Many of these exercise are also
available to prospective users on the thermalsoftware.com website.

Overview of Quick Tour #2

You will be starting with the simple model shown in Figure 1.  This is just a DPAK-package
device on a single layer board.  With no heatsinking provisions and 1W of dissipation, you can
expect that the device will be rather warm.

S1

DPAK package power
device, Q=1W,
X=40, Y=31.5

80

80

24

traces are
0.5 mm wide

single layer
FR4 board,
1 oz. copper

X

Y

Z

Figure 1: DPAK package device on single layer board

After creating the basic model, you will investigate the three variations shown in Figure 2.
These types of what-ifs are very easy to perform with Sauna.
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  What-if #1:
Shorter Traces

  What-if #2:
25 x 25 Pad

  What-if #3:
Four Layer Board
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Figure 2: What-if's for DPAK-only board

After the DPAK what-if's, you will add components with different package styles, as shown in
Figure 3.  Sauna includes a library of over 150 packages, so a number of different component
types can be handled.
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Figure 3: Four layer board with multiple component types, modeled in 2nd half of exercise

You will surely notice that the components are not interconnected with traces.  For thermal
modeling, the first 10 or 15 mm of traces are most significant, particularly when working with
multilayer boards.  While it is certainly possible to connect all traces between components, it is
only really necessary when components are closely spaced.  (More on these effects later.)
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Creating a circuit board assembly

Before starting the exercise, make sure that the error beep on your computer is turned on (not muted).

You will begin by creating a circuit board assembly which represents the laminate (dielectric)
layer:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Board ➔ hit <Enter> to skip ➔ Rectangle
➔ Vertical XY ➔ "80,80" (do not type the quotes) ➔ .062"/1.57mm ➔ (0,0,0) ➔ FR4

You will reach the Copp Layers menu:

  COPP LAYERS
>1 Zer/Lam Only
 2 One
 3 Two
 4 Three
 5 Four
 6 Six
 7 Eight
 8 Enter Layers

Since you want to create a laminate only layer, you will be using "Zer/Lam Only", which stands
for "zero copper layer/laminate only".  The other selections are used with the planar board
modeling method, which is used for quick simulations.  Complete creation of the board
assembly with:

Zer/Lam Only ➔ .025"/0.64mm ➔ One oz. ➔ None

Sauna will create an array of node and resistors, framed by thick dashed lines which represent
the assembly limits.

Adding traces and pads

Begin creating the traces and pads with:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Board Side
➔ click dashed outline of board ➔ Component ➔ One oz. ➔ Library

You will reach the Library menu:

   LIBRARY
 1 DPAK's
 2 TDSON/TOLL
 3 Single/Dual
 4 Quad
 5 Diodes
 6 LED's
 7 Resistor

Sauna has over 200 different package styles in the library, so you do not need to define
individual rectangles for DPAK pads.  You just need to pick the component type and the
placement point.  To see an overview of the different library categories, click the Picture button
which is found just underneath the Library menu (to the right of the Menu Ref button):

click  Picture

A window will pop up showing the different package categories, as shown on the next page.
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DPAK TDSON/TOLL

Enhanced Source Types
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Figure 4: Package categories

Click the Done button to clear the picture, then continue with:

DPAK's ➔ DPAK ➔ 2 ➔ Same As Body ➔ Enter ➔ "24" (do not type the quotes)
➔ 0.50mm/20mil ➔ Yes ➔ 0 Degrees ➔ Coords/Trap ➔ "40,31.5" (do not type quotes)

The pads and traces will be created as shown in Figure 5, all with a single string of commands.

primary pad

reference
  point

X

Y

Figure 5: DPAK traces and pads

Note that there is a reference point at the center of the primary pad, which will be used to
position the heat source.

Adding the heat source

Now you are ready to add an "enhanced" heat source.  An enhanced heat source allows for heat
transfer through the heat slug, as well as through individual leads and the top of the
component.
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Begin with:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ DPAK's ➔ "1" ➔ "S1"
➔ DPAK ➔ 2 ➔ Typical

You will reach the R_Lead_Pad menu:

  R_LEAD_PAD
>1 Typ-1500 C/W
 2 Enter Resis
 3 Enter R_para
 4 No Lead Conn

The R_Lead_Pad menu is used to specify the resistance between the enhanced source junction
and the lead pads.  The problem with Rjunct-to-lead-pad is that it is generally not on the datasheet
and is rather difficult to obtain.  But Thermal Solutions has determined that 1500°C/W is a
reasonable typical value to use, primarily based on published data from Infineon and Amkor.

Finish creating the enhanced source:

Typ-1500 C/W ➔ Ref Point ➔ click reference point

The enhanced heat source will be created.  If you look closely at the screen, you will see that
there is an additional assembly.  This is the body assembly associated with the heat source.

To better see the body assembly, you will switch to a shaded perspective view.  For commonly
used commands, there are a series of buttons at the lower-left of the Sauna window.  The right
button in the top row is for switching to a perspective view.  Change the view with:

click  

Use the right button in the third row to activate shade mode:

click  

The screen will be as shown in Figure 6:
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Figure 6: Enhanced heat source with body assembly

Return to a front view and get an Info report for the heat source:

click  Front

<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ click red S1 source node
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The  report will be displayed on the screen.  On the second page of the report, a variety of
important information is provided.  For example, you can see that Rjc = 1.80°C/W and
Rjunct-to-top = 37.94°C/W.  The last section shows that there are two lead pad connections with
Rjunct-to-lead-pad = 1500°C/W.  Clear the report from the screen before continuing.

For best accuracy, you should align the mesh of nodes and resistors to the heat source.:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source
➔ 4 Node Conn ➔ click on red heat source node ➔ All In Wind ➔ USE

The node and resistor mesh will be regenerated to match the dimensions of the DPAK source.

Adding float resistors and a fixed node

At this point, you have defined the circuit board stackup and the heat input.  However, the
current model is invalid.  No heat flow path has been established between the circuit board and
the ambient temperature environment.  A "fixed temperature" node is required to represent the
room environment.  The name "fixed temperature" comes from the fact that ambient nodes have
temperatures which remain fixed throughout the temperature calculation.  You also need "float"
resistors to represent the convection and radiation.  These are called “float resistors” because
the resistance values are adjusted according to the ∆T and convection conditions.

Create the fixed node and float resistors:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd-›Fix ➔ "Room Amb"
➔ Enter Later ➔ Comp+Secdry ➔ All In Wind ➔ USE

The fixed node and float resistors will be created.  To better see the new nodes and resistors,
switch to a right view:

click  Right

The screen will be as shown in Figure 7:
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Figure 7: Fixed node and float resistors
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Now that the heat flow path to ambient has been created, you can reduce screen clutter by
making these nodes and resistors invisible.  There's a button for this:

click  

Return to a front view:

click  Front

Calculate temperatures with natural cooling:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain TS1-junction = 173.98°C.  Activate contours:

click  

With the temperatures contours turned on, you can clearly see that only the center of the board
is warm, so the outer parts of the board are not contributing much to the cooling of the
component.

What-if #1: shorter traces

In thermal modeling, there is a rule of thumb that states that traces longer than 25 mm (1 inch)
have no effect on cooling.  Based on the thermal contours, that rule seems valid, because the
ends of the traces are rather cool.  In this section, you will shorten the traces, as shown on the
left of Figure 2 on page 2.

It is easy to change trace length.  However, it will be necessary to delete the float resistors and
ambient nodes that you created earlier.  Sauna can do this automatically, provided that you
click the Yes button when modifying the trace length.

First, turn off the contours:

click  

Begin modifying trace length with:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Dimensions ➔ In Plane
➔ Modify Y ➔ Enter Delta ➔ "-14" ➔ End

You will reach a grouping menu.  Rather than clicking on each individual trace, you can define
a region to quickly select all three traces.  Figure 8 on the next page shows a typical grouping
rectangle.  The grouping rectangle does not need to be identical to Figure 8, just reasonably
close.  You will be digitizing two times to define the rectangle.  However, please note that with
Sauna digitize means “click and release”.  It’s not hold the mouse button down and drag.  With
that in mind, finish changing the trace length:

Select Regn ➔ digitize lower-left corner of grouping rectangle in Figure 8
➔ digitize upper-right corner of rectangle ➔ USE

➔ click Yes to accept delete of float resistors and ambients
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Figure 8: Grouping rectangle for modifying trace length

The traces will be shortened to match what-if #1 in Figure 2.  As before, add float resistors:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Enter Later
➔ Comp+Secdry ➔ All In Wind ➔ USE

click  

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

With the shorter traces, TS1-junct = 176.20°C, a fairly modest increase of 2.2°C.  In terms of the ∆T
above ambient, this is just a 1.5% increase.  So for practical thermal modeling, you can use
traces which are shorter than 25 mm and still obtain reasonably accurate results.

Use the Undo command to return the traces to the full length:

<F12 Root Menu> ➔ Edit ➔ Undo ➔ click Yes button to undo Amb + Float

Undo ➔ click Yes button to undo edit assembly dimensions

As before, you should see TS1-junct = 173.98°C.

What-if #2: using a 25 mm x 25 mm pad

In a moment, you will enlarge the primary pad, so that the model is as shown in Figure 9 on the
next page.  But before enlarging, it is interesting to obtain a board stackup report:

<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen
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The report will show that there is one copper layer, identified as "Copp>1", and one laminate
layer: "Lamin>1".  You can use these layer names to manipulate model visibility.  Click the
Done button to clear the report, then isolate the copper layer:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Copp>1

With this change, you will see just the DPAK pads and traces.  Now use the Reshape command
to resize the primary (large) pad:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Dimensions ➔ In Plane ➔ Reshape ➔ To Rectangle
➔ Ref/Dx-Dy-DZ ➔ click upper-left corner of primary pad ➔ "-9,18" ➔ Dx-Dy-Dz

➔ "25,-25" ➔ Vertical XY ➔ Select 1 ➔ click edge of primary pad ➔ USE
➔ click Yes to accept delete of float resistors

The pad will be enlarged.  Turn on the board and switch to shade mode:

click   ➔ click  

The model will be as shown in Figure 9:

25

25

X

Y

Figure 9: Model with 25 mm x 25 mm primary pad

Since you deleted the float resistors and ambients, these need to be recreated:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Enter Later
➔ Comp+Secdry ➔ All In Wind ➔ USE

click  

Recalculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain TS1-junct = 83.74°C.  With the large pads, temperatures are substantially
cooler.
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Comparing with published results

For the comparison with published data, you will need to calculate the junction-to-ambient
thermal resistance (Rja or θja or Rθ-ja).  The equation is Rja = (Tj - Tambient) / Q.  For the initial
calculation with the minimum pads, you obtained TS1-junct = 173.98°C, so Rja = (173.98 - 25.0) / 1
= 148.98°C/W.  For the 25 mm x 25 mm pads, TS1-junct = 83.74°C and Rja =  = 58.75°C/W.

Infineon Technologies has published a very useful document, "Thermal Resistance Theory and
Practice" (available at infineon.com), which provides quite a bit of useful thermal data,
including Rja for DPAK package devices with different size copper pads.  The thermal
resistance provided by Infineon is quite close to Sauna's simulated values.  For standard pads,
Rja-Sauna is within 3.5% of Rja-Infineon.  For the 25 x 25 pad, Rja-Sauna is within 7.4% of Rja-Infineon.  So
there is a good match with published data.

What-if #3: four layer board

While the analysis of a single layer board is certainly instructive, boards with four or more
copper layers are much more common.  You will be converting the single layer board to the
four layer configuration shown in Figure 10.  As you will see, Sauna can easily model these
types of boards.

S1

high via density (100 vias/in2)
under device, connects to
first internal plane

two internal planes,
1 oz. copper, minimal
backside copper

X

Y

Z

Figure 10: Four layer board

First, use the Undo command to restore the original pads:

<F12 Root Menu> ➔ Edit ➔ Undo ➔ click Yes button to undo Amb + Float

Undo ➔ click Yes button to undo reshape

click  

As before, you should see Tjunct = 173.98°C.
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Before converting to a multi-layer stackup, you will need to delete the float resistors:

click  

<F12 Root Menu> ➔ Delete ➔ Node ➔ Fixed ➔ All In Wind ➔ USE

Now you can use the Subdivide commands to create the stackup:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Subdivide ➔ Stackup ➔ Board ➔ Intern Layer
Two ➔ Uniform ➔ One oz. ➔ Typical ➔ All In Wind ➔ USE

The new circuit board layers will be created.  Get an Info report for the new stackup:

<F7 Info> ➔ Assemblies ➔ Brd Stackup ➔ All ➔ Current ➔ Screen

The  board stackup report shows 3 copper layers and 3 laminate (dielectric) layers.  You used
the "typical" option, so the laminate thicknesses are 0.396 mm, 0.711 mm and 0.396 mm
(.016"/.028"/.016").

Internal planes improve cooling, even when there are no thermal vias.  To see this, clear the
report, then add float resistors and calculate temperatures:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Enter Later
➔ Comp+Secdry ➔ All In Wind ➔ USE

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ “25”

You should obtain Tjunct = 66.94°C, a dramatic reduction.  Ground and power planes have an
important impact on cooling, even when there are no thermal vias.

Adding thermal vias

In a moment, you will modify the via density for the front laminate layer.  Of course, it's very
important that you modify the front laminate layer and not one of the other laminate layers .  So
you will start by isolating the front laminate layer.

Isolate the layer:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Lamin>1

With this visibility change, you will see only the front laminate board assembly and the DPAK.
All other laminate layers are turned off.  All copper pads and traces are also turned off.  To
verify, switch to a top view in shade mode.

click  Top  ➔ click  

The top view shows only the DPAK and the front laminate layer.  It is important to note that
Sauna links enhanced sources to the board assemblies, not to the traces and pads.  (If you delete
the front laminate layer, the DPAK will be deleted automatically.)

While you just saw that internal planes without vias can improve thermal performance, it's safe
to say that temperatures will be even cooler with vias underneath the heat source.
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Note that there is no need to delete float resistors when modifying vias.  You must delete the float
resistors whenever there is a change to the outer surface of the board stackup.  But vias are an
internal property of the laminate layers, so nothing changes on the outer surface.

Switch to wireframe mode and return to a front view:

click   ➔ click  Front

Activate the display of via density:

<F6 Setup> ➔ Display ➔ Node ➔ Via Density ➔ Vias/In2

You will see "0i", for 0 vias per inch2, displayed across the board.  Currently there are no vias.

Now you need to visualize the exact nodes to be modified.  Activate the outlining of diepads:

<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Enhan Diepad

With this change you will see a red rectangle which indicate the limits of the diepad.  For a
DPAK, the outline is the same as the overall part, as it is assumed that the copper slug is the
same size as the overall package (in reality, the slug is usually a bit smaller, but Sauna ignores
this).

Now you can easily change the via density to "High":

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Board Props ➔ Vias ➔ Density ➔ High (100)
➔ Node Group ➔ Select Regn ➔ click upper-left corner of red outline

➔ click lower-right corner of red outline ➔ USE

The via density will be changed to "100i" for the selected nodes.  Also, in the prompt zone at the
lower-left, Sauna indicates that "via density modified for 4 nodes".  If you make a mistake, use
Edit ➔ Undo and try again.

The via density change is complete.  Restore visibility and calculate temperatures:

<F6 Setup> ➔ Display ➔ Use Default

click  

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ “25”

With the vias, you should obtain Tjunct = 50.46°C, which is roughly 40% cooler than the no-via
model.

Activate temperature contours:

click  

With the contours, you can see that the internal planes do a much better job of distributing the
heat.  So instead of a small hotspot by the component, a larger section of the board is warm,
with a dramatic reduction in the peak temperature.
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Adding pads for the multi-component layout

In the remainder of the exercise you will add three components to achieve the layout shown in
Figure 11.  This will take around ten minutes.  The procedure for adding these components is
fairly similar to what you have done already.  So if your time is limited, you can stop here.
Otherwise, please continue on.

14 x 14 LQFP device,
3W, 8 x 8 heat slug,
X=60, Y=56

SOIC-16 device,
0.5W, X=20, Y=55

SOIC-16 device,
0.5W, X=16, Y=20

Existing DPAK
device, Q=1W

X

Y

Figure 11: Multi-component board

In Figure 11, notice that the components are not connected to each other through the traces.
As you saw earlier, traces which are longer than 10 mm have only a modest effect on cooling.  So it
follows that if the components are separated by more than 20 mm, there is only limited thermal
interaction.  Since all of the components in Figure 11 are separated by more than 20 mm, you do
not need to connect components for the purposes of a thermal simulation.  Obviously, it's a
different situation when the components are close together.  In this case, you would need to
connect at least some of the traces and pads.  Of course, Sauna can handle this, but there is
additional work involved.

Start by creating the traces for the lower SOIC-16 device:

<F12 Root Menu> ➔ Model ➔ Assembly ➔ Trace/Pad ➔ Trap Trc Pad
➔ click trace or pad on front layer ➔ Library ➔ Single/Dual ➔ SOIC Wide

➔ 16 ➔ Detailed ➔ 10 mm/0.4" ➔ No ➔ 0 Degrees ➔ Coords/Trap ➔ "16,20"
➔ click Yes to accept autodelete of float resistors

The pads will be created.  Next, you will create the pads for the upper SOIC-16 device.  This
device has flared leads and is rotated at 90 degrees.  Create the pads:

SOIC Wide ➔ 16 ➔ Detail/Flare ➔ 10 mm/0.4" ➔ No ➔ 90 Degrees
➔ Coords/Trap ➔ "20,55"

Pads for the upper SOIC device will be created.
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Now you will add pads for the quad flat pack (QFP) device.  This device has an 8 mm x 8 mm
heat slug.  You can create the pad for the heat slug at the same time as the other traces and
pads.  Enter:

<F2 Backup> ➔ Quad ➔ LQFP ➔ 14 x 14 ➔ 64 Leads ➔ Detail/Flare ➔ 10 mm/0.4"
➔ Yes ➔ "8,8" ➔ Coords/Trap ➔ "60,56"

The QFP pads will be created.  You are ready to add the components.

Adding the SOIC heat sources

The method for creating enhanced heat sources for dual and quad devices is similar to the
method for DPAK’s.  But there are some additional options to consider.

You will begin with the lower SOIC device:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ Single/Dual ➔ ".5" ➔ "S2"
➔ SOIC Wide ➔ 16 ➔ Middle

You will reach the Diepad Area menu:

  DIEPAD AREA
>1 Typical/36%
 2 Typical/25%
 3 Specify

With this menu you are specifying the area of the die attach pad (diepad).  The area of the
diepad has a definite effect on heat transfer to the top of the component, as well as downward
into the board.  Unfortunately, there is a good chance that this parameter is unavailable, as it's
almost never found on a datasheet.  You may be successful (maybe) if you ask the component
manufacturer, or you could cut open the part with a fine bladed saw.  But if you don't have this
information, just use the typical value (area of diepad is 36% of the component body area).

Continue with:

Typical/36% ➔ Typ (0.1 mm)

Once again, you will reach the R_Lead_Pad menu:

  R_LEAD_PAD
>1 Typ-1500 C/W
 2 Enter Resis
 3 Enter R_para
 4 No Lead Conn

Earlier in the exercise, you used "Typ-1500 C/W" with the DPAK.  You also saw that heat
transfer through the leads was not particularly significant.  However, for components
that do not have an external copper pad (heat slug), Rjunct-to-lead-pad is an important thermal
parameter.  The recommended approach is to obtain Rjunct-to-lead-pad by reverse engineering the
Rjunct-to-ambient (Rja, θja) from the component datasheet.  This is covered in detail in Intermediate
Exercise 3: More On Circuit Board Modeling (available at thermalsoftware.com/eval_exercises.htm).
Sauna has special tools for this task and it should only take a few minutes to obtain
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Rjunct-to-lead-pad.  For now, however, you will simply use the default of "Typ-1500 C/W" which
will provide a good first pass result.  Continue with:

Typ-1500 C/W ➔ Ref Point ➔ click red reference point for lower SOIC device

The component will be created and Sauna will indicate that "Enhanced heat source created,
16 lead connections".

It's interesting to get an Info report for the enhanced source:

<F7 Info> ➔ Trap ➔ Node ➔ Heat Source ➔ click S2 heat source

On the second page, under "-- Junction To Lead Pad Resistance --", there is information on the
number of lead pad connections and the resistance values, with Raverage-to-pad = 1500°C/W and
Rparallel-to-pad = 93.75°C/W.  This is important information to check.  (Although you have used
uniform Rjunct-to-lead-pad in this exercise, Sauna let's you use a different resistance for every lead pad,
an important feature for modeling components with heatsinking leads.)

Clear the Info report, then add the upper SOIC component:

<F12 Root Menu> ➔ Model ➔ Heat Input ➔ Enhanced Src ➔ Single/Dual ➔ ".5" ➔ "S3"
➔ SOIC Wide ➔ 16 ➔ Middle ➔ Typical/36% ➔ Typ (0.1 mm) ➔ Typ-1500 C/W

➔ Ref Point ➔ click reference point for upper SOIC device

The upper SOIC component will be created.

Adding the QFP with heat slug

Begin creating the QFP source:

Quad ➔ "3" ➔ "S4" ➔ LQFP ➔ 14 x 14 ➔ 64 Leads ➔ Heat Slug

You will reach the Diepad Area menu:

  DIEPAD AREA
>1 Use Brd Pad
 2 Typical/25%
 3 Typical/36%
 4 Specify

This Diepad Area menu is different from earlier in the exercise.  When modeling a heat slug
component, the diepad will usually have the same dimensions as the solder pad on the board.
Continue with:

Use Brd Pad ➔ Typical

You will reach the Gap To Board menu:
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  GAP TO BOARD
>1 Typ (0.1 mm)
 2 0.02mm/.001”
 3 0.05mm/.002”
 4 0.15mm/.006”
 5 0.20mm/.008”
 6 0.25mm/.010”
 7 0.50mm/.020”
 8 Enter

For the resistors to the heat slug pad, Sauna assumes a solder interface.  But there is also a
portion of the component with an air gap.  This menu is used to specify that air gap.  Finish
with:

Typ (0.1 mm) ➔ Typ-1500 C/W ➔ Ref Point ➔ click QFP ref point

The QFP heat source will be created.

Performing a preliminary calculation

You have placed all of the components.  However, you still need to add vias for the QFP.  But
this is a good time to perform a preliminary calculation.  First, add float resistors:

<F12 Root Menu> ➔ Model ➔ Amb + Float ➔ Isoltd->Fix ➔ "Room Amb" ➔ Enter Later
➔ Comp+Secdry ➔ All In Wind ➔ USE

click  

Now calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ “25”

You should obtain TS1-DPAK = 66.72°C, TS2-SOIC = 75.61°C, TS3-SOIC = 78.20°C and TS4-QFP =
115.80°C.

Aligning to the QFP and adding thermal vias

At the moment, the circuit board is aligned to the DPAK.  Since the QFP is dissipating 3W, and
is likely a more expensive component, it makes sense to align to this component.  (For aligning
and adding vias, there is no need to delete the float resistors because the outer surface of the
board stackup will not changed.)

Try aligning to the QFP:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source
➔ 4 Node Conn ➔ click S4-QFP heat source node ➔ All In Wind ➔ USE

It won't work.  An error screen will be displayed with the message "Lamin>1: non-uniform via
density".  Sauna is unable to realign a board with non-uniform properties.  The via density is
not uniform, due to the vias underneath the DPAK.
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You will need to set the via density to "none" for the entire board.  After clearing the error
screen, enter these commands:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Board Props ➔ Vias ➔ Density ➔ None
➔ Entire Board ➔ Group

As you have seen earlier, you can select an assembly by clicking an edge or using a grouping
rectangle.  But you can also select with an assembly label, which you will do now.  Complete
the modification with:

Select 1 ➔ type "Lamin>1" and hit <Enter> (do not type the quotes) ➔ USE

Sauna will indicate that "via density modified for 1 board".  Now you can realign to the QFP
source:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Remesh/Align ➔ Align ➔ Heat Source
➔ 4 Node Conn ➔ click S4-QFP heat source node ➔ All In Wind ➔ USE

The mesh for the board stackup will be regenerated.  As before, isolate the front laminate layer,
activate via display and show diepad outlines:

<F12 Root Menu> ➔ Visibility ➔ Isolate ➔ Layer ➔ Lamin>1

<F6 Setup> ➔ Display ➔ Node ➔ Via Density ➔ Vias/In2

<F6 Setup> ➔ Display ➔ Node ➔ Outlines ➔ Enhan Diepad

Now you can easily change the via density to "High" for both the QFP and DPAK:

<F12 Root Menu> ➔ Edit ➔ Assembly ➔ Board Props ➔ Vias
➔ Density ➔ High (100) ➔ Node Group

➔ Select Regn ➔ click upper-left corner of QFP red outline
➔ click lower-right corner of QFP red outline

➔ Select Regn ➔ click upper-left corner of DPAK red outline
➔ click lower-right corner of DPAK red outline ➔ USE

The via density will be changed to "100i" for the selected nodes.  Also, Sauna indicates that "via
density modified for 8 nodes".

Restore the display setup and visibility:

<F6 Setup> ➔ Display ➔ Use Default

click  

Calculate temperatures:

<F12 Root Menu> ➔ Analyze ➔ Calc Temps ➔ Steady ➔ Natural ➔ "25"

You should obtain TS1-DPAK = 70.56°C, TS2-SOIC = 75.96°C, TS3-SOIC = 79.15°C and TS4-QFP =
96.23°C.

This concludes Quick Tour #2.  You should delete the model:

<F12 Root Menu> ➔ Delete ➔ Everything ➔ click Yes button

There are four other Sauna Quick Tours, as described on the next two pages.
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Sauna Quick Tour #1: Heat Sinks, Duty Cycles And Stackup Models

In the first Sauna Quick Tour, you will model these configurations:

100

5

75

45

TO-220 package, 30W,
Rjc = 1.3˚C/W, greased interface

fins: 25 long, 10 centerline, 2 thick

150

Temperature vs. Time Plot
-------------------------

0.00 5.00 10.00
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Time (minutes)

Temp (˚C) S1 (junct)

S1 (case)

Heat sink with standard device Duty cycle transient

die attach
interface

silicon chip, q = 30W,
    10 x 10 x 0.5

copper flange,
25 x 25 x 0.5

Heat sink with custom stackups

Sauna Quick Tour #3: Basic Finned Box, Box With Board

With Sauna you can do a quick analysis of a box, or you can model in great detail (including
internal convection and gray radiation analysis with automatic view factor calculation).  These
boxes are modeled:

150

150

50

25

25

25

TO-218 package, 15W,
greased interface,
Rjc = 0.6˚C/W (typ. value)

box is zinc alloy 903,
4 mm wall thickness,
white paint surface,
top cover not shown

fins: 20 long, 10 centerline, 2 thick

dimensions in mmX

Y

Z

D2PAK package,
2 W, solder interface,
(120,11.6,-120), typ. Rjc

10

Four layer board, 140 x 140,
FR4, 1 oz. plating,
top/bott layers: 10% copper,
internal layers: full plane

14 x 14 LQFP, 2 watts,
100 leads, no heat slug,
Rja = 32˚C/W on 4 lyr brd,
(40,11.6,-40)

5 watts distributed
over 60 mm x 80 mm

Basic finned box Box with internal board
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Sauna Quick Tour #4: Modeling LED Boards

You can model boards with both low power and high power LED's.  Sauna's library includes 40
standard LED packages, covering a wide range of automotive, industrial and consumer lighting
applications (user-defined packages are also allowed).  It's easy to experiment with different
pad sizes, add or remove internal copper planes, test different via densities and simulate boards
which are bonded to heat sinks.

thermal pad

ceramic body

die
wire bond

cathode
anode

die
wire bond

copper
leads epoxy body

PLCC package

ceramic package

S1 S2

S3

OSLON
Square LED

aluminum heat sink

epoxy
interface

Multilayer board with high
power LED, heat sink

Sauna Quick Tour #5: Tubes and Cold Plates

Sauna is not just for air cooling.  You can also easily handle liquid cooling with water,
antifreeze mixtures, and more.  In the fifth Sauna Quick Tour, you will start with a simple tube
model.  Then you will model a full cold plate, including heat sources.

200

24

24

6061 aluminum

16 diam

100W heat load
 at top center

 

water cooling,
1 gallon/minute

Outer Diam = 16 mm
Inner Diam = 14 mm
Center = (12,12)

100

50

50

50

25 x 25 power module,
Q = 100 W, Rjc = 0.1˚C/W,
Rcs = 0.05˚C/W

water out

aluminum,
6061 T0

Tubes and cold plates with llquid cooling
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Wrapping up and disclaimers

You have just seen that Sauna can quickly model board stackups with a variety of component
types.  You can also quickly handle a variety of what-if modifications: changes in via density,
component placement, pad size, trace width, and more.  And, even with many advanced
features, Sauna is moderately priced and there is outstanding technical support.

Remember that the Sauna Quick Tours only provide an overview of Sauna's capabilities.
Important details have been omitted.  If you want to create accurate Sauna models, you must
work through the Introductory Exercises in the Sauna User Manuals.   Many of the exercises are
available online (www.thermalsoftware.com/eval_exercises.htm).  You can even work through the
exercises with the Sauna Evaluation Package.

Thank you for your interest in the Sauna thermal modeling package.  ◆
15 Jul 24


